Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Anmelden -> zurück zu Startseite
#21
Hast du Änderungen vorgenommen, die das Verursachen könnten? Ist der folgende Code so in der member.php (ab Zeile 925):
PHP-Code:
if($mybb->input['url'] != "" && strpos(basename($mybb->input['url']), 'member.php') === false)
{
    
// Redirect to the URL if it is not member.php
    
redirect(htmlentities($mybb->input['url']), $lang->redirect_loggedin);
}
else
{
    
redirect("index.php"$lang->redirect_loggedin);

Dass man beim Abmelden auf der Startseite landet ist normal. Beim Anmelden sollte man aber zu der Seite geleitet werden, die davor aufgerufen wurde.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#22
Die Zeile 925 und ff meiner member.php lauten:

PHP-Code:
if($mybb->input['url'] != "" && strpos(basename($mybb->input['url']), 'member.php') === false)
    {
        
// Redirect to the URL if it is not member.php
        
redirect(htmlentities($mybb->input['url']), $lang->redirect_loggedin);
    }
    else
    {
        
redirect("portal.php"$lang->redirect_loggedin);
    } 

Ausser, dass die Portalseite als Startseite dienen soll (mit der htaccess) und die Side-Boxes (Plugin) auf allen Seiten angezeigt werden (nach Anleitung von Dragon, betrifft aber nur die Templates des Plugins) wurde nichts geändert.
Danke & Gruss
Fatih
#23
Auch wenn das jetzt total dämlich klingt, eigentlich kann das nicht sein.
Richte uns bitte mal einen Testaccount ein. Welche Version benutzt du?
Vantage-Forum: http://vantage-forum.de/
#24
Mak schrieb:Auch wenn das jetzt total dämlich klingt, eigentlich kann das nicht sein.
Richte uns bitte mal einen Testaccount ein. Welche Version benutzt du?

Hi Mak,

habe das zwar im Profil stehen aber schreibe es gerne hier nieder 1.2.12.

Und zum Testaccount:

- An wen soll ich den richten und mit welchen Benuterrechten benötigst Du oder Ihr ihn?
Danke & Gruss
Fatih
#25
Hallo ich habe das selbe Problem, habe euer Forum durchsucht und bin nicht weitergekommen,
denke das es bei mir ma cookie liegt aber ich bekomme das Problem nicht in den griff!

also info:

http://www.r0di.de/forum
> is das board da funktioniert das alles problemlos.
http://www.gpz.de.gg
>is die haupturl wenn ich da drüber mich einloggen will
geht es nicht, lande immer wieder auf der Startseiteund hallo gast!
er fragt auch nich ober name und pw speichern soll

! .de.gg ist ne URL umleitung auf r0di.de/forum
#26
Du musst dich für eine Domain entscheiden und die Cookie-Einstellungen dementsprechend anpassen. Dann gibts auch keine Probleme mehr.

Siehe auch: https://www.mybb.de/doku/haeufig-gestell...elden.html

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#27
Cookie-Domain: .gpz.de.gg
Cookie-Pfad: /
habe ich & geht immernoch nicht!

Code:
$settings['bburl'] = "http://www.r0di.de/forum";
$settings['cookiedomain'] = ".gpz.de.gg";
$settings['cookiepath'] = "/";
$settings['homeurl'] = "http://www.gpz.de";?>

is da ein fehler drin?
#28
Also ich hab nach cloaking gesucht im forum habe dort herrausgefunden
cloaking aus so das orginal url angezeigt wird

dann habe ich cookie url auf
.r0di.de
und für cookie Path
/forum/
$settings['bburl'] = "http://www.r0di.de/forum";
$settings['homeurl'] = "http://www.r0di.de/forum";

geht immernoch nich -.-
#29
k4ub0y schrieb:Danke für die Antworten.

Also cookiePath = "/" ist gesetzt, aber wo muss ich die utf8_header.php hinladen?
Die config.php hab ich schon wie in https://www.mybb.de/69-0-UTF-8-Konvertierung.html beschrieben geändert.


Na fein. Habe auch ein Problem mit Usern (Kein aktualisierung der Beiträghe, beim Abmelden grunssätzlich die Meldung "Sie konnten nicht abgemeldet werde...Vielleicht hat ein böswilliges Javascript...".

Und dann stimmen die Links hier nicht...Obiger Link führt ins Nichts...
#30
@sensation: Siehe: https://www.mybb.de/doku/haeufig-gestell...elden.html
@helmut54: Zu der Meldung wirst du mit der Suche einiges finden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.