Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Archiv-Modus ohne Bilder
#1
Hallo,

wenn ich in den Archiv-Modus gehe werden mir Bilder mit einem roten-x ausgegeben da die links zu den Bilder nicht gefunden werden die ich in der Definition der Forennamen angegeben habe.

Ich habe z.B. den 1. Foren-Namen mit folgendem zusätzlichem html-code definiert:
Code:
<img border="0" src="images/flag_feedback.gif">   Neuigkeiten und Ankündigungen

bei diesem beispiel kann ich die bilder in den gesuchten verzeichnis-path (http://www.boersenportal.ch/forums/archive/images/) hinzufügen damit die Bilder angezeigt werden.

Sobald ich aber in ein Unter-Menu im Archive-Modus gehe werden mir die Bilder wiederum nicht angezeigt.
Der Link-path in dem die Bilder gesucht werden zeigt:
http://www.boersenportal.ch/forums/archi...hp/images/

Leider kann ich kein verzeichnis mit namen .../forums/archive/index.php/images/... erstellen.

Welche Lösung stehen mir zu Verfügung damit die Bilder im Archiv-Modus auch angezeigt werden.

Grüsse Salamander
#2
Gib im Admin-Cp einfach die Komplette URL zur Grafik an. Also anstatt
Code:
<img border="0" src="images/flag_feedback.gif">
sollte es heißen:
Code:
<img border="0" alt="" src="http://www.boersenportal.ch/forums/images/flag_feedback.gif" />

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Michael schrieb:Gib im Admin-Cp einfach die Komplette URL zur Grafik an. Also anstatt

Das habe ich bereits versucht.

Fazit:
Die Anzahl möglicher Zeichen im Forum-Name ist begrenzt.
Wenn du die kompleten URL + Forumname erfasst so wird der Forumname abgeschnitten weil nicht alle Daten gespeichert werden können.

- Kann der Attribut-Type für den Forenname in der MYBB_Tabelle nicht grösser gesetz werden (Zeichen-Länge) um das zu verhinern ?
- Welche Attribut-Typen müsste man abändern.
- Gibt es dadurch andere Probleme ?

Salamander
#4
Führe folgenden Query aus, um die mögliche Zeichenanzahl zu erhöhen:
Code:
ALTER TABLE `mybb_forums` CHANGE `name` `name` VARCHAR(250);

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Super...es hat geklappt
vielen dank

Gruss Salamander


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [MyBB 1.2.x] Archiv Modus zeigt die einzelnen Foren nicht an ! Plexxart 6 1.950 01.11.2008, 16:35
Letzter Beitrag: Plexxart
  Archiv-Modus Dieter 13 2.321 13.06.2008, 12:37
Letzter Beitrag: Michael
Question Foren ansehen im Archiv Modus tortisoft 13 2.799 17.06.2007, 20:52
Letzter Beitrag: P25
  Umlaute im Archiv-Modus falsch dargestellt GrosserBlonder 3 1.405 07.06.2007, 09:09
Letzter Beitrag: GrosserBlonder
  Archiv-Modus funktiert nicht Georg 7 1.657 07.09.2006, 19:59
Letzter Beitrag: Georg