Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Loginproblem beim Zurücksetzen von Templates
#11
Ich habe jetzt folgende Änderungen am template.php vorgenommen:

1. Setzen einer Variablen $str_group = ""
2. Abfrage, ob $grouptype wirklich einen Wert hat
3. den kompletten Parameter als $str_group dranhängen

PHP-Code:
        $str_group "";
                if(
$grouptype)
                {                    
                    if (
$grouptype != "") {$str_group "&group=$grouptype";}
                    echo 
"<tr>\n";
                    echo 
"<td class=\"$altbg\" width=\"10\">&nbsp;</td>\n";
                    echo 
"<td class=\"$altbg\">";
                }
                else
                {
                    echo 
"<tr>\n";
                    echo 
"<td class=\"$altbg\" colspan=\"2\">\n";
                }
                if(!
$template['tid'])
                {
                    echo 
"<a href=\"templates.php?".SID."&amp;action=add&amp;title=".$template['originaltitle']."&amp;sid=".$set['sid'].$opengroup."\"><span class=\"highlight4\">".$template['originaltitle']."</span></a></td>\n";
                    echo 
"<td class=\"$altbg\" align=\"right\">";
                    echo 
"<input type=\"button\" value=\"$lang->change_original\" onclick=\"hopto('templates.php?".SID."&amp;action=add&amp;title=".$template['originaltitle']."&amp;sid=".$set['sid'].$str_group."');\" class=\"submitbutton\" />";
                    echo 
"</td>\n";
                    echo 
"</tr>\n";
                }
                elseif(
$template['customtemplate'])
                {
                        echo 
"<a href=\"templates.php?".SID."&amp;action=edit&amp;tid=".$template['tid'].$opengroup."\"><span class=\"highlight2\">".$template['title']."</span></a></td>";
                        echo 
"<td class=\"$altbg\" align=\"right\">";
                        echo 
"<input type=\"button\" value=\"$lang->edit\" onclick=\"hopto('templates.php?".SID."&amp;action=edit&amp;tid=".$template['tid'].$str_group."');\" class=\"submitbutton\" />";
                        echo 
"<input type=\"button\" value=\"$lang->delete\" onclick=\"hopto('templates.php?".SID."&amp;action=delete&amp;tid=".$template['tid']."&amp;expand=$expand".$str_group."');\" class=\"submitbutton\" />";
                        echo 
"</td>\n";
                        echo 
"</tr>\n";
                }
                else
                {
                    echo 
"<a href=\"templates.php?".SID."&amp;action=edit&amp;tid=".$template['tid'].$opengroup."\"><span class=\"highlight3\">".$template['originaltitle']."</span></a></td>";
                    echo 
"<td class=\"$altbg\" align=\"right\">";
                    echo 
"<input type=\"button\" value=\"$lang->edit\" onclick=\"hopto('templates.php?".SID."&amp;action=edit&amp;tid=".$template['tid'].$str_group."');\" class=\"submitbutton\" />";
                    if(
$expand == 1)
                    {
                        echo 
"<input type=\"button\" value=\"$lang->diff\" onclick=\"hopto('templates.php?".SID."&amp;action=diff&amp;title=".$template['originaltitle']."&amp;sid2=$expand');\" class=\"submitbutton\" />";
                    }
                    echo 
"<input type=\"button\" value=\"$lang->revert_original\" onclick=\"hopto('templates.php?".SID."&amp;action=revert&amp;tid=".$template['tid']."&amp;expand=$expand".$str_group."');\" class=\"submitbutton\" />";
                    echo 
"</td>\n";
                    echo 
"</tr>\n";
                }
                
$grouptype ""
#12
Rotti schrieb:p.s habe den dazu passenden Bug gefunden:
http://bugs.php.net/bug.php?id=28585&edit=1

was kann ich tun, wenn der Provider nicht updatet? Sad
Der Bug-Report ist von 2004 und betrifft PHP-Version 4.3.6. Hier wäre ein Update generell dringend erforderlich. Wenn der Provider das nicht macht solltest du erwägen den Hoster zu wechseln.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#13
ne geht nicht, Provider ist ein Bekannter und daher der Server kostenlos ^^ Da müssten dann schon noch härtere Gründe her Wink
PHP Version ist übrigens 4.3.11, da ist der Bug auch noch drin.

trotzdem danke für die Unterstützung.
Rotti