Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Install von Coppermine für mybb
#1
Könnte mir jemand helfen bei der Coppermine-Installation ? Beim ersten ausführen der install.php hatte ich die Fehlermeldung: Benutzername und Passwort nicht "alphanumerisch". Nach Korrigieren dessen, hatte ich plötzlich folgende Fehlermeldungen:
---------------------------------------------
The following errors were encountered and need to be corrected first:

mySQL Error: Table 'cpg1410_albums' already exists on query ' CREATE TABLE cpg1410_albums ( aid int(11) NOT NULL auto_increment, title varchar(255) NOT NULL default '', description text NOT NULL, visibility int(11) NOT NULL default '0', uploads enum('YES','NO') NOT NULL default 'NO', comments enum('YES','NO') NOT NULL default 'YES', votes enum('YES','NO') NOT NULL default 'YES', pos int(11) NOT NULL default '0', category int(11) NOT NULL default '0', thumb int(11) NOT NULL default '0', keyword VARCHAR( 50 ), alb_password VARCHAR( 32 ), alb_password_hint TEXT, PRIMARY KEY (aid), KEY alb_category (category) ) TYPE=MyISAM COMMENT='Used to store albums''
----------------------------------------------

Ich ersuche um Hilfe !

mfg Stoffbaer65
Zitieren
#2
Lösche die Tabellen der Galerie aus der Datenbank und versuche es erneut. Das Skript versucht die Tabelle cpg1410_albums anzulegen, diese existiert aber bereits.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Hallo Michael !
Erstmal vielen Dank für Deine schnelle Antwort ! Bei mir beisst sich aber anscheinend die berühmte Katze selbst in den Schwanz. Wenn ich die Tabellen lösche ist das Problem gelöst, dafür kommt folgende Error-Meldung:
----------------------------------------------------------------------------------------------------
• • • ERROR • • •
Before you continue with Coppermine installation, there are some problems that need to be fixed.

A subdirectory called 'albums' should normally exist in the directory where you uploaded Coppermine. The installer can't find this directory. Check that you have uploaded all Coppermine files to your server.

A subdirectory called 'userpics' should normally exist in the 'albums' directory. The installer can't find this directory. Check that you have uploaded all Coppermine files to your server.

A subdirectory called 'edit' should normally exist in the 'albums' directory. The installer can't find this directory. Check that you have uploaded all Coppermine files to your server.

Once you are done, hit the "Try again" button.

-----------------------------------------------------------------------------------------------------
Füge ich die Tabellen wieder ein, beziehungsweise lade ich die Dateien wieder neu per FTP hoch kommt wieder die erste Error-Meldung vom vorigen Posting.

mfg Stoffbaer65
Zitieren
#4
In der Fehlermeldung steht, dass folgende Ordner innerhalb des Galerieordners fehlen:
  • albums
  • albums/userpics/
  • albums/edit/

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Hallo,

hast du eigentlich auch die Rechte auf 777 gesetzt?

Auszug aus der Coppermine Installationsankleitung:

Zitat:Installation und Setup

Vorgehensweise

Entpacken Sie zunächst das Programmpaket unter Beibehaltung der Directory-Struktur

Sie haben Freiheit bei der Vergabe des Verzeichnisnamens, in welchem Sie Coppermine installieren wollen. Es versteht sich aber von selbst, dass sowohl Datei- als auch Verzeichnamen des Coppermine-Paketes nicht verändert werden dürfen.

Laden Sie nun per FTP alle Dateien in Ihr Coppermine-Verzeichnis auf dem Server

Wenn Sie eines der gängigen FTP-Programme benutzen, brauchen Sie in aller Regel keine weiteren Einstellungen bezüglich des Modus vorzunehmen. Belassen Sie die Einstellung bei „Auto“

Bevor Sie nun mit der eigentlichen Installation beginnen, sind noch ein paar Vorbereitungen notwendig.

Setzen Sie mit Ihrem FTP-Programm folgende Rechte:

* Verzeichnis /include auf 777
* Verzeichnis /albums 777
* Verzeichnis /albums/edit auf 777
* Verzeichnis /albums/userpics auf 777


Legen Sie ferner noch ein Verzeichnis „/albums/uploads“ an und setzen Sie die Rechte hier auch auf 777

Der Name ist wahlfrei. Der Vorteil: Sie verfügen bereits jetzt über ein Verzeichnis, welches Sie für das Hochladen im Batch-Betrieb später ohnehin benötigen.

MfG

Hufi
Zitieren
#6
Tja, was soll ich sagen Sad

.) Ordner im Galerieordner angelegt (bei mir cpg1410)

.) Rechte gesetzt (777)

habe auch bei einem meiner Versuche den /albums/uploads Ordner (mit 777-Rechten) angelegt kein Erfolg, selbe Fehlermeldungen Sad

anbei Screenshot`s meines FTP-Programms:

   
   
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Coppermine Galerie-Fotos in MyBB-Postings anzeigen Cid 2 1.782 06.05.2010, 07:40
Letzter Beitrag: Cid
  Coppermine 1.4..25 Bridge zu MyBB 1.4.9 bilderload 14 3.007 19.11.2009, 23:00
Letzter Beitrag: Michael
  Coppermine Bridge zu MyBB Jogi79 14 5.130 12.09.2009, 10:10
Letzter Beitrag: linwinman
Question Coppermine-MyBB mit eigenen Benutzergruppen-Rechten Bernd S. 3 1.151 08.05.2009, 11:14
Letzter Beitrag: gastwirt
  coppermine 1.4.10 und mybb svenkaiser 7 1.280 23.01.2007, 15:12
Letzter Beitrag: Mak