Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Bild-Fehler im oberen Menü
#1
Nun ich habe ein Problem im oberen Menü, das kann man schlecht erklären, aber das Bild sagt alles aus. die bilder sind an der richtigen Stelle, nur der Text dazu ist um viele px nach rechts verschoben.
Dieser Fehler tritt im IE auf, Opera/FF zeigt alles perfekt an. Ich hab keine Anhnung wie ich das lösen soll-
Ich verwende den ganz normalen Code im header:
Code:
<div id="header">
    <!-- {$easybanner} -->
            <div class="menu">
                       <ul>
                                       <li><a href="{$mybb->settings['bburl']}/rules.php"><img src="{$theme['imgdir']}/toplinks/rules.gif" alt="" />{$lang->toplinks_rules}</a></li>
<li>
<a href="{$mybb->settings['bburl']}/portal.php"><img src="{$theme['imgdir']}/toplinks/portal.gif" alt="" />Portal</a></li>
<li>
im Theme oberes Menü:
Code:
text-align: left;
padding:4px;
padding-top:0px;


Angehängte Dateien Thumbnail(s)
   
Keinen Support per PN, eMail und Messenger
computerhartware.de
GIGA - Spielen geht immer!
Zitieren
#2
Da muss noch mehr CSS vorhanden sein. Poste mal alles für menu, menu ul, menu li und ggf. menu img
Vantage-Forum: http://vantage-forum.de/
Zitieren
#3
Normale Menü-Tabelle hab ich oben schon gepostet.
Code:
.menu ul {
        list-style: none;
        margin-top:-1px;
        text-align:left;
}

.menu li {
    display: inline;
    padding-left: 5px;
}

.menu img {
    padding-right: 5px;
    vertical-align: top;
}
Keinen Support per PN, eMail und Messenger
computerhartware.de
GIGA - Spielen geht immer!
Zitieren
#4
Nimm mal das padding-left beim li und das padding-right beim img oder nur eins von beiden raus. Wenn das nicht klappt, bitte nochmal einen Screenshot, wie es dann aussieht.
Vantage-Forum: http://vantage-forum.de/
Zitieren
#5
Keine Veränderung am Screenshot auch wenn ich beide oder nur eins davon entferne.Shy:question:
Keinen Support per PN, eMail und Messenger
computerhartware.de
GIGA - Spielen geht immer!
Zitieren
#6
Also da müsste zumindest eine Änderung sichtbar sein... Guck dir bitte das mal an und entfern erstmal alle Fehler aus dem HTML: http://validator.w3.org/check?verbose=1&...npic.de%2F
Vantage-Forum: http://vantage-forum.de/
Zitieren
#7
Wenns nur diese Fehler wären MakRolleyes
Aber das Problem tritt in einem anderem Forum auf. Ich könnte darauf schlie0en, das es mit den komischen Bild <img>-Tags zusammen hängt. Quelltext wird bei der Vali mit angezeigt:
http://www.validome.org/validate/?uri=http://gamerstrix.ga.funpic.de/klasse/forum&extended=
1&viewSource=1&userAgent=Mozilla/4.0%20%28compatible%3b%20MSIE%206.0%3b%20Windows%20NT%205.
1%29
Keinen Support per PN, eMail und Messenger
computerhartware.de
GIGA - Spielen geht immer!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Frage zur der FAQ "Wie kann ich einen Link im oberen Menü ergänzen?" Riccardo 10 1.835 24.06.2009, 23:49
Letzter Beitrag: Riccardo
  Links im oberen Menü nach links verschieben und anders Färben! KungFuMarc 1 1.123 05.08.2008, 20:01
Letzter Beitrag: krafdi
  Neue Links im oberen Menü alexking 5 1.079 28.12.2007, 20:23
Letzter Beitrag: alexking
  Box5: Oberes Menü auch Hintergruund Bild stadt Farbe? Aki 8 1.346 16.12.2007, 15:39
Letzter Beitrag: krafdi
  wie ändere ich die schrift im oberen menü? aman 3 969 02.10.2007, 10:35
Letzter Beitrag: Michael