Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Photoshop "Slices" logo.html
#1
Hallo zusammen

Ich habe mit Photoshop 6 ein Banner erstellt und mit dem Werkzeug "Slices" in das Banner zwei Links eingefügt. Danach mit "Für Web speichern" das Banner abgespeichert.
Alles soweit gut jetzt habe ich eine logo.html Datei wenn ich die starte greift die logo.html auf die Banner Bilder zu und setzt die Bilder zusammen, daraus entsteht ein Banner mit den darin enthaltenen Links.

logo.html Code:
Code:
<HTML>
<HEAD>
<TITLE>Ohne Titel-1</TITLE>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
</HEAD>
<BODY BGCOLOR=#FFFFFF>
<!-- ImageReady Slices (Ohne Titel-1) -->
<TABLE WIDTH=978 BORDER=0 CELLPADDING=0 CELLSPACING=0>
    <TR>
        <TD ROWSPAN=2>
            <A HREF="http://www.pc-tips.ch"
                ONMOUSEOVER="window.status='Home';  return true;"
                ONMOUSEOUT="window.status='';  return true;">
                <IMG SRC="images/logo_01.gif" WIDTH=351 HEIGHT=77 BORDER=0 ALT="PC-Tips Forum"></A></TD>
        <TD>
            <A HREF="http://www.nateltreff.ch"
                ONMOUSEOVER="window.status='Das ist ein Test';  return true;"
                ONMOUSEOUT="window.status='';  return true;">
                <IMG SRC="images/logo_02.gif" WIDTH=564 HEIGHT=73 BORDER=0 ALT="Shop"></A></TD>
        <TD ROWSPAN=2>
            <IMG SRC="images/logo_03.gif" WIDTH=63 HEIGHT=77></TD>
    </TR>
    <TR>
        <TD>
            <IMG SRC="images/logo_04.gif" WIDTH=564 HEIGHT=4></TD>
    </TR>
</TABLE>
<!-- End ImageReady Slices -->
</BODY>
</HTML>

Nun habe ich im AdminCP --> Themes --> Ändern --> Mein Themes --> Forum Logo, den Pfad zur logo.html hineingeschrieben. In der Hoffnung das dass Banner im Forum angezeit wird, aber leider wird das Banner nicht gefunden.

Muss ich die ganze Sache anderst angehen, wieso funktioniert das nicht mit der logo.html, muss evt. im AndminCP die "header" unter Themplates abgeändert werden damit es funktioniert.

Evt. die untenstehende Zeile im header abgeändert werden damit es geht:
Code:
<div class="logo" align="left"><a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" /></a></div>

Wer kann mir da weiterhelfen???
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#2
Versuche mal folgendes. Ersetze im Template header diesen Code:
Code:
<a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" /></a>
Durch diesen:
Code:
<!-- ImageReady Slices (Ohne Titel-1) -->
<TABLE WIDTH=978 BORDER=0 CELLPADDING=0 CELLSPACING=0>
<TR>
<TD ROWSPAN=2>
<A HREF="http://www.pc-tips.ch"
ONMOUSEOVER="window.status='Home';  return true;"
ONMOUSEOUT="window.status='';  return true;">
<IMG SRC="images/logo_01.gif" WIDTH=351 HEIGHT=77 BORDER=0 ALT="PC-Tips Forum"></A></TD>
<TD>
<A HREF="http://www.nateltreff.ch"
ONMOUSEOVER="window.status='Das ist ein Test';  return true;"
ONMOUSEOUT="window.status='';  return true;">
<IMG SRC="images/logo_02.gif" WIDTH=564 HEIGHT=73 BORDER=0 ALT="Shop"></A></TD>
<TD ROWSPAN=2>
<IMG SRC="images/logo_03.gif" WIDTH=63 HEIGHT=77></TD>
</TR>
<TR>
<TD>
<IMG SRC="images/logo_04.gif" WIDTH=564 HEIGHT=4></TD>
</TR>
</TABLE>
<!-- End ImageReady Slices -->

[edit]Das das mit dem Eintragen beim Theme hat nicht funktioniert, weil du da nur den Dateinamen und Pfad eines Bildes eintragen kannst.
Eine Homepage ist nie fertig, man hört nur auf an ihr zu arbeiten - Unbekannter Verfasser
Zitieren
#3
Danke frankrieger

Jetzt funktioniert alles.
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#4
Da ich nicht weiß ob es wünschenswert ist, dass ich ein neues Thema erstelle, führe ich einfach diesen Thread weiter. MyBBoard.de soll ja schliesslich übersichtlich bleiben.

Der oben genannte Lösungweg ist nur für solche Foren gedacht,
die nur 1 Design haben.

Frage:
Ich habe jedoch 2 Themes die allesamt das gleiche Template benutzen.
Nun wie kriege ich es hin, 2 verschiedene Imagesmaps zu benutzen ?

Ich könnte mir vorstellen dass man folgendes umwandelt.
PHP-Code:
ANSTATT: <IMG SRC="images/logo_01.gif" alt="muster" /> 
PHP-Code:
DIESES: <img src="{$theme['logo_01']}alt="{$mybb->settings['bbname']}/> 

PHP-Code:
ANSTATT: <IMG SRC="images/logo_02.gif" alt="muster" /> 
PHP-Code:
DIESES: <img src="{$theme['logo_02']}alt="{$mybb->settings['bbname']}/> 

usw.

Was ist das in dem folgendem Code Schnipsel ?:
PHP-Code:
{$theme['logo']} 
,
Ist das 'logo' in einer CSS Datei untergeordnet ?
Müsste ich dann in der CSS .logo_01 , .logo_02, .logo_03, usw. anlegen ?
MyBB ist die weltbeste Forensoftware u. 1000 mal besser als VB, WBB und phpBB !

Seit Sommer 2006 setze ich auf MyBB.
Zitieren
#5
$theme['logo'] gibt den Pfad zum Logo aus, der in den Einstellungen des Themes angegeben wurde. Warum benutzt du nicht einfach zwei Templatesets?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Forum Logo fest machen, bzw das man das Logo nicht Kopieren oder klauen kann?=/ BattlieldAD 44 3.159 07.06.2014, 15:07
Letzter Beitrag: MrBrechreiz
  Photoshop Bliss v3 theme BetaTrez 2 303 03.05.2014, 00:48
Letzter Beitrag: BetaTrez
Question Logo links + Logo rechts press 45 7.463 28.01.2014, 15:49
Letzter Beitrag: MrBrechreiz
  Vorlage Grafiken (Gimp, Photoshop)??? GrinGEO 3 1.015 10.07.2006, 12:56
Letzter Beitrag: Michael
  [Erledigt]Logo NAVIGATION Logo Jan 4 1.352 01.04.2006, 07:37
Letzter Beitrag: Jan