Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler bei Update der Optionen im Benutzer-CP
#1
Hallo Leute!

Normalerweise versuche ich alle meine Probleme (meist selbst verursacht) selbst wieder in den Griff zu bekommen. Meine Devise = learning by doing.
Als Hilfestellung benutze ich sehr gerne euer Forum und die Dokumentationen.
Nach einem erfolgreichen Forenupdate von 1.1.5 auf 1.2.1 ohne Fehlermeldung stehe ich nun vor einem Problem.


Mein Problem Nr.1: Jeder User erhält beim anmelden, nach der Mitteilung dass die Anmeldung erfolgreich war, folgende Fehlermeldung


Fatal error: Cannot redeclare user_exists() (previously declared in /homepages/32/d148086833/htdocs/forum/inc/functions_user.php:9) in /homepages/32/d148086833/htdocs/forum/inc/functions_user.php on line 9

Wenn ich nun den Browser aktualisiere ist man ganz normal eingeloggt und das Forum funktioniert soweit normal.
Jetzt kommt -->

Mein Problem Nr2.
Also, ich versuche zum Beispiel als eingeloggter Benutzer in meinem Benutzer-CP die Datums- oder Uhrzeiteinstellung zu verändern. Sobald ich auf Update klicke erscheint folgende Fehlermeldung:

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /homepages/32/d148086833/htdocs/forum/inc/functions.php on line 671

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /homepages/32/d148086833/htdocs/forum/inc/functions.php on line 682


Auch ein löschen der temp. Internetdateien, Cookies und ein erneutes Einloggen führte bei beidem nicht zur Problemlösung.

Bin für jede Hilfe von euch dankbar.

Grüsse Zac
#2
Hallo zac mc cracken,
Hast du noch irgendwelche Plugins installiert, die aktiviert sind?

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#3
ja, es sind folgende Plugins installiert und aktiviert:

Ein Account pro E-Mail-Adresse v.1.0;
PN Papierkorb leeren v.1.0;
Quick Language v.1.1;
Willkommens-Panel [Index] v.1.0

die ersten 3 der Plugins habe ich gestern zusätzlich installiert. auf deine frage hin, habe ich diese deaktivert und die angegebenen fehler sind verschwunden! wahrscheinlich verträgt die Pluginversion sich nicht mit der version vom mybb-board. werde jetzt nochmal genau nachschauen, und bei inkompatibilität lasse ich die plugins deaktiert.

Danke für die schnelle Hilfe!

Grüsse vom Zac
#4
Hallo zac mc cracken,
Die Plugins aus mybb 1.1.x sind mit mybb 1.2 inkompatibel. Es stehen allerdings in den meisten Fällen neue kompatible Versionen zur Verfügung.
Hier solltest du fündig werden: http://community.mybboard.net/forumdisplay.php?fid=28

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#5
Danke für den Link!

sind nette plugins dabei!

gruss zac
#6
Hi, zac mc cracken!

Das Plugin "Ein Account pro E-Mail-Adresse" wurde noch nicht für die neue Version von MyBB angepasst. Ich hab das mal provisorisch gemacht. (siehe Anhang)

Ich hoffe ja noch, dass es irgendwann in die Standardfunktionen des MyBB aufgenommen wird.

LG, GM!


Angehängte Dateien
.php   preventusedemail.php (Größe: 1,92 KB / Downloads: 0)
Wer eine Wahrheit verbergen will, braucht sie nur offen auszusprechen - sie wird einem ja doch nicht geglaubt.
(Charles Talleyrand)


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Question Optionen der Umfragen Sven4972 4 618 02.12.2007, 12:13
Letzter Beitrag: Sven4972
  Benutzer-CP Optionen ändern Qi Bo 1 996 31.08.2007, 08:12
Letzter Beitrag: StefanT
  Klick auf Optionen im Benutzer CP Crasher 10 1.485 02.10.2006, 09:22
Letzter Beitrag: Crasher