Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.38 veröffentlicht (30.04.24)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Weiße Seite nach Umstellung auf PHP8
#21
wenn ich nach dem ersten Teil der Fehlermeldung im weltweiten Netz suche, finde ich diverse Hinweise auf Probleme mit PHP selbst, als wäre etwas nicht richtig konfiguriert.

Aber da ich von Server keine Ahnung habe, halte ich die Fresse, denn das sollte man immer tun, wenn man keine Ahnung hat
Kein Support per PN, Mail, Telefon, Hausbesuch, Discord, Telegram, WhatsApp und anderen nutzlosen Tools
Zitieren
#22
Guten Abend!

Ich habe mein Board wieder auf PHP 5.6 gestellt, damit meine Spieler darauf zugreifen können, deshalb sieht alles ganz normal aus Wink

Ich habe vorhin noch einmal auf PHP 8 gestellt und mir statt dem Error-Log das PHP-Error-Log herunter geladen. Vielleicht wird man daraus schlauer:

Code:
[04-May-2024 19:31:39 Europe/Berlin] PHP Fatal error:  Uncaught Error: Undefined constant "subject" in /home/web7sun88/html/Schattenharz/inc/plugins/inplaytracker.php:1278
Stack trace:
#0 /home/web7sun88/html/Schattenharz/inc/class_plugins.php(142): inplaytracker_global('')
#1 /home/web7sun88/html/Schattenharz/global.php(498): pluginSystem->run_hooks(Array)
#2 /home/web7sun88/html/Schattenharz/index.php(18): require_once('/home/web7sun88...')
#3 {main}
  thrown in /home/web7sun88/html/Schattenharz/inc/plugins/inplaytracker.php on line 1278


.php   class_plugins.php (Größe: 5,97 KB / Downloads: 0)
.php   global.php (Größe: 37,65 KB / Downloads: 0)
.php   index.php (Größe: 13,54 KB / Downloads: 0)
.php   inplaytracker.php (Größe: 61,1 KB / Downloads: 1)

Die betreffenden Dateien habe ich angehängt Wink
Liebe Grüße
Banshee
Zitieren
#23
es betrifft aber nur eine davon, die inplaytracker.php

versuch mal Zeile 1278 zu ändern:
$test .= $szene['subject'];

um nicht ständig dein laufendes Forum abzuschießen, empfehle ich dir eine Kopie deines Forums aufzusetzen und daran dann unter PHP8 zu arbeiten, bis alles funktioniert
Kein Support per PN, Mail, Telefon, Hausbesuch, Discord, Telegram, WhatsApp und anderen nutzlosen Tools
Zitieren
#24
Guten Abend und vielen lieben Dank für deine Antwort!

Und weiter geht es. Big Grin 

Ich habe die betreffende Zeile geändert und schon kommt der nächste Fehler. Aber mühsam ernährt sich das Eichhörnchen, irgendwann haben wir es! Smile 

Code:
thrown in /home/web7sun88/html/Schattenharz/inc/plugins/inplayquotes.php on line 476
[05-May-2024 19:18:44 Europe/Berlin] PHP Fatal error:  Uncaught Error: Undefined constant "tid" in /home/web7sun88/html/Schattenharz/inc/plugins/inplayquotes.php:476
Stack trace:
#0 /home/web7sun88/html/Schattenharz/inc/class_plugins.php(142): inplayquotes_index('')
#1 /home/web7sun88/html/Schattenharz/index.php(32): pluginSystem->run_hooks(Array)
#2 {main}

Das wäre die Meldung und  die dazu gehörige Datei hänge ich wieder an.




.php   inplayquotes.php (Größe: 16,15 KB / Downloads: 2)

Ich habe übrigens ein Spiegelboard, auf dem ich erst einmal die Versionsanpassung von mybb durchgespielt habe. Leider habe ich nur eine Domain und beide Boards laufen auf dieser. Ich kann die PHP-Version aber nur für die Domain ändern, nicht für die einzelnen Datenbanken.

Liebe Grüße
Die Banshee
Zitieren
#25
ich hatte es geahnt, als ich nur einen Blick quer drüber warf

überall, wo er so etwas mit constant meldet, setzt du das in Anführungsstriche
also banshee zu 'banshee'
Kein Support per PN, Mail, Telefon, Hausbesuch, Discord, Telegram, WhatsApp und anderen nutzlosen Tools
Zitieren
#26
jetzt seh ich erst, dass das ja wieder eine andere php-Datei ist, na egal, gilt das gleiche

Und gut, wenn du ein Spiegeluniversum hast, aber schon blöde, wenn man da nicht die PHP-Version separat schalten kann. Eine zweite Domain kostet aber auch nicht die Welt Wink Ich hab mir eine zugelegt, die ich nur für Testsachen brauche, damit umgeht man auch Cookie-Probleme
Kein Support per PN, Mail, Telefon, Hausbesuch, Discord, Telegram, WhatsApp und anderen nutzlosen Tools
Zitieren
#27
Guten Morgen Banshee,

du kannst dir für das Spiegelboard auch eine lokale Umgebung einrichten, dass wurde dir auch schon ans Herz gelegt. Auf jeden Fall im Epic gibt es auch ein Tutorial zu Xampp. (Im SG habe ich jetzt nicht nachgeschaut)

Du findest im SG auch im Tutorial Bereich von MyBB bei den wichtigen Thema auch das Theme "Fehler und Warnungen: php8", was dir auch helfen kann bei deinen Problemen. Du wirst bei einigen Plugins auf Fehler und Warnungen stoßen, da nicht alle auf php8 geupdatet sind oder werden.
Für die zwei Fehler die du gepostest hast, gibt es sogar eine Erklärung im SG im MyBB Bereich "[Basic] Problemsammlung & erste Hilfe" unter dem Punkt "Fehlermeldung: Error in a future Vision of PHP". Da diese Fehler bei den Plugins schon unter php7 auftauchte und man es fixen musste.

Gerade bei den gängigen RPG Plugins könnte es eher vom Vorteil sein in den RPG Community Boards nachzufragen, weil dort die Chance größer ist, dass es schon jemand für sich gefixt hat.
(Was nicht bedeutet, dass ich hier jemand die Fähigkeit absprechen möchte das zu können. Nur kennt die RPG Community die Plugins auf jeden Fall.)

LG
Lara
Zitieren
#28
Hallo zusammen! Smile 

Es ist endlich geschafft und " ' " war wirklich nur noch das einzige Hindernis und dank euch läuft das Board jetzt auf PHP 8.2! Vielen lieben Dank für die Hilfe! Smile 

@ Lara: Den erwähnten Thread habe ich im SG übersehen. Vielen Dank für den Hinweis!
Zitieren
#29
na prima, das freut dann doch, viel Spaß weiterhin mit MyBB
Kein Support per PN, Mail, Telefon, Hausbesuch, Discord, Telegram, WhatsApp und anderen nutzlosen Tools
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Umstellung auf PHP 8 Fehlermeldung macca 12 3.887 27.07.2023, 13:42
Letzter Beitrag: macca
  Fehlermeldung nach Umstellung auf PHP8.0 Dominic82 1 1.005 20.04.2023, 17:31
Letzter Beitrag: StefanT
  PHP8.1.13 > Fehlermeldung bei Aufruf eines Online-Users Gerti 11 1.429 22.02.2023, 18:46
Letzter Beitrag: SvePu
  Komme nicht mehr ins ACP nach Umstellung auf 8.1.15 KarinB 16 1.569 16.02.2023, 12:32
Letzter Beitrag: bv64
  MyBB 1.8.33 Fehlermeldungen nach Umstellung auf PHP 8.0 (8.1 / 8.2) Hatschi 16 2.333 20.01.2023, 00:50
Letzter Beitrag: SvePu