Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.38 veröffentlicht (30.04.24)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Umstellung auf PHP 8 Fehlermeldung
#1
Hallo,
sobald ich bei mir auf PHP8 umstelle werde ich mit folgender Mail vom Forum vollgeballert.

Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/thankyoulike.php (Line no. 1640)
Message
Undefined property: MyLanguage::$tyl_thankyou_sm
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(229): errorHandler->email_error(2, 'Undefined prope...', 'inc/plugins/tha...', 1640)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Undefined prope...', 'inc/plugins/tha...', 1640)
#2 /var/customers/webs/forum/inc/plugins/thankyoulike.php(1640): errorHandler->error_callback(2, 'Undefined prope...', '/var/customers/...', 1640)
#3 /var/customers/webs/forum/inc/class_plugins.php(142): thankyoulike_templatelist('')
#4 /var/customers/webs/forum/global.php(100): pluginSystem->run_hooks(Array)
#5 /var/customers/webs/forum/index.php(18): require_once('/var/customers/...')

Die Mails laufen nonstop rein bis ich wieder auf PHP 7.4 umstelle. Hat jemand nen Tip wie ich diesen Fehler beheben kann?
Liegt wohl an dem Plugin thankyoulike. Gibt es ne Alternative um auch die bereits enthaltenen Einträge zu behalten?
Zitieren
#2
Welches Plugin verwendest du? Da fehlt jedenfalls eine Sprachvariable.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
(23.05.2023, 17:34)StefanT schrieb: Welches Plugin verwendest du? Da fehlt jedenfalls eine Sprachvariable.

Na " thankyoulike "... ist doch eindeutig...
Also Stefan... Big Grin Big Grin
Zitieren
#4
Tut mir Leid, dass ich am Dateinamen nicht das genaue Plugin und die Version des Plugins erkenne.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
In einer deiner thankyoulike.lang.php Sprachdateien scheinen einige Einträge zu fehlen.
In diesem Fall $l['tyl_thankyou_sm']
Zitieren
#6
Ich habe mal die aktuelle Version runtergeleaden, dort gibt es diesen Eintrag jedoch auch nicht.

Es liegt wohl an den Plugins.
1. Wenn ich das Plugin komplett deinstalliere und die aktuelle version neu installiere, werden dann die schon gegebenen Thanks and likes wieder angezeigt?

2. Gibt es zum Google SEO Plugin eine alternative die unter PHP 8 läuft (es geht mir auch um eine SEO freundliche URL)?



https://community.mybb.com/mods.php?acti...ad&pid=360

Ich habe mal die original SPrachdateien testweise hochgeladen und bekomme nun die mail...
Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: global.php(961) : eval()'d code (Line no. 40)
Message
Undefined variable $unreadreports
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined varia...', 'global.php(961)...', 40)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Undefined varia...', 'global.php(961)...', 40)
#2 /var/customers/webs/forum/global.php(961) : eval()'d code(40): errorHandler->error_callback(2, 'Undefined varia...', '/var/customers/...', 40)
#3 /var/customers/webs/forum/global.php(961): eval()
#4 /var/customers/webs/forum/index.php(18): require_once('/var/customers/...')

Es stehen immer andere Fehler in den Mails

Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/google_seo/url.php (Line no. 100)
Message
Undefined array key "extra"
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined array...', 'inc/plugins/goo...', 100)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Undefined array...', 'inc/plugins/goo...', 100)
#2 /var/customers/webs/forum/inc/plugins/google_seo/url.php(100): errorHandler->error_callback(2, 'Undefined array...', '/var/customers/...', 100)
#3 /var/customers/webs/forum/inc/plugins/google_seo.php(317): require_once('/var/customers/...')
#4 /var/customers/webs/forum/inc/class_plugins.php(38): require_once('/var/customers/...')
#5 /var/customers/webs/forum/inc/init.php(235): pluginSystem->load()
#6 /var/customers/webs/forum/admin/index.php(18): require_once('/var/customers/...')



Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/google_seo/url.php (Line no. 1250)
Message
Undefined variable $location
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined varia...', 'inc/plugins/goo...', 1250)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Undefined varia...', 'inc/plugins/goo...', 1250)
#2 /var/customers/webs/forum/inc/plugins/google_seo/url.php(1250): errorHandler->error_callback(2, 'Undefined varia...', '/var/customers/...', 1250)
#3 /var/customers/webs/forum/inc/plugins/google_seo/url.php(174): google_seo_url_hook()
#4 /var/customers/webs/forum/inc/plugins/google_seo.php(317): require_once('/var/customers/...')
#5 /var/customers/webs/forum/inc/class_plugins.php(38): require_once('/var/customers/...')
#6 /var/customers/webs/forum/inc/init.php(235): pluginSystem->load()
#7 /var/customers/webs/forum/admin/index.php(18): require_once('/var/customers/...')
Zitieren
#7
(24.05.2023, 12:15)macca schrieb: Ich habe mal die aktuelle Version runtergeleaden, dort gibt es diesen Eintrag jedoch auch nicht.
Dann solltes Du prüfen in welchem Template die bemängelte Sprachvariable enthalten ist.
(24.05.2023, 12:15)macca schrieb: 1. Wenn ich das Plugin komplett deinstalliere und die aktuelle version neu installiere, werden dann die schon gegebenen Thanks and likes wieder angezeigt?
Aus Erfahrung:
Sichere vorher die zugehörigen Tabellen damit Du sie bei Bedarf, sollten sie nicht erhalten geblieben sein, diese wieder einspielen kannst.
Sollte ich der Ansicht sein helfen zu können biete ich Hilfe(n) an!  ...ich bitte jedoch nicht darum helfen zu dürfen!
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner] ♦ [PlugIns]
Zitieren
#8
Ich habe mal meine Templates aktualisiert, der Fehler mit ThankYouLike bleibt schonmal weg, nun habe ich noch folgenden fehler...
Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/google_seo/url.php (Line no. 100)
Message
Undefined array key "extra"
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined array...', 'inc/plugins/goo...', 100)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Undefined array...', 'inc/plugins/goo...', 100)
#2 /var/customers/webs/forum/inc/plugins/google_seo/url.php(100): errorHandler->error_callback(2, 'Undefined array...', '/var/customers/...', 100)
#3 /var/customers/webs/forum/inc/plugins/google_seo.php(317): require_once('/var/customers/...')
#4 /var/customers/webs/forum/inc/class_plugins.php(38): require_once('/var/customers/...')
#5 /var/customers/webs/forum/inc/init.php(235): pluginSystem->load()
#6 /var/customers/webs/forum/admin/index.php(18): require_once('/var/customers/...')

Wie deinstalliere ich dieses Pluging komplett und gibt es eine Alternative?

Oder, wie behebe ich diesen Fehler am besten?

Wen ich das Plugin deaktiviere kommmt ...

Type: 2
File: inc/class_session.php (Line no. 603)
Message
Trying to access array offset on value of type bool
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Trying to acces...', 'inc/class_sessi...', 603)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Trying to acces...', 'inc/class_sessi...', 603)
#2 /var/customers/webs/forum/inc/class_session.php(603): errorHandler->error_callback(2, 'Trying to acces...', '/var/customers/...', 603)
#3 /var/customers/webs/forum/inc/class_session.php(526): session->get_special_locations()
#4 /var/customers/webs/forum/inc/class_session.php(412): session->create_session()
#5 /var/customers/webs/forum/inc/class_session.php(116): session->load_guest()
#6 /var/customers/webs/forum/global.php(49): session->init()
#7 /var/customers/webs/forum/showthread.php(28): require_once('/var/customers/...')

(25.05.2023, 14:24)macca schrieb: Ich habe mal meine Templates aktualisiert, der Fehler mit ThankYouLike bleibt schonmal weg, nun habe ich noch folgenden fehler...
Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/google_seo/url.php (Line no. 100)
Message
Undefined array key "extra"
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined array...', 'inc/plugins/goo...', 100)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Undefined array...', 'inc/plugins/goo...', 100)
#2 /var/customers/webs/forum/inc/plugins/google_seo/url.php(100): errorHandler->error_callback(2, 'Undefined array...', '/var/customers/...', 100)
#3 /var/customers/webs/forum/inc/plugins/google_seo.php(317): require_once('/var/customers/...')
#4 /var/customers/webs/forum/inc/class_plugins.php(38): require_once('/var/customers/...')
#5 /var/customers/webs/forum/inc/init.php(235): pluginSystem->load()
#6 /var/customers/webs/forum/admin/index.php(18): require_once('/var/customers/...')

Wie deinstalliere ich dieses Pluging komplett und gibt es eine Alternative?

Oder, wie behebe ich diesen Fehler am besten?

Wen ich das Plugin deaktiviere kommmt ...

Type: 2
File: inc/class_session.php (Line no. 603)
Message
Trying to access array offset on value of type bool
Back Trace: #0 /var/customers/webs/forum/inc/class_error.php(232): errorHandler->email_error(2, 'Trying to acces...', 'inc/class_sessi...', 603)
#1 /var/customers/webs/forum/inc/class_error.php(153): errorHandler->error(2, 'Trying to acces...', 'inc/class_sessi...', 603)
#2 /var/customers/webs/forum/inc/class_session.php(603): errorHandler->error_callback(2, 'Trying to acces...', '/var/customers/...', 603)
#3 /var/customers/webs/forum/inc/class_session.php(526): session->get_special_locations()
#4 /var/customers/webs/forum/inc/class_session.php(412): session->create_session()
#5 /var/customers/webs/forum/inc/class_session.php(116): session->load_guest()
#6 /var/customers/webs/forum/global.php(49): session->init()
#7 /var/customers/webs/forum/showthread.php(28): require_once('/var/customers/...')

Mist, Fehler kommen sogar wenn ich alle Plugins deaktiviere!
Zitieren
#9
Ich habe mir nun ein neues Hosting bei Netcup angemietet, nach Umzug des Forum kam Fehler500. Nachdem ich die htaccess umbenannte lief die Seite, allerdings habe ich immer noch besagtes Problem aus diesem Thread mit php 8.

Mein Gedanke, ich setz das Fortum ganz neu auf, wie bekomme ich die Beiträge am besten wieder eingespielt, ohne die vieleicht fehlerhaften Datenbankeinträge?

Für suchmaschienenfreundliche URLs hatte ich das Plugin "Google SEO", nur ohne htaccess läuft da nichts. mod_rewrite ist aktiv, hat auf dem Host noch ne Joomla-Seite am laufen ohne Probleme mit.

Hat jemand ein paar gute Tips, oder kann mir jemand etwas helfen?
Son ich habe nun das Forum auf dem neuen Host ganz neu installiert und nur die Datenbank eingespielt, immernoch kommen massig mails mit der fehlermeldung.
Ich habe die alten Uploads hochgeladen, jedoch sin keine Bilder mehr im Forum zu sehen.
So, nach viel Kampf und mehfacher Neuinstallation ist nun Ruhe.
https://www.koronaforum.de/

Das Danke/Gefällt mir System habe ich mal für meine Zwecke etwas eingedeutsch, ich hoffe ich habe da nichts falsch gemacht!? Anbei mal die Datei dazu.
Desweiteren habe ich Netcup angeschrieben, denn selbst mit einem ganz neu installiertemn Forum geht nix mit .htaccess (Fehler500) bis dato weiss ich nicht wie ich die Googlefreundlichen URLs hinbekommen soll.
Desweiteren wurden mir im alten Forum, in den Beiträgen hinterlassene Links im Beitrag selbst als Vorschau angezeigt, praktisch eine Grafik und Text der Linkquelle angezeigt. Weiss nicht mehr wie ich das hinbekomme. Ich dachte das erledigt das AutoMedia-plugin, das ist auch installiert und eingerichtet, jedoch ändert dies nix.

EDIT: gerade Antwort von Netcup bekommen, für alle die mod_rewrite suchen, hier die Lösung:

Mod_rewrite ist leider ein wenig versteckt und stark eingedeutscht worden. Ich beschreibe Ihnen aber gerne den Weg, dies zu aktivieren.

CCP -> Produkte -> Lupe vor dem Hosting -> Auto-Login WEB -> Domain aussuchen -> Einstellungen für Apache & Nginx -> "Fähigkeit, symbolischen Verknüpfungen zu folgen, einschränken" deaktivieren -> Übernehmen. Exclamation


Angehängte Dateien
.php   thankyoulike.lang.php (Größe: 6,39 KB / Downloads: 2)
Zitieren
#10
So, zu früh gefreut, trotz neu aufgesetztem Forum und trotz neuen Hostig wieder massig Fehler. Kann mir denn wirklich keiner helfen?
Die Fehler treten immer auf sobald jemand im Forum unterwegs ist.
   


Bekäme ich keine Mails würde ich von dem Fehler nichts merken, sollte ich einfach den Versand der Mail deaktivieren und den Fehler ignorieren?
   

Code:
Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/thankyoulike.php (Line no. 1640)
Message
Undefined property: MyLanguage::$tyl_thankyou_sm
Back Trace: #0 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined prope...', 'inc/plugins/tha...', 1640)
#1 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/class_error.php(153): errorHandler->error(2, 'Undefined prope...', 'inc/plugins/tha...', 1640)
#2 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/plugins/thankyoulike.php(1640): errorHandler->error_callback(2, 'Undefined prope...', '/var/www/vhosts...', 1640)
#3 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/class_plugins.php(142): thankyoulike_templatelist('')
#4 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/global.php(100): pluginSystem->run_hooks(Array)
#5 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/misc.php(21): require_once('/var/www/vhosts...')

Code:
Your copy of MyBB running on KORONA POS Kassenforum (https://www.koronaforum.de) has experienced an error. Details of the error include:
---
Type: 2
File: inc/plugins/google_seo/404.php (Line no. 156)
Message
Undefined array key "ajax"
Back Trace: #0 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/class_error.php(232): errorHandler->email_error(2, 'Undefined array...', 'inc/plugins/goo...', 156)
#1 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/class_error.php(153): errorHandler->error(2, 'Undefined array...', 'inc/plugins/goo...', 156)
#2 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/plugins/google_seo/404.php(156): errorHandler->error_callback(2, 'Undefined array...', '/var/www/vhosts...', 156)
#3 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/class_plugins.php(142): google_seo_404('Falscher Autori...')
#4 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/functions.php(911): pluginSystem->run_hooks(Array, 'Falscher Autori...')
#5 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/inc/functions.php(764): error('Falscher Autori...')
#6 /var/www/vhosts/hosting188853.a2ffa.netcup.net/koronaforum.de/httpdocs/ratethread.php(18): verify_post_check('4b93f7a94f35628...')
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Weiße Seite nach Umstellung auf PHP8 Banshee 28 1.418 09.05.2024, 20:25
Letzter Beitrag: bv64
  Fehlermeldung nach Umstellung auf PHP8.0 Dominic82 1 1.005 20.04.2023, 17:31
Letzter Beitrag: StefanT
  Komme nicht mehr ins ACP nach Umstellung auf 8.1.15 KarinB 16 1.569 16.02.2023, 12:32
Letzter Beitrag: bv64
  MyBB 1.8.33 Fehlermeldungen nach Umstellung auf PHP 8.0 (8.1 / 8.2) Hatschi 16 2.333 20.01.2023, 00:50
Letzter Beitrag: SvePu
  Umstellung von reCaptcha auf unsichtbares reCaptcha falcao1010 1 994 05.10.2020, 10:06
Letzter Beitrag: StefanT