Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.38 veröffentlicht (30.04.24)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.8.33 Fehlermeldungen nach Umstellung auf PHP 8.0 (8.1 / 8.2)
#1
Moin, Smile
ich dachte, alle Probleme sind gelöst. Im Admin-Bereich gibt es tatsächlich keine Probleme mehr, dafür steht jetzt in den einzelnen Foren ganz oben folgendes:

   
 
Es sind keinerlei Plugins installiert.

Mein Hoster ist Strato mit PHP 8.0. (Eine Änderung auf PHP 8.1 oder 8.2 bringt auch keine Änderungen der Situation.)

Diverse genannte Abhilfen im oben verlinkten Thread (auch mit weiter Verlinkungen) führen hierbei leider nicht zum Ziel.

Hat noch jemand diese Probleme? Weiß jemand Abhilfe?

Über Hilfe würde ich mich sehr freuen. - Danke vorab.

Grüße,
Hatschi.
Zitieren
#2
Fix für Fehler Nr.2 - Datei einfach nach FORUMROOT/inc/ kopieren (Alte überschreiben)

.php   functions_post.php (Größe: 35,32 KB / Downloads: 12)

Lösung zum Fehler 1 habe ich auf die Schnelle nicht finden können.
Zitieren
#3
Das habe ich eben ausprobiert. Leider kein Erfolg!

Alle Fehlermeldungen bleiben, auch der 2.!

Es ging ja auch eigentlich um die functions.php ... Rolleyes  - Habe nur ich das Problem?!?
Zitieren
#4
(14.01.2023, 20:16)Hatschi schrieb: Das habe ich eben ausprobiert. Leider kein Erfolg!

Alle Fehlermeldungen bleiben, auch der 2.!

Es ging ja auch eigentlich um die functions.php ... Rolleyes  - Habe nur ich das Problem?!?

Ich habe ähnliche Probleme. Allerdings habe ich Plugins installiert.
Und mit denen einen Berg an Fehlermeldungen nach Update auf die neuste MyBB version und anschließender Umstellung auf PHP 8.0

Mirror:  CAMDEN VILLAGE – A WILD WEST STORY (buffymagazin.de)

Interessanterweise, wenn man das Forum komplett neu aufsetzt, mit der neusten Version, dann umstellt auf PHP 8.0 und alle Plugins von Hand wieder installiert, läuft das Forum fehlerfrei.
Zitieren
#5
@clayton
Der Großteil der Fehler/Warnungen scheinen durch die installierten Plugins bzw. veraltete Theme Templates erzeugt worden zu sein.
Zitieren
#6
Es empfiehlt sich alle PlugIns zu deaktivieren und wenn keine Fehlermeldungen bestehen, dann ein PlugIn nach dem anderen aktivieren und die angezeigten Fehler beseitigen. Ledier haben viel PlugIn-Entwickler ihre PlugIns (noch) nicht an PHP 8.x.x angepasst.

Anregung:
Es wäre empfehlenswert, wenn z.B. jemand ein PlugIn an PHP 8.x.x angepasst hat, dies hier ein einem eigenen Thread (z.B. Kategorie: PlugIns > Forum: PHP 8.x.x > Unterforem: Pluginnamen.

Diese Wissenssammlung würde allen MyBB-Admins enorm helfen und je größer die Sammlung ist, effektiver können Fragen beantwortet bzw. auf die Lösung verwiesen werden. Diese wäre dann ein Nutzen für Alle.

Ich denke, wenn einige Hoster im Laufe des Jahres die Zwangsumstellugn auf PHP 8.x.x durchführen, wird es hier, ohne Wissenssammlung, einen Anfrageboom geben. Dem könnte man im Vorfeld vorbeugen.

Ok, diese Anregung stelt lediglich meine bescheidene Meinung zur Gesamtthematik MyBB und PHP 8.x.x da.
Sollte ich der Ansicht sein helfen zu können biete ich Hilfe(n) an!  ...ich bitte jedoch nicht darum helfen zu dürfen!
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner] ♦ [PlugIns]
Zitieren
#7
Und jetzt bitte wieder zurück zum ursprünglichen Problem. Hatschi verwendet keinerlei Plugins.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
Hallöchen,

na da bekomme ich doch Gefrierbrand in den Haaren :-(
Ich habe das produktive Forum bei Strato, ein Testforum bei Strato und zwei bei 1und1.

Bei 1und1 habe ich in einem Forum alles deaktiviert / deinstalliert, gesäubert und was auch immer, und dann geschaut, wo es klemmt.

Plugins, und Erweiterungen, die bei mir bei 1und1 nicht funktionieren, sind
ProPortal
MarkEditAsUnread
HideForunms

1und1 hat den Vorteil, dass man die Datenbanken schnell und einzeln um- und auch wieder zurück stellen kann.


Bei Strato ist das nicht möglich. Hier soll man zum Test einer einzelnen Datenbank die .htaccess ändern, folgende Zeile hinzufügen:
AddType application/x-httpd-php8 .php

Damit erhalte ich

Forbidden
You don't have permission to access this resource.
PHP Version 7.4.30
MySQL Version 5.7.42
Mybb Version 1.8.37
(Stand 01/2024)

Grüße, André
Zitieren
#9
@schauan

Nur mal nebenbei... Die PHP-Version hat nichts mit der Datenbank zu tun. Wink
Bei Strato kannst du umstellen und innerhalb einer halben Stunde wieder zurück wechseln.
Du darfst dich in dieser halben Stunde bei Strato allerdings nicht ausloggen, sonst ist die Umstellung fest.
Zitieren
#10
(18.01.2023, 15:06)Schnapsnase schrieb: @schauan
Bei Strato kannst du umstellen und innerhalb einer halben Stunde wieder zurück wechseln.
Du darfst dich in dieser halben Stunde bei Strato allerdings nicht ausloggen, sonst ist die Umstellung fest.

Das ist richtig. - Ich habe ja nun "fest umgestellt" und immer noch die oben genannte Fehler.

Kann mir jemand sagen, ob ich die Fehler (zunächst) ignorieren kann und das Forum weiter nutzen - oder gibt es dann irgendwelche Probleme, z.B. in den Datenbank oder sonst etwas?!?
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Weiße Seite nach Umstellung auf PHP8 Banshee 28 1.398 09.05.2024, 20:25
Letzter Beitrag: bv64
  Umstellung auf PHP 8 Fehlermeldung macca 12 3.880 27.07.2023, 13:42
Letzter Beitrag: macca
  Fehlermeldung nach Umstellung auf PHP8.0 Dominic82 1 1.002 20.04.2023, 17:31
Letzter Beitrag: StefanT
  Komme nicht mehr ins ACP nach Umstellung auf 8.1.15 KarinB 16 1.556 16.02.2023, 12:32
Letzter Beitrag: bv64
  Umstellung von reCaptcha auf unsichtbares reCaptcha falcao1010 1 992 05.10.2020, 10:06
Letzter Beitrag: StefanT