Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.28 veröffentlicht (26.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[NG] Fehler-Meldung beim Antworten
#1
Hallo,

Da ich seit einiger Zeit kaum mehr was in meinem Forum gemacht habe, weiß ich nicht, wielange dieser Fehler schon existiert. Vordem lief alles einwandfrei, und ich habe auch nichts an den Einstellungen vorgenommen, doch nun ist mir aufgefallen, dass ich nicht mehr auf Beiträge antworten und diese auch nicht zitieren kann.
Ich werde auf eine weiße Seite geleitet, wo ich diese Meldung sehe:

Fatal error: Uncaught Error: [] operator not supported for strings in /kunden/100192_54531/mybb/newreply.php:826 Stack trace: #0 {main} thrown in /kunden/100192_54531/mybb/newreply.php on line 826

Was kann da passiert sein?
Zitieren
#2
Um welche MyBB-Version handelt es sich und um welche PHP-Version?

Einen Bug kann man allerdings fast ausschließen, in der aktuellen Version deutet in der genannten Zeile nichts auf einen Fehler hin.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Die Version ist 1.8.7
Die PHP Version ist 7-73 bzw. 7.3.23
Zitieren
#4
(04.08.2021, 22:52)Dante schrieb: Die Version ist 1.8.7
Die PHP Version ist 7-73 bzw. 7.3.23

Aktuell ist ja die Version 1.8.27. Ich vermute mal, da gibt es für Version 1.8.7 keinen Support mehr.
Auch PHP ist aktuell bei Version 8.
Zitieren
#5
Soll ich dann also erstmal trotz Fehler updaten?
Zitieren
#6
wenn dir etwas an deinem Forum liegt, solltest du immer updaten, wenn ein Update heraus kommt
Die sind keine Schikanen um Foren-Admins zu ärgern, sondern bringen Sicherheits-Fixes und/oder neue Funktionen
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#7
(04.08.2021, 23:12)Dante schrieb: Soll ich dann also erstmal trotz Fehler updaten?

Was könnte Dich hindern die Forensoftware auf die aktuelle Version upzudaten? Ein Updatepaket von 1.8.7 auf V1.8.27 wird ja hier zur Verfügung gestellt.

Mache vorher eine Sicherung der Datenbank sowie der FTP-Daten, dann lege los.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#8
Das Problem entsteht durch deine PHP-Version in Verbindung mit einer veralteten newreply.php
Es betrifft speziell diese Definition, die in deiner newreply.php nicht vorhanden ist:
PHP-Code:
$quoted_ids = array(); 
Entweder du schraubst die PHP-Version zurück, oder du updatest.
Das Update ist die bessere Lösung. Wink
Zitieren
#9
Alles klar, dann werde ich mich da mal dran geben, danke für eure Antworten
Zitieren