Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Merge-System-Fehlermeldung
#1
Zitat:Warning: Declaration of debugErrorHandler::error($type, $message, $file = NULL, $line = 0) should be compatible with errorHandler::error($type, $message, $file = NULL, $line = 0, $allow_output = true) in /www/htdocs/+++/update/merge/resources/class_error.php on line 34

würde mich doch mal interessieren wollen, was das ist, ich hatte versucht, diese Merge-Version zu testen, die ist offenbar immer noch nicht wirklich Willens zu funktionieren?

Ich habe die 1.8.27 auf PHP7.4.19 installiert und das hat problemlos funktioniert, dann hatte ich die Idee, das Merge-System zu testen ob das inzwischen auch die MyBB nach 1.8.15 und PHP7.1 umsetzen kann .. da die zu Mergende Version die 1.8.21 auf PHP 7.4.19 ist wäre das nützlich, wenn das funktionieren würde

Die Meldung oben bleibt stehen, die möglichen Optionen sind trotz allem zu nutzen .. ich werde mal weiter durchklicken und sehen was am Ende in der Installation angekommen ist

Edit: mit einigem Murren hat er dann doch etwas getan und am Ende kam dann noch folgende Meldung dazu:
Zitat:Warning [2] Cannot modify header information - headers already sent by (output started at /www/htdocs/+++/update/merge/resources/class_error.php:76) - Line: 277 - File: merge/resources/output.php PHP 7.4.19 (Linux)
File Line Function
/merge/resources/class_error.php 60 errorHandler->error
[PHP] debugErrorHandler->error
/merge/resources/output.php 277 header
/merge/index.php 1027 converterOutput->module_list

sowas aber auch .. und das war wie gesagt beides PhP7.4.19 basis, ich habe es vorsätzlich nicht mit der 7.1 versucht, weil ich da probleme habe kommen sehen ..

irgendwie schade dass das nicht so wollte wie ich das gern gehabt hätte - so fehlerfrei und ohne Probleme ..

dann muss ich es wohl doch mit dem Update versuchen ohne Merge .. das ist aber eher nicht so meins, weil mir das regelmäßig daneben geht, aber mehr als der Anleitung zu folgen ist ja nunmal nicht drin

hm .. das Ergebnis ist schon spannend, die User-Ids werden offenbar frei nach Schnauze vergeben .. aber zumindestens scheint die Zuordnung der Themen in die forenbereiche zu funktionieren
Zitieren
#2
Man kann sich in Unkenntnis leider auch unnötige Arbeitsabläufe auferlegen. Daher nachstehend ein wenig Information wie man fremde Forensoftware zu MyBB migriert bzw. bestehende MyBB-Forensoftware aktualisiert. Mit der korrekten Vorgehensweise erspart man sich unnötige (fehlschlagende) Arbeitsabläufe..

Vorweg:
Das Merge funktioniert fehlerfrei wenn es für den Zweck für das es gedacht ist verwendet wird.

Merge
* Wie Du hier entnehmen kannst, ist Merge nicht dazu gedacht, eine ältere MyBB-Forensoftware auf die aktuelle Forensoftware zu aktualisieren.
* Merge dient dazu, eine von fremde Forensoftware zur MyBB-Forensoftware zu migrieren.

Aktualisierung MyBB
Dazu werden, die, je nach vorhandener Version, die hierzu erforderlichen MyBB-Pakete hier bereit gestellt.

Updateprobleme:
* Gibt es Probleme bei den Update ist es meist dadurch geschuldet, das eventuell Templates noch aktualisiert werden müssen.
> Dazu im ACP unter "Templates & Style" > "Tempaltes" > "Finde aktualisierte Templates" eine saubere Möglichkeit jede Datei, welche von dir selbst angepasst werden muss, mittels der Differenz-Aanalyse (rechts = Optionen) sich anzeigen zu lassen.
* PlugIns sollten dahingehend geprüft werden, ob Sie mit der aktuellen MyBB-Version im Einklang stehen.
> Eventuell sind PlugIns zu aktualisieren.

PHP-Version
Die MyBB-Forensoftware funktioniert definitiv unter PHP7.4.19 (sowie alle niedrigen PHP-Versionen) fehlerfrei.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#3
Die beiden Fehlermeldung werden vermutlich dadurch verursacht, dass das Merge-System noch nicht an MyBB 1.8.27 angepasst wurde. Es existiert ein passendes Ticket: https://github.com/mybb/merge-system/issues/273
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
(31.07.2021, 12:01)StefanT schrieb: Die beiden Fehlermeldung werden vermutlich dadurch verursacht, dass das Merge-System noch nicht an MyBB 1.8.27 angepasst wurde. Es existiert ein passendes Ticket: https://github.com/mybb/merge-system/issues/273
Da der OP nichts von Migration fremder Forensoftware zu MyBB-Forensoftware sondern Update von MyBB V1.8.15 auf MyBB 1.8.27 schrieb, implementiert Deine Erläuterung (nur auf die Fehlermeldung bezogen) dass das Merge auch zum Update von MyBB-Versionen (derzeit nicht auf die aktuelle Version 1.8.27) verwendet werden kann. Ist dem so? Wozu dann die (alten) Update-Pakete?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#5
Wie du dies aus meinem Beitrag, bei der ich ausschließlich auf die Fehlermeldungen eingegangen bin, ableiten willst, ist mir völlig schleierhaft.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
(31.07.2021, 12:26)StefanT schrieb: Wie du dies aus meinem Beitrag, bei der ich ausschließlich auf die Fehlermeldungen eingegangen bin, ableiten willst, ist mir völlig schleierhaft.

Ich versuche mal Deinen Schleier etwas anzuheben:
Es ist an Deinem Beitrag inhaltlich nicht erkennbar, dass Du lediglich eine autonome Merge-Analyse der Fehlermeldung durchführtest. Es wird Deinerseits als Eräuterung die derzeitig gegebene Versionbegrenzung von Merge aufgeführt, was unstrittig eine wichtige Information darstellt. Da Dein Beitrag jedoch schlussfolgernd auf die Problematik der vom OP geschilderten Vorgehensweise geschrieben wurde, ist die von mir erwähnte Implementation (gleichfalls schlussfolgernd) sehr wohl gerechtfertigt.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#7
(31.07.2021, 12:01)StefanT schrieb: Die beiden Fehlermeldung werden vermutlich dadurch verursacht, dass das Merge-System noch nicht an MyBB 1.8.27 angepasst wurde. Es existiert ein passendes Ticket: https://github.com/mybb/merge-system/issues/273

da ich nur versucht habe das Mergesystem in der 1.8.27 auf PHP 7.4.19 zu nutzen die Daten aus der 1.8.21 zu holen, hatte die Fehlermeldung die bereits beim Start des Mergesystems gekommen ist damit sicher etwas zu tun dass das merge-system noch nicht die 1.8.27 kennt .. denn der Rest lief weitestgehend durch, das das Resultat dann nicht ganz dem entsprach was ich dachte das kommen würde .. gleiche UserID bei den vorhandenen und importierten Mitgliedern .. das ist eine andere Nummer ..

ich habe nicht versucht, die 1.8.21 mit dem Mergesystem zu upgraden auf 1827, dass das nicht geht weiß ich selbst, dafür gibt es ja nicht aus langeweile die Updatepakete .. ich habe nur versucht Daten zu übertragen und ulkiger Weise ist dies genau die Funktion von dem Merge-system - Daten zu übertragen ..von "updaten" steht nirgends etwas .. das hätte ich auch so nicht versucht ..

aber der Einwurf bringt mich auf eine Idee die ich noch gar nicht so erfasst hatte vorher

Danke StefanT für die Erklärung zur Fehlermeldung

Danke Gerti für den Denkanstoß, wie unschwer zu erkennen war, bereits vor dem Beitrag von Gerti .. war das Thema "erledigt" markiert Wink
Zitieren
#8
Absatz 1
Zitat:ich nur versucht habe das Mergesystem in der 1.8.27 auf PHP 7.4.19 zu nutzen die Daten aus der 1.8.21 zu holen
Absatz 1
Zitat:ich habe nicht versucht, die 1.8.21 mit dem Mergesystem zu upgraden auf 1827
Deine Ausführungen, Eingangssätze von Absatz 1 und Absatz 2, muss man nicht verstehen.

Status 05.08.2021 - 17:27 Uhr: Das Thema ist, entgegen Deiner Ausführung, NICHT als erledigt gekennzeichnet!
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#9
(05.08.2021, 17:28)Gerti schrieb: Status 05.08.2021 - 17:27 Uhr: Das Thema ist, entgegen Deiner Ausführung, NICHT als erledigt gekennzeichnet!

das habe ich nicht umgestellt, keine Ahnung wie der zurück auf unerledigt gekommen ist, ich war das jedenfalls nicht und es war bereits erledigt vor deinem ersten Beitrag zu dem Thema ..
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Import von WBB4 über Merge System GabyH 2 575 21.12.2020, 16:53
Letzter Beitrag: GabyH
Sad Merge System will nicht jojo-gfx 19 1.570 30.09.2020, 19:07
Letzter Beitrag: jojo-gfx
  Merge-System zeigt Fehler an Niko 9 1.272 02.10.2019, 14:06
Letzter Beitrag: bv64
  wBB -> MyBB? Mit Merge System? itsmeJAY 3 1.232 06.02.2019, 08:25
Letzter Beitrag: itsmeJAY
  Merge System - Problem mit Datenbankkonfiguration/table prefix Cassidy 9 2.838 27.12.2018, 21:15
Letzter Beitrag: RobiRobs