Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.33 veröffentlicht (03.01.23)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Farbige Kategorieüberschriften (Subforen)
#1
Hallo,

1. im Template forumbit_depth1_cat defniere ich die Farben je Kategorie mit:
<td class="thead{$expthead}" colspan="6" id="forum_cat_{$forum['fid']}">
Dies funktioniert (CSS ist angelegt) ohne Probleme!

2. Klickt man die Kategorie an, wird das Template forumdisplay_subforums aufgerufen und es steht im Browser "forumdisplay.php?fid=xx" (xx=aufgerufene FID). Die im CSS eingetragene Farbe (Aufruf wie vor über ID) wird nicht angezeigt, sondern die Forenstandardfarbe (sowie nicht in 1 anders definiert)

Unabhängig an welcher Stelle im Template die Anweisung id="forum_cat_{$forum['fid']}" eingebunden wird.

Frage:
Muss bei den Subforen anstelle "id="forum_cat_{$forum['fid']}" eine andere Defintion angegeben werden? Welche?

Vorab Danke für eine Hilfestellung.
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#2
forumbit_* : {$forum['fid']} (in allen Templates)
forumdisplay_subforums: {$forum['fid']}
forumdisplay_threadlist: {$fid}

Die mit GET-Methode übergebene Variable xx spielt hier gar keine Rolle und hat weder mit id, class oder CSS etwas zu tun. Die bearbeitet nur der Webserver intern und erzeugt daraus entsprechende Variablen, die dann auch in Temples genutzt werden können.

[ETS]
MyBB-Forum + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Unlösbares Problem? -> das Nötel
Zitieren
#3
(25.06.2021, 16:49)[ExiTuS] schrieb: Die mit GET-Methode übergebene Variable xx spielt hier gar keine Rolle und hat weder mit id, class oder CSS etwas zu tun. Die bearbeitet nur der Webserver intern und erzeugt daraus entsprechende Variablen, die dann auch in Temples genutzt werden können.
Erst mal Danke dass Du Dich meinem Anliegen annimmst.

Wie bereits geschrieben:
a) im Template forumbit_depth1_cat funktioniert es mit:
<td class="thead{$expthead}" colspan="6" id="forum_cat_{$forum['fid']}">
b) nicht aber in
forumdisplay_subforums: {$forum['fid']} und forumdisplay_threadlist: {$fid}

die CSS beinhaltet:
.forum_cat_xx: {background: #F00}
.forum_cat_yy: {background: #00F}
.forum_cat_zz: {background: #FFF}
was zu a) Fehlerfrei funktioniert.

Wie kann/könnte dies nunmehr zu "b" in Funktion gebracht werden?
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#4
(25.06.2021, 17:25)Gerti schrieb: was zu a) Fehlerfrei funktioniert.

Selbst das dürfte, wenn´s denn so ist, nicht funktionieren.
Du definierst im Template eine ID und in der CSS-Datei eine Klasse.
Ohne das ich´s mir jetzt angeschaut habe - wie soll das gehen?
Zitieren
#5
(25.06.2021, 19:20)Schnapsnase schrieb:
(25.06.2021, 17:25)Gerti schrieb: was zu a) Fehlerfrei funktioniert.
Du definierst im Template eine ID und in der CSS-Datei eine Klasse.
Sorry, versehentlich hier beim Posting einen Punkt statt eine Raute angegeben. Ist selbstverständlich im CSS als ID definiert.
Mea Culpa.

Wie kann "b" umgesetzt werden?
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#6
(26.06.2021, 08:23)Gerti schrieb: Wie kann "b" umgesetzt werden?

Funktioniert bei mir problemlos.

1. Was soll der Doppelpunkt hinter deiner CSS-ID? (.forum_cat_xx: {background: #F00})
2. Im Template "forumdisplay_subforums" musst du $fid verwenden
Zitieren
#7
(26.06.2021, 10:05)Schnapsnase schrieb:
(26.06.2021, 08:23)Gerti schrieb: Wie kann "b" umgesetzt werden?
Funktioniert bei mir problemlos.
1. Was soll der Doppelpunkt hinter deiner CSS-ID? (.forum_cat_xx: {background: #F00})
2. Im Template "forumdisplay_subforums" musst du $fid verwenden
Zu 1: Der Doppelpunkt ist selbstverständlich nicht gegeben, sonst würde "a" nicht funktionieren.

Bei mir nicht, auch wenn ich $fid (vermutlich inkorrekt, siehe nächste Zeile) verwende.

Beim Abspeichern mit id="forum_cat_{$forum['$fid']}" kommt die Meldung: "Es wurde ein mögliches Sicherheitsproblem im Template gefunden. Bitte prüfe deine Eingabe oder wende dich an den MyBB-Support."

Zu 2: Würdest Du bitte mal die gesamte Zeile aus dem Template "forumdisplay_subforums" posten, in welcher Du es funktionierend eingebunden hast?

Danke vorab.
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#8
(26.06.2021, 14:26)Gerti schrieb: Zu 2: Würdest Du bitte mal die gesamte Zeile aus dem Template "forumdisplay_subforums" posten,...

Bitte: Wink
Code:
<td id="forum_cat_{$fid}" class="thead" colspan="5" align="center"><strong>{$lang->sub_forums_in}</strong></td>
Zitieren
#9
Es funktioniert jetzt.

Bei  forumbit_depth1_cat funktioniert es mit: id="forum_cat_{$forum['fid']}"
Bei  forumsdisplay_subforums  funktioniert es mit: id="forum_cat_{$fid}"

Hatte die unterschiedliche = geschweiften Klammern nicht verstanden. Darum auch hier für alle die es auch verwenden wollen nochmals nachvollziehbar niedergeschrieben 

Besten Dank.
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#10
muss leider nochmals nachfragen Sad :

Keine der beiden vorgenannten Lösungen funktioniert im Template forumdisplay_threadlist!
Scheint noch eine dritte Variante von Nöten zu sein? *grübel.

Hat jemand eine Lösung?
Fehler gefunden!

Es funktioniert mit id="forum_cat_{$fid}" (man sollte auch die ID in der CSS definieren *schäm)
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Text aus den Kategorieüberschriften generell durch Bilder ersetzen clayton 1 925 07.02.2019, 15:02
Letzter Beitrag: clayton
Question Darstellung von Subforen bei bei Kategorien anpassen lenox 4 1.841 08.01.2018, 21:47
Letzter Beitrag: lenox
  Subforen Anzeige bearbeiten kittenparanoia 4 1.684 04.10.2017, 17:34
Letzter Beitrag: kittenparanoia
  Subforen mit einem comma trennen Lagerlui 2 1.219 06.01.2017, 15:06
Letzter Beitrag: Lagerlui
  Farbige Rahmen um Kategorien don_vito 1 947 29.10.2016, 05:02
Letzter Beitrag: MrBrechreiz