Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.24 veröffentlicht (09.08.20)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Ausloggen nicht mehr möglich
#1
Hallöchen,

ich wollte mich gerade aus meinem Forum ausloggen um mich mit einem anderen einzuloggen. Allerdings kommt dann


Zitat:Ihre Benutzer-ID konnte nicht verifiziert werden, um Sie abzumelden. Ein Grund könnte sein, dass ein böswilliges JavaScript versucht hat, Sie abzumelden. Wenn Sie sich abmelden wollen, benutzen Sie bitte den Abmelde-Button im Menü.


Ich habe schon das Forum hier durchforstet und den Template header_welcomeblock_member in das hier umgeändert

Code:
<!-- Continuation of div(class="upper") as opened in the header template -->
    <!-- <span class="welcome">{$lang->welcome_back} <a href="{$mybb->settings['bburl']}/member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}">{$lang->welcome_logout}</a></span>
    </div>
</div> -->
<!--<div class="lower">
    <div class="wrapper">
        <ul class="menu panel_links">
            {$usercplink}
            {$modcplink}
            {$admincplink}
        </ul>
        <ul class="menu user_links">
            <li><a href="javascript:void(0)" onclick="MyBB.popupWindow('{$mybb->settings['bburl']}/misc.php?action=buddypopup&modal=1', null, true); return false;">{$lang->welcome_open_buddy_list}</a></li>
            {$searchlink}
            {$pmslink}<!-- AccountSwitcher -->{$as_header}<!-- /AccountSwitcher -->

    
    <br class="clear" />
</div> -->

Allerdings funktioniert es immernoch nicht.

Ich benutzt zwei selbst erstellte Themes, das Standardtheme gibt es nicht mehr.

Liebe Grüße
Riku
Zitieren
#2
Hast Du einen angemeldeten User gelöscht? Stimmen die Cookie-Einstellungen (noch)?

Ein Link zum Forum würde eine Hilfestellung vereinfachen.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Hilfe(n) kann man lediglich anbieten. Wer Hilfe nicht annimmt, dem ist nicht zu helfen!
Aktive Version: MyBB: 1.8.24 | PHP: 7.4.10 | SQL: 5.7.28
Zitieren
#3
Nein keine User gelöscht, ich habe einen Erstellt, aber das sollte kein Problem sein, oder?
Ich habe eigentlich gar nichts in letzter Zeit geändert, ich wollte nur schauen ob der Account-Switcher funktioniert und den Admin abmelden und mich mit dem Testcharakter anmelden.

http://aerandir.bplaced.net/ hier ist der Link zum Forum!

Edit: Ich sehe gerade, einloggen funktioniert auch nicht. Habe mich über einen Anonymen Tab eingeloggt. Der User wird zwar in der Liste angezeigt, aber er wird nicht eingeloggt.
Zitieren
#4
(17.09.2020, 15:01)Kiruku schrieb: Ich habe schon das Forum hier durchforstet und den Template header_welcomeblock_member in das hier umgeändert
Wie alt war die "Lösung" denn? So ist der Link komplett falsch, bitte vergleiche das Template mit dem Original und korrigiere das.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Ich habe das Template jetzt auf das Original zurück gesetzt.
Ändert aber auch nichts am Problem
Zitieren
#6
Wird dieses Templates bei diesem Theme überhaupt verwendet?
Bei Cookie-Problemen empfiehlt es sich die Cookies im Browser zu löschen oder einen anderen Browser zu probieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Es liegt nicht an dem Template, da hast Du Recht, ich ging nur davon aus das es das ist weil es bei meinen Recheren vorkam.

In meinen Themes läuft alles (was wahrscheinlich nicht sehr ordentlich ist, wie ich nun gerade feststelle) über das Template 'header' ich hab die einzelnen Variablen mit If & Else gelöst, weil ich damals nicht wusste wie man das aufteilt.

Mit den Cookies hab ich keine Probleme und testen tu ich sowieso immer in verschiedenen Browsern
Zitieren
#8
Welches Probleme treten nun auf? Nur der Fehler beim Ausloggen oder gibt es auch andere Symptome?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Ja Einloggen und Ausloggen funktioniert nicht, sonst gibt es keinerlei Probleme. Wie beim Eröffnungsbeitrag erwähnt, erscheinen die folgenden Worte

'Ihre Benutzer-ID konnte nicht verifiziert werden, um Sie abzumelden. Ein Grund könnte sein, dass ein böswilliges JavaScript versucht hat, Sie abzumelden. Wenn Sie sich abmelden wollen, benutzen Sie bitte den Abmelde-Button im Menü.'
Zitieren
#10
Zitat:Das bedeutet, dass Ihr Logout-Link keine SID enthält, und seit MyBB 1.2.8 ist dies erforderlich. Dafür gibt es zwei mögliche Gründe:

1. Das Board wurde auf eine neuere Version von MyBB aktualisiert, aber einige Vorlageninformationen  (Templates) wurden nicht aktualisiert.
2. Sie verwenden eine Vorlage, die für eine Version von MyBB älter als 1.2.8 entworfen wurde, und als solche fehlt im Logout-Link auch die SID-Komponente.

Eine Lösung für diese beiden Probleme finden Sie, indem Sie den Anweisungen hier (https://community.mybb.com/showthread.ph...#pid177101) folgen, um den Abmeldelink Ihrer Vorlagen manuell zu aktualisieren, so dass er die SID enthält. Hinweis: Sie müssen dies für jedes Theme tun, das Sie in Ihrem Forum verwenden und das derzeit keinen SID-Link enthält.

Weitere Informationen, usw hier:

Quelle: https://docs.mybb.com/1.8/faq/logout/
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [Hilfe] Kein Ein/ausloggen möglich CeeZee 12 1.943 28.07.2016, 23:26
Letzter Beitrag: MrBrechreiz