Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler bei Registrierung
#1
Hallo,

nach meinem Update auf 1.8.21, das bisher recht gut verlief, habe ich nun die Registrierung freigeschaltet. Bei einer Test-Registrierung kam nun leider ein Fehler:

Auszug:

M"has experienced an internal SQL error and cannot continue.

SQL Error:
1054 - Unknown column 'aim' in 'field list'
Query:
INSERT INTO mybb_users (`username`,`password`,`salt`,`loginkey`,`email`,`postnum`,`threadnum`,`avatar`,`avatartype`,`usergroup`,`additionalgroups`,`displaygroup`,`usertitle`,`regdate`,`lastactive`,`lastvisit`,`website`,`icq`,`aim`,`yahoo`,`skype`,`google`,`birthday`,`signature`,`allownotices`,`hideemail`,`subscriptionmethod`,`receivepms`,`receivefrombuddy`,`pmnotice`,`pmnotify`,`showimages`,`showvideos`,`showsigs`,`showavatars`,`showquickreply`,`showredirect`,`tpp`,`ppp`,`invisible`,`style`,`timezone`,`dstcorrection`,`threadmode`,`daysprune`,`dateformat`,`timeformat`,`regip`,`language`,`showcodebuttons`,`sourceeditor`,`buddyrequestspm`,`buddyrequestsauto`,`away`,`awaydate`,`returndate`,`awayreason`,`notepad`,`referrer`,`referrals`,`buddylist`,`ignorelist`,`pmfolders`,`warningpoints`,`moderateposts`,`moderationtime`,`suspendposting`,`suspensiontime`,`coppauser`,`classicpostbit`,`usernotes`) VALUES ('xxxxxxx','f0d7200050b76799e515425b79db623d','1InUP4wN','9sfZwRpI3uV70pjALvtq8gwQVQRSPohjkhEcuClldSBq4U1dUJ','test.test@web.de',0,0,'','',5,'',0,'',1572892944,1572892944,1572892944,'',0,'','','','','','',1,0,2,1,0,1,0,1,1,1,1,1,1,0,0,0,0,'1',2,'linear',0,'','',X'5b3f9b5e','',1,0,1,0,0,0,0,'','',0,0,'','','',0,0,0,0,0,0,1,'')
Please contact the MyBB Group for technical support."


Was ist denn da wohl schief gelaufen?  Undecided
Zitieren
#2
bitte überprüfe, ob deine Templates alle aktuell sind!
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive

Die Doku bietet viele Lösungen für bekannte Probleme und weitere Tipps!
Schau doch mal rein...
Zitieren
#3
Ich habe ganz neu das BootBB-Theme und dessen Templates aufgespielt. Daher dürften die Templates keine Rolle spielen, oder?

Alte Templates habe ich nicht übernommen, mal von den globalen Templates abgesehen.
Zitieren
#4
"aim" gibt es in MyBB nicht mehr
Entweder ist hier beim Update etwas schief gegangen, oder Du hast vor dem Update nicht alle Dateien neu hochgeladen und die alten überschrieben.
Zitieren
#5
(04.11.2019, 20:46)Schnapsnase schrieb: "aim" gibt es in MyBB nicht mehr
Entweder ist hier beim Update etwas schief gegangen, oder Du hast vor dem Update nicht alle Dateien neu hochgeladen und die alten überschrieben.
Mein Update erfolgte von 1.8.8 auf 1.8.21. Was kann ich jetzt tun?
Zitieren
#6
Hallo falcao1010,

das Updatescript hast du aber durchlaufen lassen, oder? Oft werden auch Anpassungen an den Tabellen des MyBB in der Datenbank gemacht. Dafür ist das Ausführen des Update/Upgradesripts oft zwingend erforderlich.

Nur die neuesten Dateien kopieren bzw. auf den Webspace hochladen und ein anderes Theme zu verwenden reicht nicht aus. Die Datenbank wäre beim einem solchen Vorgehen ja trotzdem noch auf dem Stand der alten Version.
Cheers
Zitieren
#7
Ja, das Upgradesripts habe ich laufen lassen. Ich hatte dabei keine Fehlermeldung.
Zitieren
#8
Das liegt weder an Templates noch an der Datenbank. Vermutlich sind nicht alle Dateien auf dem aktuellen Stand. Dies kannst du z.B. mit der Datei-Überprüfung im ACP prüfen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
stimmt Stefan, das muss die member.php sein, wie komme ich da auf Templates *grübel*

Aber besser wirklich ALLE php-Dateien auf aktuellen Stand prüfen, nicht dass da noch mehr Karteileichen rum gammeln
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive

Die Doku bietet viele Lösungen für bekannte Probleme und weitere Tipps!
Schau doch mal rein...
Zitieren
#10
Ich habe die Dateiprüfung durchgeführt. Ergebnis:

Datei Status
inc/datahandlers/warnings.php Verändert
inc/datahandlers/event.php Verändert
inc/datahandlers/login.php Verändert
inc/datahandlers/pm.php Verändert
inc/datahandlers/post.php Verändert
inc/datahandlers/user.php Verändert
inc/functions.php Verändert
inc/mailhandlers/smtp.php Verändert
inc/tasks/versioncheck.php Verändert
inc/tasks/checktables.php Verändert
inc/languages/english.php Verändert
inc/languages/english/portal.lang.php Verändert
inc/languages/english/admin/user_groups.lang.php Verändert
inc/languages/english/admin/global.lang.php Verändert
inc/languages/english/admin/tools_adminlog.lang.php Verändert
inc/languages/english/admin/config_badwords.lang.php Verändert
inc/languages/english/admin/forum_management.lang.php Verändert
inc/languages/english/admin/tools_spamlog.lang.php Verändert
inc/languages/english/admin/config_questions.lang.php Verändert
inc/languages/english/admin/forum_attachments.lang.php Verändert
inc/languages/english/admin/user_module_meta.lang.php Verändert
inc/languages/english/admin/config_attachment_types.lang.php Verändert
inc/languages/english/admin/tools_recount_rebuild.lang.php Verändert
inc/languages/english/admin/home_dashboard.lang.php Verändert
inc/languages/english/admin/config_mod_tools.lang.php Verändert
inc/languages/english/admin/user_mass_mail.lang.php Verändert
inc/languages/english/admin/tools_tasks.lang.php Verändert
inc/languages/english/admin/config_mycode.lang.php Verändert
inc/languages/english/admin/tools_file_verification.lang.php Verändert
inc/languages/english/admin/style_templates.lang.php Verändert
inc/languages/english/admin/style_themes.lang.php Verändert
inc/languages/english/admin/home_preferences.lang.php Verändert
inc/languages/english/admin/tools_modlog.lang.php Verändert
inc/languages/english/admin/config_profile_fields.lang.php Verändert
inc/languages/english/admin/user_users.lang.php Verändert
inc/languages/english/admin/config_settings.lang.php Verändert
inc/languages/english/admin/tools_system_health.lang.php Verändert
inc/languages/english/admin/user_admin_permissions.lang.php Verändert
inc/languages/english/global.lang.php Verändert
inc/languages/english/helpdocs.lang.php Verändert
inc/languages/english/ratethread.lang.php Verändert
inc/languages/english/reputation.lang.php Verändert
inc/languages/english/search.lang.php Verändert
inc/languages/english/memberlist.lang.php Verändert
inc/languages/english/messages.lang.php Verändert
inc/languages/english/showthread.lang.php Verändert
inc/languages/english/showteam.lang.php Verändert
inc/languages/english/datahandler_user.lang.php Verändert
inc/languages/english/stats.lang.php Verändert
inc/languages/english/misc.lang.php Verändert
inc/languages/english/forumdisplay.lang.php Verändert
inc/languages/english/newreply.lang.php Verändert
inc/languages/english/index.lang.php Verändert
inc/languages/english/warnings.lang.php Verändert
inc/languages/english/datahandler_pm.lang.php Verändert
inc/languages/english/online.lang.php Verändert
inc/languages/english/usercp.lang.php Verändert
inc/languages/english/member.lang.php Verändert
inc/languages/english/report.lang.php Verändert
inc/languages/english/modcp.lang.php Verändert
inc/languages/english/moderation.lang.php Verändert
inc/plugins/hello.php Verändert
jscripts/select2/select2.png Verändert
jscripts/select2/select2x2.png Verändert
Admin-Ordner/styles/default/modal.css Verändert
Admin-Ordner/styles/default/main.css Verändert
install/resources/language.lang.php Verändert
inc/languages/english/admin/user_awaiting_activation.lang.php Fehlend


Woran könnte es liegen? Ich habe daran bewusst keine Änderungen vorgenommen.
PS: Der Vollständigkeit halber: Geändert sind die newthread.php und newreply.php, aber die dürften hier ja keine Rolle spielen.
Zitieren