Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
301-Weiterleitung
#11
Ich bin froh das mal einer mit mir die ganzen Möglichkeiten durchgeht! Big Grin 

.htaccess "gewechselt" cache geleert .... keine Änderung. Sad

Ich habe jetzt diese 3 Seiten durchgeackert, aber geholfen hat es nix.

https://www.sistrix.de/frag-sistrix/onpa...ner_Domain

https://seo-summary.de/301-redirect/#funktion

https://pugstaller.com/seo-weiterleitung-301-redirect/
Zitieren
#12
(21.06.2019, 20:27)OTF schrieb: Dodgy Sachmal, wie blöd schätzt Du mich ein???
Wer sollte sich mit dieser Frage angesprochen werden?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#13
(21.06.2019, 21:22)frostschutz schrieb: ...
Debugge dir mal was in den Variablen da eigentlich drinsteht. Zur Not (ohne Serverzugriff) eben auch mit einer "RewriteRule":
Code:
RewriteEngine on
RewriteBase /
RewriteCond https=%{HTTPS}:host=%{HTTP_HOST} (.*)
RewriteRule ^debug$ result?%0 [L,R=302]
und dann mal http(s)://deineseite/debug aufrufen und schauen ob du result?https=on:host=www.deinedomain.com bekommst - oder halt was anderes. Und dann weisst du evtl. warum es nicht klappt.
Code in kopiert und beim https://gaxxxx.de/debug aufruf kam nix.

Zitat:Kriegst du nix, ist das Rewrite-System womöglich komplett tot.

Und da werde ich mal als nächtes nachschauen oder fragen.
Zitieren
#14
(22.06.2019, 16:15)OTF schrieb:
(21.06.2019, 21:22)frostschutz schrieb: Kriegst du nix, ist das Rewrite-System womöglich komplett tot.

Und da werde ich mal als nächtes nachschauen oder fragen.
Das kannst Du eventuell mit einer phpinfo.php mit Inhalt:
PHP-Code:
<? phpinfo(); ?>
sofort selbst prüfen bzw. feststellen.

Bei mir genügte in der .htaccess die Angabe:
Code:
# <IfModule mod_rewrite.c>
RewriteEngine on
# </IfModule>
sowie die Direktumleitung 301
Code:
# Direktumleitungen Start
RewriteRule ^basis\-URL\.de$ /Ziel-URL.de? [L,R=301]
# Direktumleitungen Ende
damit die Umleitungen korrekt funktionierten. Beachte, dass bei der Basis-URL (beispiel) die Zeichen "-" und "." "escaped" werden müssen.
Ob dies je nach Hoster unterschiedlich ist/sein kann, entzieht sich meiner Kenntnis.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#15
(22.06.2019, 16:52)Gerti schrieb: Das kannst Du eventuell mit einer phpinfo.php mit Inhalt:

PHP-Code:
<? phpinfo(); ?>

sofort selbst prüfen bzw. feststellen.

Dodgy  Ich liebe solche Sätze ... Willste wissen warum?

Ich weiß das Du mir helfen willst ... mal ein Beispiel damit Du verstehst was ich meine.

Du fährst im Zug mehrere Male die selbe Strecke und Du merkst das es an der ein und der selben Stelle jedesmal klallt und das es einen Ruck nach rechts gibt.

Und das stört Dich und Du willst das gerne beseitigt haben. Jetzt kommst Du zu mir und erzählst mir von diesen Knall und Ruck.

Ich gehe hin, schaue mir das an, komme wieder und erzähle Dir dann: "Ja da mußte was machen, da wird die Herzstückspitze angefahren."
Das beste ist Du überprüftst mal die Leitweite und Rillenweite vom Radlenker. 

Na dann leg mal loß. Was kannste nicht?  Omg Ist doch kein Problem, das erledige ich Dir in 10 min. Wink

Ich bin auf diesem ganzen Programmier-Gebiet ein Laie und kann mit dem wie es oben steht nicht allzuviel anfangen.
Zitieren
#16
So, ich hatte mich mal mit meinem Webspace-Anbieter in Verbindung gesetzt und der meinte nur ganz trocken: "Auf den ersten Blick scheint das eine Fehlende RewriteRule zu sein..." und er kenne sich mit MyBB nicht aus und so.



Und jetzt fliegen wieder die großen Fragezeichen durch den Raum ... Huh

Aber so wie es aussieht bin ich ja nicht der Einzige, der mit einem Apache-Webserver Probleme mit dieser RewriteRules hat.
Zitieren
#17
Also entweder gehen Rewrites bei dir generell nicht (das zu ermitteln liegt dann beim Webhoster), oder deine .htaccess hat was anderes verquer, z.B. die Sachen in ein <if sonstwasanderes> reingeschrieben wo sie ignoriert werden, oder auskommentiert oder sonstwas. Du könntest mal deine .htaccess in voller Länge posten und ansonsten... brauchst eben jemand der direkt einen Blick draufwirft. Oder einen anderen Webhoster.
Zitieren
#18
(22.06.2019, 21:25)OTF schrieb: Ich bin auf diesem ganzen Programmier-Gebiet ein Laie und kann mit dem wie es oben steht nicht allzuviel anfangen.
Da bist Du nicht der Einzige, also mach Dir da mal keine Sorgen.

Du solltest einfach das tun was man Dir empfiehlt/anbietet und das Ergebnis berichten. Wenn ergänzende Fragen bestehen, dann eben Fragen.

(23.06.2019, 01:22)OTF schrieb: ...und er kenne sich mit MyBB nicht aus und so.
Deine Urprungsanfrage "301-Weiterleitung" hat ja auch nichts mit MyBB zu tun.
(23.06.2019, 01:22)OTF schrieb: Aber so wie es aussieht bin ich ja nicht der Einzige, der mit einem Apache-Webserver Probleme mit dieser RewriteRules hat.
Mir ist nicht bekannt bzw. kann mir nciht vorstellen, das Deine Aufgabenstellung "301-Weiterleitung" vom Apache- oder Linux-Server abhängig sein sollte

Vorschläge hast Du bisher Einige erhalten, was aber hast Du bisher wie umgesetzt und welche Ergebnisse/Fehlermeldungen? (Je detaillierter Deine Angaben, desto effektiver kann man helfen)

Angebot:
Richte einen FTP-Zugang an und definiere deine Aufgabenstellung detailliert. Ich versuche dann Deien Aufgabenstellung umzusetzen. Die Daten bitte nur via PN senden. Nach Ausführung kannst Du den FTP-Zugang wieder löschen.
Die Umsetzung würde ich dann heute Abend oder Morgen versuchen durchzuführen.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#19
Zitat:Oder einen anderen Webhoster.
At Frostschutz: Das wird es wohl sein.

Auf diese etwas laienhafte Frage: 
Zitat:[font=Calibri][font=Arial]Und dann gibt es das leidige 301-Weiterleitung Problem
Kann es sein, dass  ich irgendwie das Rewrite-System deaktiviert habe?
Oder habe ich im Server irgendwas anderes verstellt? Fallen Ihnen irgend welche Fehler auf, die dringend beseitigt werden müssten?
[/font]
[/font]


bekam ich folgende Antwort:
Zitat:[font=Calibri]Auf den ersten Blick scheint das eine Fehlende RewriteRule zu sein und keine fehlende Datei. Suchen Sie sich jemand der sich mit der Forensoftware auskennt und Ihnen Support leisten kann. Wie bereits mitgeteilt ist bei dem Webspace kein Support zu den eingesetzten Scripten enthalten.[/font]


Und, die Datei htaccess.txt ist total jungfräulich, will damit sagen, sie ist so wie bei der Neuinstallation.

Die Antworten auf Gerti´s Fragen kommen auch gleich.

(23.06.2019, 15:16)Gerti schrieb: Du solltest einfach das tun was man Dir empfiehlt/anbietet und das Ergebnis berichten. Wenn ergänzende Fragen bestehen, dann eben Fragen.

Das versuche ich doch auch, wenn ich mit dem angebotenen was anfangen kann. Und mit ner
Zitat:phpinfo.php
-Datei in der
Zitat:<? phpinfo(); ?>
steht, konnte ich so überhaupt nix anfangen. Deshalb auch die Geschichte mit der angefahrenen Herzstückspitze.


Zitat:Deine Urprungsanfrage "301-Weiterleitung" hat ja auch nichts mit MyBB zu tun.

Ja mir ist das mittlerweile klar, aber ob das auch mein Webspace-Anbieter weiß?

Zitat:Mir ist nicht bekannt bzw. kann mir nciht vorstellen, das Deine Aufgabenstellung "301-Weiterleitung" vom Apache- oder Linux-Server abhängig sein sollte.
Irgendwie schon ... nur ein Beitrag den ich hier im Forum gefunden habe.

(28.03.2017, 10:50)KSCNeon schrieb: Vielen Dank für die schnellen Antworten. Auch mit dem Default Theme ändert sich nichts.
Ich habe jetzt den mod_rewrite teil der .htaccess einfach in die vhost kopiert. Jetzt habe ich einen 404 Fehler.
Könnte mir jemand sagen wie ich das integriere und warum nimmt Apache die RewriteRules nicht direkt aus der .htaccess?

Vielen Dank! Smile
Und da kam leider keine Antwort dazu.

Zitat:Vorschläge hast Du bisher Einige erhalten, was aber hast Du bisher wie umgesetzt und welche Ergebnisse/Fehlermeldungen? (Je detaillierter Deine Angaben, desto effektiver kann man helfen)

https://www.sistrix.de/frag-sistrix/onpa...ner_Domain
https://seo-summary.de/301-redirect/#funktion
https://pugstaller.com/seo-weiterleitung-301-redirect/

Ja, Eure Vorschläge und die der hier angebenen HPs angepasst ... versuchsweise an verschiedene Stellen in die Datei htaccess.txt kopiert ... Browser und Forumscache geleert und https://freetools.seobility.net/de/seoch...rawltype=1 aufgerufen und jedesmal festgestellt das sich nix geändert hat.

Zitat:Angebot:
Richte einen FTP-Zugang an und definiere deine Aufgabenstellung detailliert. Ich versuche dann Deien Aufgabenstellung umzusetzen. Die Daten bitte nur via PN senden. Nach Ausführung kannst Du den FTP-Zugang wieder löschen.
Die Umsetzung würde ich dann heute Abend oder Morgen versuchen durchzuführen.

Das klingt ja Super, aber da wird bestimmt das nächste Problem aufkommen .... Ich hab noch nie einen FTP-Zugang eingerichtet. Blush
Zitieren
#20
htaccess.txt ist nur ein Beispiel, die Datei muss .htaccess (beginnend mit . ohne weitere Endung) heissen.

(Ich nehme an du meinst eh das richtige, weil du vorher schonmal .htaccess geschrieben hast, aber jetzt hast du zweimal htaccess.txt gesagt, daher auf Nummer Sicher)
Zitieren