Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.8.15 und PHP 7.2
#1
Hallo,

wie ich im Forum gelesen habe, kann PHP 7.2 seit der MyBB-Version 1.8.6 verwendet werden.

Stelle ich mein Forum-1 auf PHP7.x um, wird mir nur eine weiße Seite angezeigt. Nach Rückstellung auf PHP5.6 funktioniert wieder allls korrekt.

Nein, ein Update von MyBB 1.8.15 auf die aktuelle Version ist derzeit nicht möglich, da ein veraltetes Themee verwendet wird. Vllt. komme ich im Laufe des jhares dazu abzudaten.

Hat mir jemand Tipps wie ich bzgl. eine PHP-Umstellung vorzugehen habe?

Danke vorab mit Gruß ins Jahr 2019
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Wer nicht weiß wohin er will, darf sich nicht wundern wenn er woanders ankommt.
Aktive Version: MyBB: 1.8.21 | PHP: 7.2.13 | SQL: 5.6.38
Zitieren
#2
Hallo,

Du musst einen Fehler in der .htaccess haben. Wenn ich die index.php Deiner Seite direkt aufrufe, funktioniert die Seite Wink .

Grüße
Zitieren
#3
Kein Fehler, da ich wieder zurück auf PHP 5.6 gestellt habe.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Wer nicht weiß wohin er will, darf sich nicht wundern wenn er woanders ankommt.
Aktive Version: MyBB: 1.8.21 | PHP: 7.2.13 | SQL: 5.6.38
Zitieren
#4
(04.01.2019, 14:50)Gerti schrieb: wie ich im Forum gelesen habe, kann PHP 7.2 seit der MyBB-Version 1.8.6 verwendet werden.
Ich weiß nicht, woher du diese Information haben willst. PHP 7.2 wurde erst Ende 2017 veröffentlicht, also über 2 Jahre später als MyBB 1.8.6.

Eine weiße Seite erscheint meist dann, wenn ein PHP-Fehler auftritt, die Anzeige der Fehlermeldung aber unterdrückt wird (was in produktiven Umgebungen durchaus sinnvoll ist). Um dir zu helfen, benötigen wir allerdings die genaue Fehlermeldung.

Unabhängig von deinem Problem handelt sich bei MyBB 1.8.19 um ein wichtiges Sicherheitsupdate, das schnellstmöglich eingespielt werden sollte.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
(05.01.2019, 11:01)StefanT schrieb:
(04.01.2019, 14:50)Gerti schrieb: wie ich im Forum gelesen habe, kann PHP 7.2 seit der MyBB-Version 1.8.6 verwendet werden.
Ich weiß nicht, woher du diese Information haben willst. PHP 7.2 wurde erst Ende 2017 veröffentlicht, also über 2 Jahre später als MyBB 1.8.6.
Siehe hier aus diesem Forum. Ok, da wurde PHP7 und nicht PHP7.2 angesprochen. Habe ich somit inkorrekt interpretiert.
(05.01.2019, 11:01)StefanT schrieb: Eine weiße Seite erscheint meist dann, wenn ein PHP-Fehler auftritt, die Anzeige der Fehlermeldung aber unterdrückt wird (was in produktiven Umgebungen durchaus sinnvoll ist). Um dir zu helfen, benötigen wir allerdings die genaue Fehlermeldung.
Fehler gefunden. Es lag an einer includierten PHP-Datei. PHP7.2 ist nunmehr erfolgreich aktiv.
(05.01.2019, 11:01)StefanT schrieb: Unabhängig von deinem Problem handelt sich bei MyBB 1.8.19 um ein wichtiges Sicherheitsupdate, das schnellstmöglich eingespielt werden sollte.
Welches "wichtige" Sicherheitsrisiko besteht da genau bzw. wird abgedeckt?

Soweit ich ermitteln konnte, ist ein Update wegen des Template vermutlich nciht umsetzbar. Muss mir also erst die Zeit abzwacken und ein neues (passendes) Template (Forum-1) finden um danach ein Update durchführen zu können. Auch stellen einige PlugIns (z.B. Thanks) ein Problem dar.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Wer nicht weiß wohin er will, darf sich nicht wundern wenn er woanders ankommt.
Aktive Version: MyBB: 1.8.21 | PHP: 7.2.13 | SQL: 5.6.38
Zitieren
#6
Ein SQL-Injection-Lücke erlaubt es einem Angreifer unter Umständen Datenbank-Inhalte auszulesen, zu manipulieren oder zu löschen. Dabei können möglicherweise auch (private) Nutzerdaten entwendet oder Admin-Rechte erzwungen werden.

Zwar gab es zwischenzeitlich einige kleine Veränderungen an Stylesheets und Templates, ein neues Theme wird allerdings normalerweise nicht benötigt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Ich habe mal heute den Mut aufgebracht und ein Testforum kopiert.

Die Umstellung von 1.8.15 auf 1.8.19 funktionierte problemlos. Lediglich die global.php, misc.php sowie die global_lang.php musste ich wieder ergänzen (WinMerge ist da eine gute Hilfe).

Dann die Umstellung im Live-Forum (Forum-1) durchgeführt und alles ist Bestens abgelaufen.

Dank an Alle (insbeondere Schnapsnase) für Eure Update-Ausführungen hier im Forum, welche mir doch einiges erleichterten.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Wer nicht weiß wohin er will, darf sich nicht wundern wenn er woanders ankommt.
Aktive Version: MyBB: 1.8.21 | PHP: 7.2.13 | SQL: 5.6.38
Zitieren
#8
Habe leider keine Antwort, sondern eine Frage.
Muss auf den Server von PHP 5.6 auf 7.2 umstellen, was ich auch gemacht habe. Aber dann hatte ich nur noch ein Buchstabensalat.
Da ich mich nicht damit auskenne, stellt sich für mich die Frage, wo etwas geändert werden muss.
Die Umstellung auf MyBB 1.8.19 hat ohne Probleme geklappt.

Gruß

Helmut
Zitieren
#9
Wenn Du nach allen Deiner letzten MyBB-Updates auch die eigenhändig geänderten Templates aktualisiert hast,
dann sollten unter Vers. 1.8.19 keine Probleme mit PHP 7.2.x entstehen.
Denkbar wäre, dass irgendwelche Plugins verrückt spielen.
Deaktiviere doch vor der Umstellung der PHP-Version mal alle Plugins und teste dann nochmal.
Zitieren