Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fette Links in Beiträgen
Hy,
hab ich alles aber nix geht.
siehe Anhang.

   
Gruß Norbert

In der Ruhe liegt die Kraft. Cool

4 x 1.6 PHP Version 5.2.11-0 MySQL 5.0.77
Zitieren
Jetzt ist es über den Quelltext des Templates auch erkennbar.
(12.12.2009, 01:07)Jockl schrieb: Im Quelltext ist zwar zu sehen, dass Du die Klasse postmsg im Template gesetzt hast, in der global.css scheint es diese aber nicht zu geben.
Aber in Deiner global.css ist die Klasse .postmsg nicht definiert!
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
(13.12.2009, 15:03)Jockl schrieb: Jetzt ist es über den Quelltext des Templates auch erkennbar.
(12.12.2009, 01:07)Jockl schrieb: Im Quelltext ist zwar zu sehen, dass Du die Klasse postmsg im Template gesetzt hast, in der global.css scheint es diese aber nicht zu geben.
Aber in Deiner global.css ist die Klasse .postmsg nicht definiert!

Sagst du mir bitte auch wie das nu wieder geht

danke Dir.
Gruß Norbert

In der Ruhe liegt die Kraft. Cool

4 x 1.6 PHP Version 5.2.11-0 MySQL 5.0.77
Zitieren
ACP -> Template&Style -> Themes -> Dein verwendetes Theme -> global.css -> über den Reiter "Stylesheet bearbeiten: fortgeschrittene Methode" die CSS-Codes dieses Beitrages einfügen
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
Das hab ich doch gemacht
die stehen doch auch drin ganz unten.

Aber ich glaub es geht nur nicht bei mir
meine Frau hat eben geschaut und da ging es und bei mir nicht
Ich muss das erst mal abbrechen ich schaff sonst Heute die anderen Sachen nicht

Ich danke Dir und den Rest der Mannschaft und wünsche noch einen schönen 3. Advent

( muss erst mal die Pferde in den Stall bringen )
Gruß Norbert

In der Ruhe liegt die Kraft. Cool

4 x 1.6 PHP Version 5.2.11-0 MySQL 5.0.77
Zitieren
Hallo...

bei mir funktioniert es leider nicht:

Habe ins postbit-classic dies hier eingefügt (bold):
  • <div id="pid_{$post['pid']}" style="padding: 15px 0 5px 0;">
    <p class="postmsg">{$post['message']}</p></div>

Und ins Theme (global.css):
  • .postmsg a {
    font-weight: bold;
    font-size: 20px;
    }


Im Quelltext wird bei mr das im CSS-Eingefügte nicht aufgeführt.
Was mache ich verkehrt?
Zitieren
Versuch es bitte mal mit:
Code:
.postmsg a:link {
font-weight: bold;
font-size: 20px;
}
Gruß NetHunter
Zitieren
Hi NetHunter,

leider, funktioniert auch nicht.

Ich wollte ja eigentlich eine andere Farbe für die Links im Beitrag, ggf. unterstrichen. Wollte nur erstmal das ausprobieren, was hier angegeben war.

Ah.. halt, Korrektur. Es funktioniert. Warum nun auch immer.
Hm.. scheinbar nur bei Firefox. IE zeigt keine Veränderung.
Komisch, in den Quelltexten steht es, bei Firefox und auch beim IE.

Nachtrag: Probiere selbst noch etwas herum, habe ich selbst keine Idee mehr, melde ich mich wieder.
Erstmal danke.

Nachtrag 2: Hat nun geklappt.



Für andere Intessenten nochmal kompakt:

Habe im postbit_classic dies (bold) eingefügt:
  • <div class="postmsg"><p class="postmsg">{$post['message']}</p></div>

Mit <div>, wie von Michael in diesem Thread gesagt, wird der Link auch bei vorherigem Zitieren eingefärbt und unterstrichen

und ins CSS:
  • .postmsg a, .postmsg a:link, .postmsg a:visited {
    text-decoration: underline;
    color: #C40000 !important;
    }

    .postmsg a:hover, .postmsg a:active, .postmsg a:focus {
    color: #464646 !important;
    }

Prima, freu mich.
Zitieren
Prima! Auch Deine Zusammenfassung für die Nachwelt.
Gruß NetHunter
Zitieren