Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Kleine Avatarbasteleien
#1
Da ich kein passendes Thema gefunden habe, eröffne ich jetzt mal eines.
Falls ich den falschen Thread erwischt hab, verschiebt mich einfach ^^



Es geht um kleine Schönheitskorrekturen mit Avatars.

Nachdem es mir jetzt erfolgreich gelungen ist auf der Indexseite für jedes Thema ein eigenes Noava anzeigen zu lassen, würde ich das ganze auch gerne im Profil, in der Mitgliederliste und die kleinen Avas neben dem letzten Post haben.

Aber alle Suche war bisher leider erfolglos, selbst hier hab ich nichts gefunden, was auch nur entfernt passen könnte.

Könntet Ihr mir da bitte helfen? lieb guckt

Vor allem wo ich suchen muss und was ich eingeben soll. Ich vermute mal iwas mit {$theme[imgdir]}
Im acp hab ich das schon so versucht, aber das greift nicht, dann seh ich gar kein Ava.
Im Augenblick werden an den drei genannten Stellen lediglich die default_avas angezeigt.
Zumindest so viel hab ich heraus gefunden, das Ava in der Mitgliederliste häng mit dem im Profil zusammen ^^



hier gehts zum Forum


mybb1.8.19
plugins:
Account Switcher
Jump to top
Anzeige der Mitgliederliste der letzten 24 std
Thread Description
Who is away
Checkbox Validation
Love  Kaffee und Kekse als Dankeschön da lässt   Love
Zitieren
#2
Ich kann nur sagen, wie wir es gemacht haben, dass für jedes Theme überall ein eigener Standard-Avatar angezeigt wird, wenn ein User keinen verwendet.
Wir haben jeweils in den image-Ordner jedes Themes verschiedene Avas hochgeladen, die aber alle default_avatar.png heißen.
Dann haben wir im ACP in den Profileinstellungen unter Standard-Avatar eingetragen:
{theme}/default_avatar.png

Und damit funktioniert alles, wie es sollte. Für jedes Theme wird überall der entsprechende Ava angezeigt.
Schwierigkeiten dürfte es nur geben, wenn mehrere Themes den selben image-Ordner verwenden.
Zitieren
#3
Die noavas sind alle in den Ordnern des jeweiligen Themas
also, der reguläre Pfad (würde man ihn für ein Ava angeben) wäre: images/_themeordner/images/novatar.png

Ein default-avas wären dann images/_themeordner.
Wäre dann nicht der Pfad images/{theme]/default_avatar.png? *grübel*

Aber das werde ich auf jeden Fall nach der Arbeit mal versuchen Big Grin
Love  Kaffee und Kekse als Dankeschön da lässt   Love
Zitieren
#4
Bei images/_themeordner/images/novatar.png wäre der Pfad in den Einstellungen eher:
{theme}/images/noavatar.png
Zitieren
#5
So, ich hab das default_ava aus dem Theme-Ordner einfach gegen die noavas getauscht und sie alle default_ava genannt und zurück in den Theme-Ordner geschoben.
Dein {theme}/default_ava.png klappt besser als erwartet, sogar die Avas im ASC sind davon betroffen Big Grin
(hier wird ein Smilie mit Daumen hoch angezeigt) Top, tausend Däneker


aaaaber Big Grin jaaaa, jetzt kommt noch was

Da sind noch die Avas hinter dem letzten Post auf der Indexseite, die sind leider nicht betroffen.

Deffiniert sind sie in der funktions_forumlist.php mit folgendem Code:
Code:
##avatar##
$uid = intval($lastpost_data['lastposteruid']);
$user = get_user($uid);
if ($user['avatar'] != "")
{
$forum['lp_avatar'] = '<img src="'.$user['avatar'].'" height="71" width="50" title="'.$user['username'].' \'s avatar." alt="" />';
}
else
{
$forum['lp_avatar'] = '<img src="images/default_avatar.png" height="71" width="50" title="Default Avatar" alt="" />';
}
##avatar##

ausgeworfen werden sie dann in der forumbit_depth2_forum_lastpost mit {$forum['lp_avatar']}.

So, wie bekomme ich da jetzt meine default_avas oder meine Noavas rein? Ich hab in der php mal rumexperimentiert, aber mit {$theme[imgdir]} funst es nicht, da bekomme ich nen sql error gemeldet.  mit [imgdir] alleine sehe ich keine Avas, genauso wie mit {theme} oder {$theme} (n allen Variationen die mir einfielen). Ich bin mal wieder mit meinem Latein am ende  Confused
Love  Kaffee und Kekse als Dankeschön da lässt   Love
Zitieren
#6
Du kannst ja mal deinen gesamten Code ersetzen durch:

PHP-Code:
##avatar##
$uid = (int)$lastpost_data['lastposteruid'];
$user get_user($uid);

$lastavatar format_avatar($user['avatar'], '50|71''71|71');
$forum['lp_avatar'] = '<img src="'.$lastavatar['image'].'" '.$lastavatar['width_height'].' title="'.htmlspecialchars_uni($user['username']).' \'s avatar." alt="" />';
##avatar## 
Zitieren
#7
Wuhuuuuu das funktioniert *umärmelt* Daaaankeeeee *freu freu freu*

Beer *Kiste Bier da lässt*

Jetzt bin ich (fast) glücklich...
Könntet ihr mir hier vielleicht auch noch helfen? *ganz lieb schaut*
Love  Kaffee und Kekse als Dankeschön da lässt   Love
Zitieren
#8
Ich bräuchte bitte noch mal Eure klugen Köpfe

Ich hab mir jetzt ein Gast-Avatar gemacht, im Post wird es wunderbar angezeigt, aber wie bekomme ich es jetzt auf die Indexseite?

Anders rum gefragt, was müsste ich in der funktion_forumlist.php und im depth2_forum_lastpost.tpl eintragen, damit es auch angezeigt wird, wemm ein Gast etwas geschrieben hat?
Love  Kaffee und Kekse als Dankeschön da lässt   Love
Zitieren