Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Unerwünschtes Themenabo nach Beitragserstellung über Quick Reply
#1
Hallo ihr Lieben,

ich wurde in unserem Forum darauf aufmerksam gemacht, dass beim Antworten das jeweilige Thema direkt zu den Abonnements gesetzt wird, was so nicht gewünscht ist. Zuerst dachte ich auch, dass ich mich selbst nur irgendwo verklickt habe aber da nun mehrere unser User dieses Problem haben, scheint da was nicht zu stimmen.

Im Benutzer CP ist die Einstellung "Standard-Abonnierungsmodus für Themen, in denen du gepostet hast:" auf "Nicht abonnieren" eingestellt.

Ich selbst nutzte zudem auch gerne die Schnellantwort und hatte unter der eigentlichen Antwortmöglichkeit (im Editor) mal nach den Themen Abonnement geschaut. Dieser ist tatsächlich auf den zweiten Radiobutton eingestellt (Abonnieren, ohne bei einer neuen Antwort eine Benachrichtigung zu erhalten) - das Alerts schlägt an. Nach dem Umstellen und dem erneuten Antworten über den Editor scheint das Thema auch nicht mehr abonniert zu sein aber sobald ich wieder das bequeme Quick Reply nutzte, hat es sich wieder verstellt.

Was könnte da schief gegangen oder übersehen worden sein?

Zuletzt hatte ich unser Forum von 1.8.15 auf 1.8.18 geupdated.
Die PHP Version ist die 7.0, falls das hilft.
Link zum Forum: https://behind.the-shades.de

Anbei auch einfach noch den Inhalt des showthread_quickreplys-Templates:
Code:
<div id="quickreply_spinner" class="showthread_spinner" style="display: none"><img src="{$theme['imgdir']}/spinner.gif" /></div>
<br />
{$moderation_notice}
<form method="post" action="newreply.php?tid={$tid}&amp;processed=1" name="quick_reply_form" id="quick_reply_form">
    <input type="hidden" name="my_post_key" value="{$mybb->post_code}" />
    <input type="hidden" name="subject" value="RE: {$reply_subject}" />
    <input type="hidden" name="action" value="do_newreply" />
    <input type="hidden" name="posthash" value="{$posthash}" id="posthash" />
    <input type="hidden" name="quoted_ids" value="" id="quoted_ids" />
    <input type="hidden" name="lastpid" id="lastpid" value="{$last_pid}" />
    <input type="hidden" name="from_page" value="{$page}" />
    <input type="hidden" name="tid" value="{$tid}" />
    <input type="hidden" name="method" value="quickreply" />

    <table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
        <thead>
            <tr>
                <td class="thead{$collapsedthead['quickreply']}" colspan="2" style="position:relative;">
                    <div class="expcolimage"><img src="{$theme['imgdir']}/collapse{$collapsedimg['quickreply']}.png" id="quickreply_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
                    <div><strong>{$lang->quick_reply}</strong></div>
                </td>
            </tr>
        </thead>
        <tbody style="{$collapsed['quickreply_e']}" id="quickreply_e">
            <tr>
                <td class="{$trow}" valign="top" width="22%">
                    <strong>{$lang->message}</strong><br />
                    <span class="smalltext">{$lang->message_note}<br /><br />
                    {$option_signature}
                    <label><input type="checkbox" class="checkbox" name="postoptions[disablesmilies]" value="1" />&nbsp;<strong>{$lang->disable_smilies}</strong></label>{$closeoption}</span>
                </td>
                <td class="{$trow}">
                    <div style="width: 95%">
                        <textarea style="width: 100%; padding: 4px; margin: 0;" rows="8" cols="80" name="message" id="message" tabindex="1"></textarea>
                    </div>
                    <div class="editor_control_bar" style="width: 95%; padding: 4px; margin-top: 3px; display: none;" id="quickreply_multiquote">
                        <span class="smalltext">
                            {$lang->quickreply_multiquote_selected} <a href="./newreply.php?tid={$tid}&amp;load_all_quotes=1" onclick="return Thread.loadMultiQuoted();">{$lang->quickreply_multiquote_now}</a> {$lang->or} <a href="javascript:void(0)" onclick="Thread.clearMultiQuoted(); return false;">{$lang->quickreply_multiquote_deselect}</a>.
                        </span>
                    </div>
                </td>
            </tr>
            {$captcha}
            <tr>
                <td colspan="2" align="center" class="tfoot">{$as_post}&nbsp;<input type="submit" class="button" value="{$lang->post_reply}" tabindex="2" accesskey="s" id="quick_reply_submit" /> <input type="submit" class="button" name="previewpost" value="{$lang->preview_post}" tabindex="3" /></td>
            </tr>
        </tbody>
    </table>
{$guestterms}</form>

Liebe Grüße
Amu
Zitieren
#2
ein bekannter Bug in der 1.8.18, siehe hier: https://community.mybb.com/thread-219406.html und weitere dort verlinkte Seiten inkl. Fix
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
Zitieren
#3
Komme auf githup echt nicht zurecht von der Übersicht Big Grin muss man nun nur in der newreply.php


if(!isset($postoptions['subscriptionmethod']))
zu
if(!isset($postoptions['subscriptionmethod']) || ($postoptions['subscriptionmethod'] == "dont" && $mybb->get_input('method') == "quickreply"))

ändern oder hab ich noch was übersehen.
Zitieren
#4
Auf MyBB 1.8.19 zu warten ist vermutlich einfacher und weniger fehleranfällig als diesen etwas umfangreicheren Fix manuell einzubauen. Wink

Die Frage von lenox verstehe ich allerdings nicht, die Zeile kommt im Fix gar nicht vor.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
@Stefan das war von Effone hier: https://github.com/mybb/mybb/pull/3416#i...-416479386
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
Zitieren
#6
In MyBB 1.8.16 und 1.8.17 wurden vorhandene Abonnements durch die Schnellantwort gelöscht. In MyBB 1.8.18 werden stattdessen überall welche hinzugefügt.
Ich hatte mir für 1.8.17 einen provisorischen Fix gebastelt, der zum Glück auch noch mit 1.8.18 funktioniert, daher warte ich mal in Ruhe ab, was die nächsten Updates für die Abonnements so bringen. Toungue
Zitieren
#7
Es werden auf jeden Fall keine Abonnements mehr hinzugefügt, weitergehend habe ich das allerdings nicht getestet. Hier im Forum ist der (offizielle) Fix auch bereits eingespielt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
(11.09.2018, 15:42)bv64 schrieb: @Stefan das war von Effone hier: https://github.com/mybb/mybb/pull/3416#i...-416479386

Genau das meinte ich  Shy



(11.09.2018, 16:08)doylecc schrieb: In MyBB 1.8.16 und 1.8.17 wurden vorhandene Abonnements durch die Schnellantwort gelöscht. In MyBB 1.8.18 werden stattdessen überall welche hinzugefügt.
Ich hatte mir für 1.8.17 einen provisorischen Fix gebastelt, der zum Glück auch noch mit 1.8.18 funktioniert, daher warte ich mal in Ruhe ab, was die nächsten Updates für die Abonnements so bringen. Toungue

Und wie sieht der Fiix aus  Big Grin? Den bis 1.8.19 kommt wird es ja wahrscheinlich noch was dauern und wenn da wieder Fehler auftauchen werde ich das Update auch  überspringen wie in der Vergangenheit. Habe da auch alle Updates seit 14 wegen Bugs übersprungen bis zur jetzigen 18.
Zitieren
#9
(11.09.2018, 21:09)lenox schrieb: Den bis 1.8.19 kommt wird es ja wahrscheinlich noch was dauern
Die Wette hättest du verloren. Wink MyBB 1.8.19 findest du bereits auf unserer Download-Seite, die Ankündigung folgt in Kürze.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#10
(11.09.2018, 21:20)StefanT schrieb:
(11.09.2018, 21:09)lenox schrieb: Den bis 1.8.19 kommt wird es ja wahrscheinlich noch was dauern
Die Wette hättest du verloren. Wink MyBB 1.8.19 findest du bereits auf unserer Download-Seite, die Ankündigung folgt in Kürze.

OK dann habe ich mich wohl geirrt  Big Grin
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Exclamation Quick Reply lädt beim absenden ewig styria 8 610 28.03.2017, 12:22
Letzter Beitrag: styria