Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Error 42 / 43
#1
Hallo Fachleute von myBB,

Vorwort:
ein myBB-Forum wurde leider geschlossen, da der eigentliche Betreiber so Ruckzuck emotional kein Interesse mehr hatte. Es ist wie es ist. Eine Datenbanksicherung (März 2017) des Forums habe ich nun freundlicherweise (eher gnädigerweise) erhalten, weil er eingesehen hat dass die enthaltenen Daten für andere User noch wichtig sind.


Folgendes durchgeführt:
1. myBB Software V1.18.14 installiert
2. Datenbank eingerichtet
3. Backup eingespielt
4. Passwort des Admin via SQL-Befehl auf "test" umgestellt
5. Hinweis das ein Upgrade durchgeführt werden muss
6. Upgrade meldet das das Forum zur Zeit gesperrt ist
7. Lock-Datei entfernt
8. Benutzernamen und Passwort eingegeben
9. Upgrade meldet das das Passwort nicht korrekt ist
> Meldung:
das Passwort ist nicht korrekt. Wenn vergessen, klicke hier...
10. Nach dem anklicken kommt die Error-Meldung 43  (Install not locked)
11. Lock-Datei erstellt

* und dann beginnt es wieder bei Punkt 5 (es dreht sich also alles im Kreis)

Kann mir jemand behilflich sein, wie ich das Forum zum funktionieren bekomme?

Alternativ wie ich das Forum (alte Version?) aufsetzen muss um mit der bestehenden Datenbank ein funktionierendes Forum erreichen zu können?

Vorab besten Dank für jedwede Hilfestellung.

Herki
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#2
(08.02.2018, 10:13)Herki schrieb: 4. Passwort des Admin via SQL-Befehl auf "test" umgestellt

Hast du den korrekten Befehl dafür verwendet?
https://community.mybb.com/thread-85406-...#pid624568
Zitieren
#3
(08.02.2018, 12:41)doylecc schrieb: Hast du den korrekten Befehl dafür verwendet?
https://community.mybb.com/thread-85406-...#pid624568
Aber selbstverständlich. Genau wie im Link habe ich die PW-Änderung durchgeführt. Der Passwortcode für "test" steht korrekt in der Datenbank beim User mit "uid" 1

Es muss doch irgendwie möglich sein ein neues myBB-Forum mit alter Datenbank aufsetzen zu können *grummel
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#4
Zur Not könntest du auch das Upgrade ohne eingeloggt zu sein durchführen:
https://www.mybb.de/forum/thread-13462-p...l#pid96456
Zitieren
#5
Um eine bestehende Datenbank (du hast ja ein Backup) nutzen zu können, musst du MyBB doch gar nicht installieren!

Finde heraus welche Version des MyBB zu dem Zeitpunkt genutzt wurde wo das DB-Backup gemacht wurde. Lade dir diese Version runter (Archiv hier auf der Downloadseite). Lade die MyBB Dateien und Ordner hoch und passe die config.php an und trage dort die Daten der neu angelegten DB ein. Importiere das Backup in die neue DB und dann musst du natürlich noch darauf achten dass eventuell die Foren URL noch angepasst werden muss falls sich die Domain des Forums zu damals geändert hat.

Installieren oder updaten musst du da zunächst nichts. Wichtig ist nur das sowohl die damals verwendete MyBB Version die im Backup DB und auch die MyBB Version gleich sind. Sonst hast du unter Umständen nicht alle Tabellen die du für den Betrieb des MyBB benötigst. In den verschiedenen MyBB Versionen kommen ja auch ab und an mal Tabellen hinzu oder es iwrd etwas an der Datenbankstruktur verändert.

Wenn alles läuft und du z.B. nun MyBB 1.8.10 wieder hergestellt hast, kannst du dann das Update machen auf die aktuellste MyBB Version.
Zitieren
#6
(08.02.2018, 14:15)doylecc schrieb: Zur Not könntest du auch das Upgrade ohne eingeloggt zu sein durchführen:
https://www.mybb.de/forum/thread-13462-p...l#pid96456
Danke! *freu jetzt wird mir das Update angezeigt.

Es erscheint eine Auswahl aller vorherigen Versionen um ein Update durchzuführen auf 1.8.14 durchführen zu können. Installiert habe ich ja vorgestern diese Verison (neues Forum) ..nur die Datenbank ist älter.

Wie finde ich (anhand der Datenbank?) heraus von welcher (Ursprungs-)Version ich ein Update tätigen muss? Oder einfach eine auswählen?
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#7
Du könntest in der Datenbank nachschauen, in der Tabelle mybb_datacache gibt es den Eintrag version, darin steht eigentlich die MyBB-Version, die zuletzt installiert war.
Zitieren
#8
Wink 
(08.02.2018, 15:01)doylecc schrieb: Du könntest in der Datenbank nachschauen, in der Tabelle mybb_datacache gibt es den Eintrag version, darin steht eigentlich die MyBB-Version, die zuletzt installiert war.
Ergebnis:
Code:
a:2:{s:7:"version";s:6:"1.2.10";s:12:"version_code";i:1210;}
Denke dann war es die 1.2.10 (was für eine alte Version) das Upgrade wurde nun "erfolgreich" durchgeführt. Hat einige Zeit gedauert.  Blush 
An dieser Stelle mal ein ganz herzlichen Danke für Deine Hilfestellungen.

Rufe ich die neue Forum-URL auf, enthält es kein Template und will ich mich einloggen, verweisen alle anklickbaren Links auf die ursprünglich URL (alte Forums-URL). Wie könnte ich die alten URL-Links z.B. mit einem SQL-Befehl auf die neue URL ändern?

Welche Möglichkeiten gibt es ansonsten um sich im ACP des Forum anmelden zu können damit ein Template zugewiesen werden kann?

EDIT:
habe mich unter Direkteingabe von "URL/member.php?action=login" einloggen können.

Jetzt wird mir eine lange Liste mit Fehlermeldungen angezeigt welche stets auf die Datei "inc/functions_forumlist.php" mit meisten dem Hinweis "PHP 5.6.32-nmm1 (Linux)" und ab und an mit "(385) : eval()'d code PHP 5.6.32-nmm1 (Linux)" endet. Die fehlermeldungen kamen auch beim Update, waren aber immer mit "Weiter" zu bestätigen und am Ende kam die Meldung "Update erfolgreich"
Die Fehlermeldung lautet: "385" = "eval" und "154" = "bulid_formbits"
Im Verzeichnis "inc" ist die dDatei "function_formlist.php" nicht zu finden.

Auch wird die Datei "/index.php" in Zeile "378" mit "bulid_formbits" bemängelt obwohl die Datei nur 35 Zeilen hat.

Was tun? Bin richtig gefrustet.

Hinweis: früher lief das Forum unter http://OldURL.de und jetzt unter https://SUB.NewURL.de vielleicht hilft bei der Lösungsfindung.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#9
In der Datei inc/settings.php die Foren-URL (bburl) und die Cookiedomain und ggf. auch den Cookiepfad anpassen. Anschließend im ACP unter Konfiguration - Seitendetails das wiederholen und abspeichern, dann sollten auch die Styles wieder geladen werden.
Zitieren
#10
hi!
hast du alle chmod einstellungen gemacht? so hats mich unlängst nach einem rückspielen aufgestellt.
hast du im acp die pfade richtig gemacht?
noch was: hab am selben server 2x genau die selbe version installiert. auf einer kein problem, auf der anderen hat das board komplett gesponnen.
erst als mir @MrBechreitz den tip gegeben hat ein cookie präfix anzugeben war ruhe. warum auch immer...
vllt hilt dir ja was weiter...
greets
sjfm
Zitieren