Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.13 veröffentlicht (07.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
mycode rel="noopener"
#1
Wird dies automatisch jetzt jedem ausgehenden Link hinzugefügt?
Falls ja, dann geht dies bei mir teilweise nicht. habe einen link nachträglich als admin bei einem anderen user in einem beitrag eingefügt und dort schaut es dann so aus:


Angehängte Dateien Thumbnail(s)
   
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#2
Ich denke das dein Titel nicht aussagekräftig ist und viele nicht wissen was du eigentlich für ein Problem hast.

rel="noopener" ist eine Sicherheitsmaßnahme die Verlinkungen sicherer machen.


Links absichern mit rel=“noopener“
Gruß Stephan Shy
Zitieren
#3
(10.11.2017, 22:51)hkkp schrieb: Wird dies automatisch jetzt jedem ausgehenden Link hinzugefügt?
Wenn man der Liste der geänderten Dateien Glauben schenken mag, dann ist dem so....
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#4
(10.11.2017, 22:51)hkkp schrieb: Falls ja, dann geht dies bei mir teilweise nicht.
Ein bisschen präziser geht es nicht? Wink Das kann an veralteten Dateien, Template oder auch Plugins liegen. Ohne weitere Informationen, kann ich dazu nur meine Glaskugel befragen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Kleine Zwischenfrage:
was ist der Unterschied zwischen nofollow und noopener?

Die Links die in einen Beitrag eingebunden werden haben nofollow.
Der www-Link eines Users z.b. hat noopener
Liebe Grüße
Tom
Zitieren
#6
In dem von wintstar verlinkten Beitrag ist das recht gut erklärt.....
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#7
(11.11.2017, 14:58)Jockl schrieb: In dem von wintstar verlinkten Beitrag ist das recht gut erklärt.....

ahhh - hab den Link übersehen. Danke

Bei mir ist es wie bei hkkp.

Gibt man einen Link ein (egal ob direkt in einen Beitrag oder über MyCode) so steht im Link nur:
...rel="nofollow"... und nicht ......rel="noopener nofollow"...... so wie es eigentlich die neue inc/class_parser.php vorgeben müsste:
Code:
if(!empty($this->options['nofollow_on']))
{
$rel = " rel=\"noopener nofollow\"";
}
else
{
$rel = " rel=\"noopener\"";
}
Liebe Grüße
Tom
Zitieren
#8
Wie gesagt, das kann viele Ursachen haben. Von veralteten Template über modifizierte Dateien bis hin zu Plugins. Ohne weitergehende Informationen kann ich leider nicht weiterhelfen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Ich habe auch ein stark verändertes MyBB am laufen, was bei Updates auch immer viel Arbeit für mich ist.
Das Problem wie ihr es mit den ausgehenden Links habt, habe ich allerdings nicht. Diese werden schön brav mit dem rel versehen. Mögliche Ursache kann auch ein nicht korrektes Upgrade sein, oder auch Fehler bei der Übertragung mit dem FTP Clienten. Wie es Stefan schon erwähnte, es kann an vielerlei mögliche Ursachen liegen.

Um Plugins auszuschliessen, einfach mal in den ACP Einstellungen das Option Alle Plugins deaktivieren klicken und dann nachsehen ob die Links noch immer fehlerhaft sind.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#10
Hab mittlerweile etwas rausgefunden. Weiß leider nicht ob es relevant ist.

Sobald ich bei der Erweiterung Google SEO Meta den Wert für NofollowLink auf 0 setze bekomme ich im zwar kein nofollow mehr aber dafür steht rel="noopener"

Setzt ich in dieser Einstellung einen anderen Wert als 0 ist der noopener wieder weg.

Nachtrag:
in der neuen inc/functions_post.php sieht es so aus:
   
Liebe Grüße
Tom
Zitieren