Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Installationsfehler!
#1
Mittag allerseits?
Ich habe soeben versucht MyBB zu installieren. Dies ging auch bis zum Schritt der Datenbank. Ich habe die Daten eingegeben und die Datenbank eingerichtet. Die Tabelle wurde erstellt und ich habe auf "Next" geklickt. Dann kam ein Error. "MyBB has experienced an internal SQL error and cannot continue. Access denied for user root@localhost using password yes unable to connect to mysql server." Schritt zurück gegangen Passwort neu eingesetzt wieder der gleiche Fehler, was mich wundert da die Tabellen ja zuvor erstellt wurde.
Hoffe auf Hilfe
Mit freundlichen Grüßen
Lukas
Zitieren
#2
Enthält dein Datenbank-Password Anführungszeichen oder Backslashes? Das könnte zu Problemen beim Schreiben der Konfigurations-Datei führen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
hi!
hab so was ähnliches... umzug auf neuen server, 1.14 rauf.
nach der erfolgreichen inst bekomme ich beim aufruf des forums:


MyBB has experienced an internal SQL error and cannot continue.

SQL Error:0 - Query:SQLSTATE[HY000]: General error: 1 no such table: mybb_datacache


ok, in den phpmyadmin hab ichs am server geschafft. keine tabellen in meiner datenbank! bei der inst hats geheissen, alle dbeinträge angelegt.
das ich dann einen error bekomme ist mit klar.
warum ich aber da lese:

Datenbank-Server
  • Server: Localhost via UNIX socket
  • Server-Typ: MariaDB
  • Server-Version: 10.1.26-MariaDB-0+deb9u1 - Debian 9.1
  • Protokoll-Version: 10
  • Benutzer: xxx@localhost
  • Server-Zeichensatz: UTF-8 Unicode (utf8)
Webserver
  • Apache/2.4.25 (Debian)
  • Datenbank-Client Version: libmysql - mysqlnd 5.0.12-dev - 20150407
  • PHP-Erweiterung: mysqli curl mbstring
  • PHP-Version: 7.0.19-1
localhost, ist mir nicht ganz klar.
was auch lustig ist: wenn ich mich in der 2. db anmelden will, anderer benutzername, selbes passwort, komm ich tropsdem nur in meine db.

  • cache (777)
  • uploads (777)
  • uploads/avatars (777)
  • inc/config.php (666) (benennen Sie zuvor die Datei config.default.php in config.php um)
  • inc/settings.php (666)
allen ordnern hab ich sicherheitshalber 777 gegeben. hatte da schon einmal probs damit beim testboard.
greets
sjfm
Zitieren
#4
Sicher das euer SQL-Server richtig läuft und eingestellt wurde ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
sicherheitshalber überall 777 zu geben ist nun wirklich nicht sicherheitshalber, sondern das absolute Gegenteil
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
Zitieren
#6
hi
bv64, ich meinte die 5 ordner und nicht alle! hatte schon inst probs wegen den rechten.
Mr.B, warum sagt dann die installroutine das alles ok ist!? auch die lock wurde angelegt. nur die db ist einfach leer.
greets
sjfm
Zitieren
#7
Evtl. wude es in eine andere (falsche) DB geschrieben die diese Verbindungsdaten hatte ?

Richtiger Servername, Datenbankname wurde verwendet ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#8
hi!
danke mr.b, ich denk das war der richtige arschtritt!
im myphpadmin steht oben:
Server: localhost:3306
die daten verschwinden im nirvana.
würde auch erklären warum ich mich auf der sql db nicht anmelden konnte und die install nur über myqlli möglich war.
die sache mit dem db wechsel ist geklärt. man muss sich abmelden, dann kommt wieder das anmelde fenster!
greets
sjfm
Zitieren
#9
hi!
und plötzlich funzt es...
naja, mit einer heftigen verkühlung sieht man manchmal den wald vor lauter bäumen nicht!
greets
sjfm
Zitieren
#10
Gesundheit ^^
Mit freundlichen Grüßen

MrBrechreiz
Zitieren