Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[G] Automatische Passwortvergabe fehlerhaft
#11
Der Inhalt der E-Mail wird in der member.php in den Zeilen 446-455 erzeugt.
Damit das gesendete Passwort funktioniert, musst du in allen vier $emailmessage-Zeilen am Ende $user_info['password'] ersetzen durch $mybb->get_input('password')

In den letzten Updates hat sich mehrmals die Passwortfunktion von MyBB geändert (der Accountswitcher hat damit nämlich auch nicht mehr funktioniert Wink  )
Hauptsächlich liegt es daran, dass vorher das Passwort im Klartext blieb, bis unmittelbar bevor es vom User-Datahandler direkt in die DB geschrieben wird, während jetzt das Passwort schon fertig gehasht aus der Validierung zurückkommt - also auch im $user_info-Array in der member.php.
Zitieren
#12
Hmmm.....irgendwo muß da aber ein Fehler sein.

Ich habe jetzt die Zeilen


Code:
case 0:
$emailmessage = $lang->sprintf($lang->email_randompassword, $user['username'], $mybb->settings['bbname'], $user_info['username'], $user_info['password']);
break;
case 1:
$emailmessage = $lang->sprintf($lang->email_randompassword1, $user['username'], $mybb->settings['bbname'], $user_info['username'], $user_info['password']);
break;
case 2:
$emailmessage = $lang->sprintf($lang->email_randompassword2, $user['username'], $mybb->settings['bbname'], $user_info['username'], $user_info['password']);
break;
default:
$emailmessage = $lang->sprintf($lang->email_randompassword, $user['username'], $mybb->settings['bbname'], $user_info['username'], $user_info['password']);
break;


mit

Code:
case 0:
$emailmessage = $lang->sprintf($lang->email_randompassword, $user['username'], $mybb->settings['bbname'], $user_info['username'], $mybb->get_input('password');
break;
case 1:
$emailmessage = $lang->sprintf($lang->email_randompassword1, $user['username'], $mybb->settings['bbname'], $user_info['username'], $mybb->get_input('password');
break;
case 2:
$emailmessage = $lang->sprintf($lang->email_randompassword2, $user['username'], $mybb->settings['bbname'], $user_info['username'], $mybb->get_input('password');
break;
default:
$emailmessage = $lang->sprintf($lang->email_randompassword, $user['username'], $mybb->settings['bbname'], $user_info['username'], $mybb->get_input('password');
break;

ersetzt, dann kommt aber die Fehlermeldung:

Parse error: syntax error, unexpected ';' in /www/htdocs/....../domainname.de/member.php on line 446
Schönen Gruß
Peter



Ich hab´gerade aus dem Fenster geguckt, um zu sehen, wie das Wetter ist.
AUS DEM FENSTER......OBWOHL MEIN HANDY NEBEN MIR LIEGT !!
Cool Wie im Mittelalter
Cool
Zitieren
#13
Ja, da fehlt immer noch eine zweite schließende Klammer ) vor dem ;  ...also
...$mybb->get_input('password'));
Zitieren
#14
Hallo Waldo,

Danke für die schnelle Hilfe, daran lag es !!
Schönen Gruß
Peter



Ich hab´gerade aus dem Fenster geguckt, um zu sehen, wie das Wetter ist.
AUS DEM FENSTER......OBWOHL MEIN HANDY NEBEN MIR LIEGT !!
Cool Wie im Mittelalter
Cool
Zitieren
#15
Ticket: https://github.com/mybb/mybb/issues/2763
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren