Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Impressum und Co. im Offline-Modus anzeigen
#21
(16.07.2020, 07:28)Schnapsnase schrieb: Dann setze in der global.php hinter 'datenschutz.php' ein Komma Wink
Wow, würdest Du verraten wie Du dies erkannt hast? Mit der Konsole scheint mir diese Analyse nicht möglich oder habe ich da etwas übersehen?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#22
(16.07.2020, 07:54)Gerti schrieb: Wow, würdest Du verraten wie Du dies erkannt hast?

Glaskugel!! Big Grin Big Grin
Neee, Beiträge aufmerksam lesen hilft - siehe hier
Zitieren
#23
(15.07.2020, 13:03)itsmeJAY schrieb: Und weshalb sollte man die Hook global_end nicht nutzen können um das Array zu erweitern?
Vielleicht weil der Hooks in diesem Fall gar nicht mehr aufgerufen wird? Wink
(16.07.2020, 07:28)Schnapsnase schrieb: Dann setze in der global.php hinter 'datenschutz.php' ein Komma Wink
Da fehlt kein Komma, denn das ist das letzte Element im Array.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#24
(16.07.2020, 07:28)Schnapsnase schrieb: Dann setze in der global.php hinter 'datenschutz.php' ein Komma Wink

Merci. Verflixte kleine Zeichen. Das ist erfolgt, hochgeladen - keine Statusveränderung.

Überlege, ob ich pragmatischerweise einfach ein Forum hinzufüge, für Gäste auf Lesen setze und dort Impressumstext und Datenschutz reinpacke.
Zitieren
#25
(16.07.2020, 08:11)StefanT schrieb: Da fehlt kein Komma, denn das ist das letzte Element im Array.

Zitat php.net: "Ein hinter dem letzten definierten Arrayeintrag angehängtes Komma ist zwar unüblich, aber dennoch gültige Syntax."

Ein Versuch war`s Wert, obwohl Du Recht hast.
Alles andere sieht ja augenscheinlich o.k. aus und scheint ja bei anderen auch zu funktionieren. Huh
Zitieren
#26
(16.07.2020, 08:15)Stornello schrieb:
(16.07.2020, 07:28)Schnapsnase schrieb: Dann setze in der global.php hinter 'datenschutz.php' ein Komma Wink

Merci. Verflixte kleine Zeichen. Das ist erfolgt, hochgeladen - keine Statusveränderung.

Überlege, ob ich pragmatischerweise einfach ein Forum hinzufüge, für Gäste auf Lesen setze und dort Impressumstext und Datenschutz reinpacke.
 versuch das mal , habe ich von hier 
https://www.mybb.de/forum/thread-18823-page-2.html

ergänze dass in deiner impressum.php

Code:
Suche:

define('IN_MYBB', 1);

und füge darunter:

define('THIS_SCRIPT', 'impressum.php');

(oder wie auch immer deine Datei heisst)

sollte dann so ca aussehen:

define('IN_MYBB', 1);
define('THIS_SCRIPT', 'impressum.php');
Zitieren
#27
Ja, rätselhat. Das mit dem eigenen Forum und für Gäste auf Lesen funktioniert auch nicht. Der Hammer muss irgendwo anders, höher, hängen.

Hinweis aus dem verlinkten Thema mit der Allowable Page hat geholfen.

Die impressum.php schaut jetzt so aus:
Zitat:<?php
define('IN_MYBB', 1);
define("ALLOWABLE_PAGE", 1);
define('THIS_SCRIPT', 'impressum.php');
//define('NO_ONLINE', 1); // Wenn Seite nicht in Wer ist online-Liste auftauchen soll

require_once './global.php';

add_breadcrumb('Impressum');

eval('$page = "'.$templates->get('impressum').'";'); // Hier wird das erstellte Template geladen
output_page($page);


Vielen Dank an alle Mit-Helfenden. Mein Anliegen/Problem ist gelöst.
Zitieren
#28
(16.07.2020, 09:01)Stornello schrieb: Ja, rätselhat. Das mit dem eigenen Forum und für Gäste auf Lesen funktioniert auch nicht. Der Hammer muss irgendwo anders, höher, hängen.

Hinweis aus dem verlinkten Thema mit der Allowable Page hat geholfen.

Die impressum.php schaut jetzt so aus:
Zitat:<?php
define('IN_MYBB', 1);
define("ALLOWABLE_PAGE", 1);
define('THIS_SCRIPT', 'impressum.php');
//define('NO_ONLINE', 1); // Wenn Seite nicht in Wer ist online-Liste auftauchen soll

require_once './global.php';

add_breadcrumb('Impressum');

eval('$page = "'.$templates->get('impressum').'";'); // Hier wird das erstellte Template geladen
output_page($page);


Vielen Dank an alle Mit-Helfenden. Mein Anliegen/Problem ist gelöst.
Hauptsache es funktioniert :-)
Ich selber habe NULL AHNUNG von der programmiererei , aber ich "schnitze" mir dass immer irgendwie zusammen... 
Sorry an alle Fachleute hier, aber ich mach nur und verstehe davon Bahnhof 
Zitieren
#29
@tc4me

Warum schreibst Du eigentlich innerhalb von \[quote\]?
Das lässt sich sehr schlecht lesen. Wink
Zitieren
#30
Curser verirrt :-))
Zitieren