Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler nach Update - Einloggen über Subdomain nicht möglich
#1
Hallo Ihr,

ich habe eben ein Update von 1.1.7 auf 1.2.1 gemacht. Es hat auch alles funktioniert. Das einzige unschöne ist:

Ich kann mich über http://www.domain.tld/forum/ einloggen, über die Subdomain http://forum.domain.tld funktioniert das einloggen jedoch leider nicht Sad

Vor dem Update hat dies funktioniert. Kann mir jemand helfen?

Gruß
Willow
#2
Das liegt wahrscheinlich an falschen Cookie-Einstellungen. Mit zwei verschiedenen Domains ist das schwierig umzusetzen. Versuch mal, folgende Einzugeben:

Domain: .domain.tld
Pfad: /
Vantage-Forum: http://vantage-forum.de/
#3
Danke hat funktioniert Smile

Die Cookie-Domain hatte ich schon kontrolliert, hatte aber nicht gedacht, dass es an dem Pfad liegt. Vor allem weil es ja vor dem Update funktioniert hatte :question:
#4
Ich habe mal noch 2 Fragen die sich nach dem Udate ergeben haben. Um nicht noch einen neuen Thread erstellen zu müssen, stelle ich sie hier.

1.
Mir ist aufgefallen, dass ich nach dem Update von 1.1.7 auf 1.2.1 beim erstellen neuer Themen/Antworten keine Smilies in dem Text verwenden kann, da das Auswahlfenster auf der linken Seite nicht da ist (das Fenster für die Beitragsicons ist da). Erst wenn ich auf editieren einer Nachricht gehe, wird mir das Smilieauswahlfenster angezeigt.
Verwendetes Theme: MyBB Default

2.
Es kann sein, dass ich es mit meinem Hoster klären muss, aber ich stelle die Frage hier auch mal, für den Fall einer Endlosschleife im Forencode.
Wenn ich im Benutzer-CP auf Optionen klicke, bekomme ich einen Fehler...
Code:
Fatal error: Allowed memory size of 20971520 bytes exhausted (tried to allocate 5486 bytes) in .../forum/inc/functions.php on line 2635
Auf meinem Webserver läuft PHP Version 5.0.4 und da liegt wohl ein Bug vor siehe hier. Kann jemand bestätigen, dass der Fehler vom PHP Bug herrührt, oder ist es ein Bug im Forencode?
#5
1. Der Fehler wurde schon einmal angesprochen, konnte aber nicht nachvollzogen werden. Kannst du mal im Quelltext gucken, ob irgendein Teil des Fensters da ist?
2. Das liegt daran, dass der Arbeitsspeicher des Servers voll war und das Script deswegen nicht den erforderlichen Speicher zur Verfügung hatte. Dafür musst du dich in der Tat an den Hoster wenden und ggf. ein größeres Webpack/Server nehmen.
Vantage-Forum: http://vantage-forum.de/
#6
Zu 1) https://www.mybb.de/forum/showthread.php?tid=3334

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Hier der Quelltext vom Editieren:
Code:
<!-- end: posticons -->
<tr>
<td class="trow2" valign="top"><strong>Ihr Beitrag:</strong><br /><div style="text-align: center;"><!-- start: smilieinsert -->
<table border="0" cellspacing="1" cellpadding="4" class="tborder" width="150">
<tr>
<td class="thead"><span class="smalltext"><strong>Smilies</strong></span></td>
</tr>
<tr>
<td class="trow1">
<table width="100%" align="center" border="0" cellspacing="0" cellpadding="2" id="clickable_smilies">
<tr>
<td><img src="images/smilies/smile.gif" border="0" class="smilie" alt=":)" /></td>
<td><img src="images/smilies/wink.gif" border="0" class="smilie" alt=";)" /></td>
<td><img src="images/smilies/cool.gif" border="0" class="smilie" alt=":cool:" /></td>
<td><img src="images/smilies/biggrin.gif" border="0" class="smilie" alt=":D" /></td>
</tr>
<tr>
<td><img src="images/smilies/tongue.gif" border="0" class="smilie" alt=":P" /></td>
<td><img src="images/smilies/rolleyes.gif" border="0" class="smilie" alt=":rolleyes:" /></td>
<td><img src="images/smilies/shy.gif" border="0" class="smilie" alt=":shy:" /></td>
<td><img src="images/smilies/sad.gif" border="0" class="smilie" alt=":(" /></td>
</tr>

</table>
</td>
</tr>

</table>
<!-- end: smilieinsert --></div></td>
<td class="trow2">
<textarea name="message" id="message" rows="20" cols="70" tabindex="3">

Hier der Quelltext vom erstellen:
Code:
<!-- end: posticons -->
<tr>
<td class="trow2" valign="top"><strong>Deine Nachricht:</strong><br /><div style="margin:auto"></div></td>
<td class="trow2">
<textarea id="message" name="message" rows="20" cols="70" tabindex="2" ></textarea>

Hier der entsprechende Auszug aus dem Template (bearbeiten)
Code:
{$posticons}
<tr>
<td class="trow2" valign="top"><strong>{$lang->your_message}:</strong><br /><div style="text-align: center;">{$smilieinserter}</div></td>
<td class="trow2">
<textarea name="message" id="message" rows="20" cols="70" tabindex="3">{$message}</textarea>

Hier der entsprechende Auszug aus dem Template (erstellen)
Code:
{$posticons}
<tr>
<td class="trow2" valign="top"><strong>{$lang->your_message}</strong><br /><div style="margin:auto">{$smilieinserter}</div></td>
<td class="trow2">
<textarea name="message" id="message" rows="20" cols="70" tabindex="2">{$message}</textarea>


Ein Anpassen der Ebene im erstellen Template auf die Ebene aus dem bearbeiten Template brachte keinen Erfolg.

Ebenso brachte das erneute Uploaden des jscripts Ordners auch keinen Erfolg.
#8
Nach einer Neuinstallation sind nun alle Fehler weg. Auch die Optionen unter BCP kann ich wieder anzeigen lassen. Da ist das Update wohl ziemlich in die Hose gegangen.

Vielen Dank auf jeden Fall für eure schnellen Antworten


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Keine Anmeldung nach Update möglich snoopy19 3 970 07.06.2007, 02:48
Letzter Beitrag: Michael
  Nach Update 1.2.1 -- Kein Login in Admin-CP möglich Peter38 0 1.320 28.09.2006, 08:14
Letzter Beitrag: Peter38
  Nach 1.2.1 Update kein Aus- und Einloggen mehr möglich Susanne 5 1.826 27.09.2006, 20:37
Letzter Beitrag: Susanne