Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Secure login
#11
Dann kommt:
Zitat:MySQLi error:
Warning: mysqli_error() expects parameter 1 to be mysqli, boolean given in /is/htdocs/wp0000000_1ULQ000000/www/xxx/inc/db_mysqli.php on line 291
Query:
VG,
Susanne
#12
Welche MySQL Version hast du denn? mysqli (mit dem i) sagt mir gar nichts.
Vantage-Forum: http://vantage-forum.de/
#13
Im Ordner inc gibt es eine db_mysqli.php und eine db_mysql.php. Daher wahrscheinlich die "i"-Meldung.
Ich habe MySQL-Client-Version: 4.1.15
VG,
Susanne
#14
MySQLi steht für MySQL Improved und steht seit PHP5 zur Verfügung. Warum der Login allerdings nicht geht kann ich auch nicht sagen. Ist das etwas hosterspezifisches?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#15
Soweit ich weiß nein. Es heißt nur bei anderen Hostern anders. Ich mach mich da mal schlau und melde mich noch mal.
VG,
Susanne
#16
Das hatte ich ganz vergessen. Dieses "secure-login" hat jeder gute bzw. größere Hoster. Auch Strato etc.
Und eigentlich müsste es klappen im MyBB. Da ich gerade ein neues TestBoard installiere, fiel mir das wieder ein/auf.....
Muss ich wohl mal direkt bei meinem Hoster nachfragen?
VG,
Susanne
#17
Wenn das jeder gute Hoster hat, darum kennt es dann kaum einer?
Ich verstehe den Sinn davon noch nicht ganz.

Irgendwo müssen diese Daten ja gespeichert sein.

#18
Also glaubst du ich denke mir das aus? Wende dich doch an die betreffenden Hoster und frag die nach dem Sinn. Wink
VG,
Susanne
#19
Nein, des will ich garnicht. es wundert mich nur, da ich es noch nie gehört habe.

#20
Zitat:Die Identifikation kann auch vom Webserver vorgenommen werden, es reicht dann ein parameterloser mysql_connect();
Kannst du das mal versuchen, also die Parameter entfernen? Suche dazu in der Datei inc/db_mysql.php:
PHP-Code:
$this->link = @mysql_connect($hostname$username$password) or $this->dberror(); 
und ersetze es durch:
PHP-Code:
$this->link = @mysql_connect() or $this->dberror(); 
Wenn du MySQLi benutzt suche in der Datei inc/db_mysqli.php nach:
PHP-Code:
$this->link = @mysqli_connect($hostname$username$password) or $this->dberror(); 
Ersetzen durch:
PHP-Code:
$this->link = @mysqli_connect() or $this->dberror(); 
Vielleicht klappt dieser Secure Login (von dem ich immer noch nichts gehört habe) vielleicht auch nicht mit MySQLi, sondern nur mit MySQL. Ersetze dazu in der Datei inc/config.php
PHP-Code:
$config['dbtype'] = "mysqli"
durch
PHP-Code:
$config['dbtype'] = "mysql"

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.