Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Nach Update 1.6.x > 1.8.7 Probleme mit der Font-Formatierung im Editor
#1
Einen wunderschönen guten Tag Smile

Nach einem Update (nicht durch mich selbst, sondern von den Besitzerinnen des Forums - ich bin nur "Wichtelmännchen" mit Admin-Panele-Zugriff) von 1.6.x auf 1.8.7 kommt es zu Problemen mit dem Editor respektive mit der Schriften-Formatierung.

Man kann zwar die Schriften (zB Impact oder Verdana oder eine neue "installierte" wzB Petit Formal Script oder PT Mono (via Google-Fonts)) im Texteingabefeld des Editors per Editor-Button-Liste auswählen bzw auf den Text anwenden, allerdings wird es im Texteingabefeld nicht bei jeder Schrift auch im neuen Format angezeigt.

Im öffentlichen User-Bereich wird beim Beitrag-Verfassen (zB) ImpactVerdana aber auch PT Mono richtig dargestellt, aber Petit Formal Script nicht. Klickt man auf Vorschau dann werden in dieser aber alle Formatierungen richtig dargestellt - im geposteten Beitrag werden ebenfalls alle Schriftarten korrekt angezeigt:

[attachment=10951] [attachment=10952]

Leider nicht so im PN-Bereich für alle Userinnen (also Registrierte Nutzerinnen inkl Admins, Mods) sowie im internen Bereich (Admins, Mods), da werden sie so wie im öffentlichen Bereich im Editor-Eingabefeld angezeigt, in der Vorschau und in der abgesendeten PN jedoch nicht:

[attachment=10953] [attachment=10954]

(weiter mit den Bildschirmfotos im nächsten Beitrag)

Weiter mit den Bildschirmfotos aus dem internen Bereich (für Admins, Mods), hier also nicht nur PNs sondern auch Beiträge in Threads:

[attachment=10956] [attachment=10957]

Interessant wohl noch der Umstand, dass ein Ankündigungs-Beitrag, der ja öffentlich (dort wo die formatierte Schrift eigentlich) von allen zu sehen ist, allerdings auch so fehlerhaft dargestellt wird, wie intern - vielleicht weil dieser im Admin-Bereich (hier von einer Kollegin und auch vor Jahren) verfasst wurde? Der Text wird also in der Standard-Schriftart angezeigt, die Formatierungs-Auszeichnung/Befehle sieht man ebenfalls:

[attachment=10958]

Hier noch ein paar Bildschirmfotos aus dem Admin-Panele, im Text darunter ein paar Beschreibungen dazu:

[attachment=10959] [attachment=10960] [attachment=10961] [attachment=10962] [attachment=10963]

Unser Forum läuft seit Mitte/Ende 2011 und bis vor Kurzem mit 1.6.x (nicht die letzte 1.6-Version war es, auf die upgedatet wurde). Wir hatten damals schon Probleme mit dem WYSIWIG-Editor, so wurde dann (damals nicht von mir) der Standard-MyCode-Editor eingestellt, oder ein ähnlicher wie markItUp!, das kann ich nun nicht mehr genau sagen. Es wurden wohl einige (WYSIWIG-) Editoren ausprobiert, also auch installiert - und eventuell nicht vollständig wieder gelöscht, nachdem sich gegen sie entschieden wurde...

Die sonstigen Foren-Daten wären:

PHP Version: 5.5.33-1~dotdeb+7.1
SQL Engine: MySQLi 5.5.47
Server-Auslastung: 5.02

Plug ins sind nur zwei Installiert, aber nicht aktiviert:
Hello World! (2.0)
markItUp! Editor (1.0)

Diesen markItUp! Editor habe ich gestern - zumindest - installiert, falls man sich gegen den aktuell aktivierten WYSIWYG-Editor, der wohl ein in (bereits 1.6.x?) myBB implementierter SCEditor ist; Genau kann ich es nicht sagen, da er nicht in der Plug-In-Liste angezeigt wird, es gibt aber sceditor-Dateien;

Über die Konfiguration kann man ganz unten einen "WYSIWIG Editor" auswählen und ein paar Einstellungen machen (vgl Bildschirmfotos). Mysteriös ist, dass - wenn sämtliche auffindbare (!) WYSIWIG-Einstellungen deaktiviert sind - kein vollständiger myBB-Code-Editor angezeigt wird?! Die Formatierungszeile fehlte bei einem Test komplett, nun wird dennoch die WYSIWIG-Formatierungszeile angezeigt...

In den Foreneinstellungen > Smilies und BBCode (ohne Bildschirmfoto) sind alle Radio-Buttons auf "An" bzw "Ja" - bis auf die letzten vier, also die sind nicht aktiviert:
Erlaube Symbol-MyCodes (Wähle "Ja" um die MyCodes für ™, © und ® zu erlauben.)
Erlaube My-MyCodes (Wähle "Ja" um die Nutzung von /me und /slaps zu erlauben.)
Zeige Gästen Bilder in Beiträgen (Wähle "Ja", um Gästen zu erlauben Bilder in Beiträgen zu sehen.)
Zeige Gästen Videos in Beiträgen (Wähle "Ja", um Gästen zu erlauben Videos in Beiträgen zu sehen.)
Gehe davon aus, dass das nichts mit dem Problem zu tun hat.

Die DVZ Shoutbox wurde vor Jahren schon mal ausprobiert, aber (noch) nicht komplett deinstalliert; Hat aber mit dem Problem wohl nichts zu tun.

Style ist MyBB_Hell_Blau - CSS, Farben und tw Grafiken bzw Scripts an die Bedürfnisse vor Ort angepasst; Ich gehe aber davon aus, dass das nichts mit dem Problem zu tun hat...

Kann unser Problem mit den nicht ganz "sauberen" Editor-Testungen (schon vor Jahren und/oder aktuell) zu tun haben?

Wäre eine komplette neue Installation von 1.8.7 in einem anderen Verzeichnis am sinnvollsten?
Zitieren
#2
Das Problem tritt nur auf, wenn HTML aktiviert. Siehe: https://www.mybb.de/forum/thread-33274-p...#pid220245
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Lieber StefanT,
herzlichen Dank für Deine rasche Antwort Smile

Habe nun auch in den PNs HTML deaktiviert - funktioniert bestens. Nur der eine Script-Font wird im Eingabefeld (noch) nicht korrekt dargestellt - aber gut, Hauptsache in der Vorschau und dann in der gesendeten PN.

Die erwähnte globale Ankündigung wird nicht automatisch korrekt umgestellt, man muss diese bearbeiten - da gibt es auch einen Radio-Button unterhalb um "HTML nicht zu erlauben".

Aber - leider noch immer nicht so im internen Bereich (Admins, Mods), da werden sie so wie im öffentlichen Bereich im Editor-Eingabefeld korrekt angezeigt (bis auf die Script), aber noch immer nicht in der Vorschau und auch nicht in den geposteten Beiträgen? Aber dort fand ich im Editor-Fenster keine Radio-Buttons oder sonstige Möglichkeit/en um "HTML nicht zu erlauben".

In der Konfiguration habe ich auch diese Optionen hier auf "Nein" gestellt:
HTML-Kommentare am Anfang/Ende der Ausgabe von Templates?
Diese Einstellung aktiviert die Ausgabe von HTML-Kommentaren am Anfang/Ende von Templates.
XMLHttp-Anfragen aktivieren?
Hier kannst du alle XMLHttp-Funktionen (AJAX) aktivieren oder deaktivieren.

Bringt keine Besserung; Nun ist mir aber aufgefallen, dass man im internen Bereich auch im Editor-Eingabefeld keine korrekte Anzeige mehr bekommt - ganz zu schweigen bei Vorschau oder abgesendetem Beitrag...
Zitieren
#4
Wenn es bei einzelnen Foren nicht funktioniert, ist bei diesen in den Einstellungen HTML weiterhin erlaubt.
(23.03.2016, 11:58)DeGato schrieb: In der Konfiguration habe ich auch diese Optionen hier auf "Nein" gestellt:
HTML-Kommentare am Anfang/Ende der Ausgabe von Templates?
Diese Einstellung aktiviert die Ausgabe von HTML-Kommentaren am Anfang/Ende von Templates.
XMLHttp-Anfragen aktivieren?
Hier kannst du alle XMLHttp-Funktionen (AJAX) aktivieren oder deaktivieren.
Diese Optionen haben mit dem MyCode-Parser nicht das geringste zu tun. Zumindest die 2. Einstellung deaktiviert allerdings zahlreiche Funktionen des Forums; von einer Deaktivierung kann ich nur abraten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Hab ich ohnehin schon rückgängig gemacht; Wo kann ich einzelne Foren auf "No-HTML" denn umstellen?

Nachtrag: Habs gefunden  Blush


Ich danke Dir herzlichst!
Zitieren
#6
Bei jedem einzelnen Forum gibt es in den Foreneinstellungen die Option "HTML erlauben".
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Ja, nochmals danke, habs eh so gefunden - es waren nur 2 der internen Unter-Foren für Amins/Mods betroffen, alles andere war ohnehin auf "No-HTML" eingestellt...
Zitieren
#8
Ich öffne hier nochmals, weil es erneut ein Problem gibt: die Formatierungs-Menü-Leiste des Editors wird in den PNs nicht mehr angezeigt. Es wird auch nur noch der Plain-Text im Eingabefeld angezeigt, Smilies kann man auch nicht mehr einfügen (gar keine Reaktion);

Auch beim Sofort-Antwort-Feld gibt es keine Formatierungs-Leiste (wobei ich aber nicht mit Sicherheit sagen kann, ob sie vorher bereits angezeigt wurde, da ich diese Option bei mir selbst ausgeschaltet hatte). Ebenso wenn man einen Beitrag editieren möchte, wird gleich wie bei den PNs nur noch Plain-Text angezeigt;

Am Editor wurde natürlich nichts herumgebastelt oder irgendwelche Einstellungen zum Editor verändert; Es wurden jedoch ein paar Plug-Ins ausprobiert, zB Link Anonymizer with ssl 1.8.x oder SomeImage Image Uploader - zumindest nach diesen beiden wurde der Ausfall zuerst entdeckt;

Die Plug-Ins wurden freilich wieder deaktiviert und deinstalliert (im ACP, aber noch nicht vom Server gelöscht) - dennoch keine Editor-Menü-Leisten wie zuvor...
Zitieren
#9
Vermutlich tritt ein Javascript-Fehler auf, was allerdings zahlreiche Ursachen haben könnte. Ein Link zu deinen Forum wäre für uns hilfreich.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#10
Link per PN bitte...
Zitieren