Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fatal error: Interface 'DB_Base'
#1
hi leute.

hab eine neues mybb installiert und wollte dann die daten von einem phpbb3 konvertieren. leider kommt beim aufruf des merge-systems die fehlermeldung "Fatal error: Interface 'DB_Base' not found in .../inc/db_mysqli.php on line 12"

hier im forum habe ich den fehler im bezug auf das merge-system nicht gefunden. kann mir vielleicht jemand sagen, warum der kommt?

grüße

frank
Zitieren
#2
Es scheint sich um einen Fehler zu handel, der bereits hier gemeldet wurde. Ein Fix scheint auch vorhanden zu sein: https://github.com/mybb/merge-system/com...35b8b5ae84
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#3
ok. zumindest wird jetzt mal was angezeigt. danke! aber... jetzt kommt auch eine neue fehlermeldung.

"Warning [2] require_once() [function.require-once]: Unable to access .../merge/resources/class_language.php - Line: 70 - File: merge/index.php PHP 5.3.17 (Linux)"

die datei class_language.php existiert gar nicht im merge. :-(
Zitieren
#4
Sollte eigentlich schon vorhanden sein:
https://github.com/mybb/merge-system/tre.../resources
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#5
Beide Fehler sollten beim Merge System 1.8.4 nicht auftreten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
also... das merge von dieser seite funktioniert bei mir nicht. das welches ich unter dem genannten link gefunden habe, funktioniert. allerdings nur bis zu der stelle, wo man dann die daten für die zu kovertierende phpbb-installation eingibt. ich gebe bei db-username und bei db-name usw... die richtigen daten ein, aber es kommt dann immer der fehler

"Error

There seems to be one or more errors with the database configuration information that you supplied:

Could not connect to the database server at 'localhost' with the supplied username and password. Are you sure the hostname and user details are correct?

Once the above are corrected, continue with the conversion."

kann es sein, dass hier nicht alles auf dem gleichen server, sondern sogar im gleichen verzeichnis liegen muss? kann ich mir eigentlich nicht vorstellen. hat doch mit der db nix am hut. bin echt am verzweifeln. :-(
Zitieren
#7
Für MyBB 1.8.4 muss das Merge System 1.8.4 verwendet werden, die Entwicklerversion von Github funktioniert aktuell nicht.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
(28.02.2015, 17:31)StefanT schrieb: Für MyBB 1.8.4 muss das Merge System 1.8.4 verwendet werden, die Entwicklerversion von Github funktioniert aktuell nicht.


MyBB Merge System - Version: 1.8.4 ist verwendet und das forum ist auch ganz frisch. ich bekomm das nicht hin. verdammte axt!

so. anscheinend hab ich ein ganz anderes problem...

ich hab jetzt mal getestet, ob ich in der db vom phpbb einfach das mybb dazu, bzw. drüber installieren kann und dann kam folgendes....

"Fehler

Es gibt ein oder mehrere Probleme mit den Daten, die Sie eingegeben haben:

Die Verbindung zum Datenbankserver unter 'localhost' konnte mit dem angegebenen Benutzernamen und Passwort nicht hergestellt werden. Sind Host und Benutzerdaten korrekt?

Sind die oben aufgeführten Probleme behoben, können Sie mit der Installation fortfahren."

also hab ich wohl ein problem mit dem zugriff auf die "alte" db. leider weiss ich nicht, an was es liegen könnte, denn username, db-name und passwort sind korrekt. :-( :-(
Zitieren
#9
(28.02.2015, 18:49)coaworld schrieb: leider weiss ich nicht, an was es liegen könnte, denn username, db-name und passwort sind korrekt. :-( :-(
Scheinbar nicht. Kann es sein, dass du beim Passwort irgendwelche ungewöhnlichen Sonderzeichen verwendest?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Installation: Admin-Account - Fatal error Hemdale 6 1.751 08.04.2017, 20:15
Letzter Beitrag: Hemdale
  Fatal Error durch class_parser.php bei upgrade Mickilina33 1 964 22.11.2014, 15:39
Letzter Beitrag: StefanT
  Fatal Error bei Upgrade Dreamer 2 1.162 16.09.2014, 17:48
Letzter Beitrag: Dreamer