Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
4-byte UTF-8 Problem
#1
Hi,

ich habe eine Cleaninstallation von MyBB 1.8 auf einer Testdomain eingerichtet und schon ein paar Einträge gemacht (Spielereien halt). Hat auch alles wunderbar funktioniert, keine Probleme. Auch ein paar neue Plugins reingemacht (alle rein 1.8 kompatibel und stable) und auch da keine Probleme.

Nun habe ich mal die Datenbanken auf das UTF8mb4 "geupdated" und auch in der Config eingetragen, hinterher die Datenbanken über MyBB nochmal optimieren lassen. In allen vorherigen Versionen hatte ich damit kein Problem, aber nun werden auf einmal keine Umlaute mehr angezeigt (stattdessen wird ein schwarzes Kästchen mit einem Fragezeichen darin angezeigt) und auch die Posts sind nicht mehr einsehbar, stattdessen steht dort der Text "click to edit".

Den Text selber kann man nicht anklicken, wenn man ganz normal auf "Bearbeiten" geht, wird der eigentliche Text im Post angezeigt, auch hier wieder ohne Umlaute, wenn man das abspeichert wird es dennoch nicht angezeigt (es bleibt "click to edit").


Das Zurückstellen auf das normale UTF8 (indem ich es in der config wieder ändere) hat das wieder behoben. Die Plugins selber nutzen keine Datenbanken und/oder ändern/ergänzen diese, also ist das vermutlich auszuschließen.

Wenn ich die Postings selber während aktiviertem MB4 bearbeite, die Umlaute lösche und wieder neu eingebe und dann abspeichern tu, wird es wieder normal angezeigt. Aber auch so Dinge wie im Benutzer-CP unter den PNs wird "Entwürfe" ebenfalls mit einem Fragezeichen versehen.


Wie gesagt, selbst in vorherigen Versionen mit unmengen an Plugins (ua auch welche die die Datenbank beeinflussen und gar nicht mal so wenige, die schon zu veraltet sind für die laufende Version) hatte ich null Probleme, weshalb ich davon ausgehe dass das ein Bug ist und ich hier hoffentlich richtig bin damit Blush 


MfG!
Zitieren
#2
config falsch geändert? wenn es eine neuinstallation war, warum nicht gleich mit utf8mb4 starten?

es muss nicht zuletzt ja auch in der datenbank und überall sonst eingestellt sein.
Zitieren
#3
Config war korrekt geändert, unter anderem erkennt das Forum das ja auch Wink

Keine Ahnung, ich habe in einer Installation noch nie die Option für MB4 gesehen?

Falls du es überlesen hast:
Es hat bisher immer funktioniert, warum sollte es ausgerechnet jetzt nicht der Fall sein bei der selben Datenbank mit den selben Eigenschaften, etc?
Zitieren
#4
Man kann den Zeichensatz bei der Installation auswählen, da ist auch utf8mb4 in der Liste seit 1.6.??

Zitat:Es hat bisher immer funktioniert, warum sollte es ausgerechnet jetzt nicht der Fall sein

Frag ich mich ja auch, utf8 vs. utf8mb4 macht bei Umlauten ja gerade mal gar keinen Unterschied. Das betrifft ja nur deutlich seltenere Zeichen.

Wenn dann Kästchen draus werden muss irgendeine Umwandlung schiefgegangen sein. Dabei ist gar keine Umwandlung notwendig.

Oder es war vorher halt doch nicht UTF-8.
Zitieren
#5
Ich habe beim Zeichensatz schon lange nicht mehr geschaut gehabt, deswegen ist mir das nicht in den Sinn gekommen^^

Aber ist ja egal ob ich vorher nachher oder gar nicht mache, ist trotzdem noch ein Fehler Wink

Und es war anfangs natürlich UTF8
Zitieren
#6
Liegt wohl an PHP5.6, bei einer Neuinstallation habe ich MB4 angegeben, die Datenbanken wurden erstellt und nach einem Klick auf Weiter wurden Fehler ausgespuckt, die dann 5.6 beinhalteten. Also zurück auf 5.5, Datenbank geleert und nochmal installiert und dann ging es einwandfrei!
Zitieren