Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Xthread
#61
bestimmt zu banal, aber habe jetzt die youtube-galerie bei mybb 1.8 am laufen, aber siehe anhang. hab ich hier was vergessen?
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#62
Die Templates eingerichtet und dem Forum den Präfix gegeben ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#63
(31.05.2015, 19:12)MrBrechreiz schrieb: Die Templates eingerichtet und dem Forum den Präfix gegeben ?

PHP-Code:
<html>
<
head>
<
title>{$thread['subject']}</title>
{
$headerinclude}
<
script type="text/javascript">
<!--
    var quickdelete_confirm "{$lang->quickdelete_confirm}";
    var quickrestore_confirm "{$lang->quickrestore_confirm}";
    var allowEditReason "{$mybb->settings['alloweditreason']}";
    lang.save_changes "{$lang->save_changes}";
    lang.cancel_edit "{$lang->cancel_edit}";
    lang.quick_edit_update_error "{$lang->quick_edit_update_error}";
    lang.quick_reply_post_error "{$lang->quick_reply_post_error}";
    lang.quick_delete_error "{$lang->quick_delete_error}";
    lang.quick_delete_success "{$lang->quick_delete_success}";
    lang.quick_delete_thread_success "{$lang->quick_delete_thread_success}";
    lang.quick_restore_error "{$lang->quick_restore_error}";
    lang.quick_restore_success "{$lang->quick_restore_success}";
    lang.editreason "{$lang->postbit_editreason}";
// -->
</script>
<!-- 
jeditable (jquery) -->
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/report.js?ver=1804"></script>
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/jeditable/jeditable.min.js"></script>
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/thread.js?ver=1804"></script>
</
head>
<
body>
    {$header}
    {$threadnotesbox}    
    
<div class="float_left">
        {$multipage}
    </div>
    <div class="float_right">
        {$newreply}
    </div>    
    
<table width="100%" border="0" cellspacing="{$theme['borderwidth']}cellpadding="{$theme['tablespace']}style="clear: both; width: 100%;">
    <tr>
        <td valign="middle" colspan="2">
            <a href="{$forumurl}"><strong>Kategorien</strong></a>
            <table border="0" width="100%">
                <tr>
                    <td align="center" style="background:#dedede; border-radius: 10px;">
                        <a href="{$forumurl_q}filtertf_ytvgalcat=Kinderfilme"><img src="" alt="" /></a><br />
                        <a href="{$forumurl_q}filtertf_ytvgalcat=Kinderfilme"><strong>Kinderfilme</strong></a>
                    </td>
                    <td align="center" style="background:#dedede; border-radius: 10px;">
                    <a href="{$forumurl_q}filtertf_ytvgalcat=Erwachsenenfilme"><img src="" alt="" /></a><br />
                    <a href="{$forumurl_q}filtertf_ytvgalcat=Erwachsenenfilme"><strong>Filme für Erwachsene</strong></a>
                    </td>
                    <td align="center" style="background:#dedede; border-radius: 10px;">
                    <a href="{$forumurl_q}filtertf_ytvgalcat=Filmefuerdiefamilie"><img src="" alt="" /></a><br />
                    <a href="{$forumurl_q}filtertf_ytvgalcat=Filmefuerdiefamilie"><strong>Filme für die Familie</strong></a>
                    </td>
                    <td align="center" style="background:#dedede; border-radius: 10px;">
                    <a href="{$forumurl_q}filtertf_ytvgalcat=Dokumentationen"><img src="" alt="" /></a><br />
                    <a href="{$forumurl_q}filtertf_ytvgalcat=Funny"><strong>Dokumentationen</strong></a>
                    </td>
                    
                
</tr>
            </table>
        </td>
    </tr>
</
table>    
<table border="0" cellspacing="{$theme['borderwidth']}cellpadding="{$theme['tablespace']}style="border-top-width: 0; width: 100%;">
    <tr>
        <td valign="top" width="50%">
            <div align="center">
                <strong>{$thread['subject']}</strong>
            </div>
            {$ratethread}
            <div align="center">
                <object type="application/x-shockwave-flash" data="http://www.youtube.com/v/{$GLOBALS['threadfields']['ytvgalid']}width="425" height="350"><param name="movie" value="http://www.youtube.com/v/{$GLOBALS['threadfields']['ytvgalid']}"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><param name="FlashVars" value="playerMode=embedded"></param><p>{$thread['subject']}</p></object>
            </div>
            <br class="clear" />
            <div>
                {$first_post}
            </div>
            <br class="clear" />
            <div align="center">
                <strong>&laquo; <a href="{$next_oldest_link}">{$lang->next_oldest}</a> | <a href="{$next_newest_link}">{$lang->next_newest}</a> &raquo;</strong>
            </div>
            <br class="clear" />
            </td>
        <td width="1">&nbsp;</td>
        <td valign="top">
            <div style="float: left;">
                <strong>Kommentare</strong>
            </div>
            
            
<br class="clear" />
            <div id="posts">
                {$posts}
            </div>
            <div class="float_right">
                {$multipage}
            </div>
            </td>
    </tr>
</
table>
    <div style="padding-top: 4px;" class="float_right">
        {$newreply}
    </div>
    <br class="clear" />
    <a name="switch" id="switch"></a>{$quickreply}
    {$threadexbox}
    {$similarthreads}
    <br />
    <div class="float_left">
        <ul class="thread_tools">
            <li class="subscription_{$add_remove_subscription}"><a href="usercp2.php?action={$add_remove_subscription}subscription&amp;tid={$tid}&amp;my_post_key={$mybb->post_code}">{$add_remove_subscription_text}</a></li>            
        
</ul>
    </div>
    <div class="float_right" style="text-align: right;">
        {$moderationoptions}
        {$forumjump}
    </div>
    <br class="clear" />
    {$usersbrowsing}
    {$footer}
    <div id="thread_modes_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="showthread.php?mode=linear&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}class="popup_item">{$lang->linear}</a></div><div class="popup_item_container"><a href="showthread.php?mode=threaded&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}class="popup_item">{$lang->threaded}</a></div></div>
    <script type="text/javascript">
    // <!--
        if(use_xmlhttprequest == "1")
        {
            $("#thread_modes").popupMenu();
        }
    // -->
    </script>
    <script type="text/javascript">
        $(".author_avatar img").error(function () {
            $(this).unbind("error").closest('.author_avatar').remove();
        });
    </script>    
</body>
</
html

so schaut meine ytvgal_showthread aus...
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#64
(31.05.2015, 19:12)MrBrechreiz schrieb: Die Templates eingerichtet und dem Forum den Präfix gegeben ?

Was ist mit dem anderem Teil meiner Frage ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#65
ja das forum hat den vorgegebenen präfix ytvgal_
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#66
lag an einem fehlerhaften plugin im ff
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#67
Und welches ? Kann ja sein das ein anderer User auch diese konstellation hat, und nach Rat fragt.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#68
So, nachdem ich mich nun durch diverse Beiträge in diversen Supportforen durchgewälzt habe, wo es immer nur hieß "Lösung gefunden/Problem behoben", stehe ich immer noch vor folgendem Problem. Ich hoffe, jemand kann mir helfen.

Ich habe die Custom Threadfields nach Anleitung erstellt. 
Die Threadfields sind für Gäste, Mitglieder, Moderatoren und Admins sichtbar.
Ich habe im entsprechenden Forum das Präfix partner_ eingegeben
Ich habe die globalen Templates partner_forumdisplay_threadlist und partner_forumdisplay_thread erstellt und mit Inhalt gefüllt und auch die jeweiligen GLOBALS['threadfields']['key'] hinzugefügt (natürlich als Variable mit $ davor und den richtigen key)


Problem: die Original-Templates werden nicht mit den partner_templates überschrieben.

Hatte jemand dieses Problem schon mal und kennt die Lösung? 

Alle meine Plugins zu deaktivieren und nacheinander wieder zu aktivieren ist etwas, was ich super ungern machen würde, da ich dann den kompletten Style nochmal neu überarbeiten muss (ich hab auch ein Problem mit dem Theme exportieren, aber das tut hier nicht zur Sache).

Ich würde mich freuen, wenn man mir helfen könnte.

LG
Zitieren
#69
Versuche mal bitte statt:
PHP-Code:
{$GLOBALS['threadfields']['key']} 

dies:
PHP-Code:
{$threadfields['key']} 
Zitieren
#70
Hallo Schnapsnase,

hat leider nichts gebracht.

Es wird noch nichtmal das "neue" html übernommen, daher denke ich nicht, dass es an der Variable an sich liegt. Sad


Hinweis: in dem besagten Unterforum, wenn ich ein neues Thema erstelle, werden mir die erstellten Felder angezeigt. Aber eben nicht in der Themenübersicht. Wenn ich im Devtool schaue, stehen da die regulären forumdisplay-thread/_threadlist templates.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Video problem xthread youtube gallery lenox 0 618 21.10.2018, 19:09
Letzter Beitrag: lenox
  XThread Frage TelCont@r 1 829 15.10.2014, 18:26
Letzter Beitrag: MrBrechreiz