Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Logobild im Header
#1
Ich habe folgendes Problem,
Ich möchte den Header meines Forums ändern, z.zt. ist das Headerbild zentriert in der Mitte untergebracht, aufgrund der noch möglichen Auflösung 800 x 600 einiger User die ab und an sich auf meine Seite verlaufen kann ich das Bild nicht breiter als ca. 770 pixel machen, da aber andersherum die meisten doch eine größere Auflösung fahren würde ich das Headerbild lieber dreiteilen, also ein kleine links, ein mittleres in der Mitte und ein kleines rechts, insgesamt sollen die 3 Bilder wieder 770 Pixel nicht überschreiten aber halt je nach Auflösung sich entsprechen zusammen oder auseinander schieben.
(Ich hoffe das war jetzt verständlich)
Gibt es dazu eine Möglichkeit??
#2
So wie du es gesagt hast nicht, aber du kannst einfach ein langes Bild machen und das dann als Hintergrundbild statt als normales BIld nehmen. Das wird dann einfach abgeschnitten, wenn der BIldschirm "aufhört".
Vantage-Forum: http://vantage-forum.de/
#3
Und genau das ist das was ich nicht möchte.
Schade
#4
Was spricht denn dagegen? Das macht optisch keinen Unterschied.
Vantage-Forum: http://vantage-forum.de/
#5
Natürlich geht das. Du kannst einfach eine dreispaltige Tabelle nehmen und dort die Grafiken einsetzen:
Code:
<table width="100%" border="0" cellspacing="0" cellpadding="0">
  <tr>
    <td align="left" valign="middle"><img src="images/logo_links.gif" alt="" border="0" /></td>
    <td width="770" align="center" valign="middle"><img src="images/logo.gif" alt="" border="0" /></td>
    <td align="right" valign="middle"><img src="images/logo_rechts.gif" alt="" border="0" /></td>
  </tr>
</table>

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#6
Klasse Michael, wo setze ich das ein und was mache ich mit dem automatischen Eintrag aus der Themeneinstellung, wenn ich das leer lasse schreibt er mir den Forennamen an der Stelle hin.
#7
Suche im Template header nach:
Code:
<a href="$settings[bburl]/index.php"><img src="$theme[logo]" alt="$settings[bbname]" border="0" /></a>
Ersetzen durch:
Code:
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td align="left" valign="middle"><img src="images/logo_links.gif" alt="" border="0" /></td>
<td width="770" align="center" valign="middle"><a href="$settings[bburl]/index.php"><img src="$theme[logo]" alt="$settings[bbname]" border="0" /></a></td>
<td align="right" valign="middle"><img src="images/logo_rechts.gif" alt="" border="0" /></td>
</tr>
</table>
Was genau meinst du mit "dem automatischen Eintrag aus der Themeneinstellung"?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
Wenn ich im Theme keine Forumslogo eingetragen habe kommt ja folgender Teil der Codezeile in Betracht

Code:
alt="$settings[bbname]" border="0" /></a>

Da ich die Zeile ja ersetzen soll ist das ja hinfällig, danke für den Tip
#9
Dann musst du dein Logo im Template header einfach durch den Code ersetzen:
Code:
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td align="left" valign="middle"><img src="images/logo_links.gif" alt="" border="0" /></td>
<td width="770" align="center" valign="middle"><a href="index.php"><img src="images/logo.gif" alt="" border="0" /></a></td>
<td align="right" valign="middle"><img src="images/logo_rechts.gif" alt="" border="0" /></td>
</tr>
</table>

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#10
Klappte wunderbar, danke Michael