Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Danke Plugin
scheinbar bin ich zu doof....

PHP-Code:
{
            
$post['thanks'] = "<a id=\"a{$post['pid']}\" onclick=\"javascript:return thx({$post['pid']});\" href=\"showthread.php?action=thank&tid={$post['tid']}&pid={$post['pid']}"\ class=\"newthbutton\">
            "
<class="fa fa-thumbs-up">Danke</i></a>";
        } 
 weisse seite :-(
Zitieren
Vor class=\"newbutton\" hast du \ und " vertauscht. Wink
Zitieren
mhh danke aber daran lag es wohl nicht...

sobald das Plugin auf dem Server liegt erhalte ich nur ne weisse seite
Zitieren
PHP-Code:
{
            
$post['thanks'] = "<a id=\"a{$post['pid']}\" onclick=\"javascript:return thx({$post['pid']});\" href=\"showthread.php?action=thank&tid={$post['tid']}&pid={$post['pid']}\" class=\"newthbutton\">
            <i class=\"fa fa-thumbs-up\">Danke</i></a>"
;
        } 
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
Perfekt nun klappt es....

nur leider ist es der falsche Button der erstellt wurde...
auch hier ist es ne andere Schriftart (die beiden Pfeile) ... lässt sich das irgendwie beheben ?

   

edit: den richtigen Button hab ich jetzt, aber wie regele ich das mit der Schriftart ?

Ebenso wäre gut zu wissen, in welchem Tenplate das "danke erhalten usw." , welches unter dem Avater steht zu bearbeiten ist, dass es auch in solchen Tabellen angezeigt wird wie z.B. Verwarnlevel
Zitieren
Statt
PHP-Code:
class=\"newthbutton\" 

muss es

PHP-Code:
class=\"button\" 

heissen. (Hast Du ja schon korrigiert)


Das passende Template findest Du in den Globale Templates, namens thankyoulike_postbit

Ersetze alles mit

Code:
<div class="label">{$lang->tyl_given}: {$post['tyl_unumtyls']}</div>

<div class="label">{$lang->tyl_rcvd}: {$post['tyl_unumrtyls']}</div>


Nochwas, diese Icons in den Buttons, werden vom IE und wahrscheinlich in weiteren Browsern, nicht erkannt !!
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
thankyoulike_postbit gibt es bei diesem Plugin nicht, ich glaube du verwechselst dasmit dem anderen Plugin ;-)
Zitieren
In Globale Templates->thanks_postbit_count
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
(31.08.2014, 21:27)MrBrechreiz schrieb: In Globale Templates->thanks_postbit_count

Danke, allerdings stimmt da noch etwas nicht, siehe hier:
   
Zitieren
Danke Jockel,

mir ist aufgefallen das Username "Danke" in der Mitte.

da wünsche ich ganz links anfangen.. 

wo kannst ich einstellen oder muss ich CSS Code wo ändern?

Hier Bild.
[attachment=10293]

da sollen alle UserName links  und nicht in der Mitte.
Zitieren