Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
alle Datumzeiten korrekt anpassen?
#1
Hallo zusammen!

Leider krieg ich es alleine nicht gebacken. Die Suche war bis auf einen Punkt, auf den ich später eingehe, nicht hilfreich.

Ich kriege es leider nicht hin, für alle die Zeit korrekt umzustellen, was doch irgendwie möglich sein muss.

Wenn ich nicht angemeldet bin, ist die Forumzszeit um eine Stunde vor geschoben. Logge ich mich ein, habe ich die korrekte Zeit. In der Benutzer-CP wie Admin-CP habe ich aber die gleichen Einstellungen vorgenommen. Standard-Zeitzone ist GMT+1:00 sowie die Sommerzeitkorrektur deaktiviert.

Warum sehe ich eingeloggt die korrekte und ausgeloggt die falsche Uhrzeit? Einziger Punkt, den ich bei der Suche gefunden habe, ist: Ich habe gelesen, dass die Forumzeit von der Serverzeit abhängig. Nur, wie kann ich denn die Serverzeit verändern? Oder muss das der Betreiber machen?

Falls ihr mir helfen könnt, die korrekten Einstellungen zu finden (und vielleicht auch eine, die alle Usereinstellungen zur Zeit neu überschreibt) würde ich mich wirklich sehr freuen.

Einen schönen Abend Euch noch.

PS: Falls es helfen sollte, die URL lautet forum.fc-blog.de

PPS: Momentan ist die Version 1.4.10 aufgespielt. Könnte es daran liegen?
#2
Wenn du die gleichen Einstellungen verwendest, wird auch die gleiche Zeit angezeigt. Mit der Serverzeit hat das nichts zu tun, da diese für alle Zeitausgaben herangezogen wird. Haben Änderungen im ACP Auswirkungen auf das Forum? Stelle bitte sicher, dass die Datei inc/settings.php beschreibbar ist und speichere die Einstellungen neu ab.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Guten Abend Michael,

doch noch wer wach. Wink Hmh, Hab spaßeshalber mal die Uhrzeit auf -10:00 gestellt in der ACP. Der speichert das zwar, die Uhrzeit ändert sich aber aus- wie eingeloggt nicht. Die Datei inc/settings ist mit dem Dateiattribut 644 gekennzeichnet. Sollte das eher auf 664 stehen?
#4
Das ist abhängig von der Serverkonfiguration. Versuche es mit 664 und dann 666.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Guten Abend nochmal!

Michael, ich danke Dir. Nun ist die Winterzeit fast vorbei und ich hab endlich die Uhrzeit richtig. Shy Es war die Teufelszahl 666.

Einzige Frage noch, in der ACP steht unter Einstellungen/Datums- und Zeitformat bei der GMT Zeit als Überrschrift "Hier können Sie die Zeitzone für Gäste und neue Mitglieder wählen." Könnte mir gut vorstellen, dass vielleicht der ein oder andere User manuell in seiner CP rumgespielt hat um die korrekte Zeit einzustellen. Gibt es die Möglichkeit, die Uhrzeiteinstellungen aller User einmal anzugleichen? Oder müsste ich über "Benutzer und Gruppen" mir jeden User einzeln ranholen und die Zeit manuell umstellen?
#6
Führe diese Abfrage in der Datenbank aus:
Code:
UPDATE mybb_users SET timezone = '+1';

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Guten Abnd nochmal,

tausend Dank Michael! Musste zwar kurz schwitzen, als ich Abfrage und Datenbank las, weil ich damit wirklich nichts am Hut hab, aber das Haussystem meines Providers hat dafür locker ausgereicht. Zum Test hab ich mich eingeloggt, übers normale CP die Zeitzzone verändert, die Abfrage ausgeführt und den Browser aktualisiert.

Nun stimmt alles! Wirklich vielen Dank für die Mühe und Zeit um diese Uhrzeit!


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Userüberprüfung wird bei der Anmeldung nicht korrekt ausgeführt Plexxart 8 1.640 19.02.2011, 22:44
Letzter Beitrag: Plexxart