Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.13 veröffentlicht (07.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Funktioniert MyBB mit MySQL-Cluster?
#11
Ok, ich habe diesen Text
FULLTEXT KEY `message` (`message`)
aus der Tabellenstruktur der Tabelle mybb_posts gelöscht.

Und "FULLTEXT KEY `subject` (`subject`)" aus mybb_threads.

Soweit funktioniert das auch. Jetzt erhalte ich aber einen anderen Fehler:
#1005 - Can't create table 'forum.mybb_usergroups' (errno: 708) (<a href="server_engines.php?engine=InnoDB&amp;page=Status&amp;token=6cbd8059dd7fead0d2244f8ee7fbbd14">Details ...</a>)

Da ich mit root-Rechten arbeite, wird es wohl nicht an fehlenden Rechten liegen?
Den Link aus der Fehlermeldung kann ich übrigens in der Dump-Datei nicht finden. Das "engine=InnoDB" irritiert mich nun allerdings schon etwas. Ist das ein von MySQL generiert Link oder gehört der zum MyBB. Für mich sieht das so aus, also würde versucht, das in die Datenbank einzufügen. Irre ich da?
#12
Das ist eine Fehlermeldung von InnoDB. Das das MyBB InnoDB nicht benutzt, muss es an deiner Konfiguration liegen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#13
(19.12.2010, 21:11)StefanT schrieb: Das ist eine Fehlermeldung von InnoDB. Das das MyBB InnoDB nicht benutzt, muss es an deiner Konfiguration liegen.

Das ist seltsam. Ich war mir eigentlich sicher, InnoDB wäre bei mir nicht installiert. Aber wenn ich mich recht entsinne ging der Datenimport bei der Bindung an einen Node ohne Probleme (habe ich gestern versehentlich mal gemacht). Ich tippe daher mal auf die Clusterengine als Fehlerursache. Was die intern macht, sehe ich ihr ja nicht unbedingt so einfach an. Und von Hand nur diese Tabelle zu importieren scheitert an der gleichen Fehlermeldung.

Ich sehe schon, das wird eine endlose Geschichte. Ich werde deshalb einen neuen Dump (mit der bewährten MyISAM-Engine) erstellen und die Datenbank des Forums an einen Cluster-Knoten binden. Das war zwar so nicht gedacht, aber dann funktioniert es wenigstens (und ich habe ja noch andere Datenbanken, die auch mit dem Cluster funktionieren ;-) ).

Trotzdem danke für eure Mühen und eure tatkräftige Hilfe bei der Fehlersuche.
So, Status-Meldung:

Es klappt. Big Grin

Es wird jetzt direkt ein Knoten des Datenbankclusters angesprochen. Der MySQL-Dump wurde unverändert vom alten Server übernommen (also mit MyISAM-Engine). Dadurch funktioniert das Cluster natürlich nur noch insoweit, dass die Datenbank zwar auf alle Knoten repliziert wird, nicht aber die Tabellen. Macht ja aber nix.

In diesem Sinne: Wöhliche Freihnachten aus dem tief verschneiten Baden-Württemberg. Toungue