Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Anmeldung über Subdomain und "richtigen" Pfad
#1
Moin,

ja ich habe bestätigt ich, dass ich die Suche benutzt und keine Antwort(en) auf meine Frage(n) gefunden habe, auch wenn es in der Tat schon solche Fragen und Antworten gab. Möchte eben sicherstellen, dass ich richtig liege (also bitte nciht hauen und wenn dann nicht so fest ^^):

Installation hat reibungslos geklappt (unter http://domain.tld/mybb) und das Benutzeranmelden funktioniert auch alles. Aber wenn ich nun eine Subdomain forum.domain.tld auf den Pfad http://domain.tld/mybb setze, dann können sich unter der Subdomain keine Benutzer anmelden (Nach der Anmeldung springt das Board auf die Anmeldeseite zurück).

Ändere ich nun den Cookiepfad von
Code:
/mybb/
auf
Code:
/
dann geht das Spiel andersrum. Ich kann mich nur über die Subdomain forum.domain.tld anmelden, aber nicht mehr über http://domain.tld/mybb (was für "Bestandsbenutzer ja auch doof ist).

Gibt es keinen Weg beides funktionsfähig zu haben? Oder muss ich wirklich das Board neu direkt im root installieren (ohne /mybb/) und die Daten übertragen? Dabei fällt mir gerade auch ein dritter Weg ein. Ich könnte automatisch von /mybb/ auf die Subdomain umleiten...

#2
Cookie Domain .domain.tld und Pfad / sollte für Domain und alle Subdomains und alle Pfade tun...

Wenn man an den Cookie-Einstellungen spielt ists auch überlegenswert, das Cookie-Prefix zu ändern, damit alte Cookies nicht mehr dazwischenfunken können. Es müssen sich dann aber alle User neu einloggen.
#3
Also das funktioniert irgendwie nicht. Wenn ich die Foren URL auf forum.domain.tld (von domain.tld/mybb) und den Pfad auf / (von /mybb/) ändere, dann funktioniert es unter der URL forum.domain.tld zwar, aber jeder der mit der alten URL "reinkommt" domain.tld/mybb bleibt angemeldet; er kann sich also gar nicht abmelden (man rutscht immer nach der Weiterleitung auf die Startseite und ist wieder angemeldet).

So ganz "idiotensicher" ist das nicht Big Grin
#4
Lösche deine Cookies...
(20.10.2010, 10:53)frostschutz schrieb: Cookie Domain .domain.tld und Pfad / sollte für Domain und alle Subdomains und alle Pfade tun...

Wenn man an den Cookie-Einstellungen spielt ists auch überlegenswert, das Cookie-Prefix zu ändern, damit alte Cookies nicht mehr dazwischenfunken können. Es müssen sich dann aber alle User neu einloggen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Umzug subdomain Christine 5 349 07.02.2015, 22:48
Letzter Beitrag: Christine
  ACP als subdomain wuschelkopp 10 735 31.05.2013, 19:26
Letzter Beitrag: frostschutz
Question Subdomain angelegt mit Forum dodo51 21 1.605 01.02.2012, 18:28
Letzter Beitrag: dodo51
  Weiterleitung nach Subdomain (/forum) funktioniert nicht richtig specops47 4 1.826 25.12.2011, 15:09
Letzter Beitrag: specops47
  Forum Steht in jeder Kategorien über der über schrift help McJump 5 2.067 23.02.2011, 17:04
Letzter Beitrag: ows