Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Variable für Avatar und Link gesucht
#1
Wink 
Huhu (:

Ich hab mal eine Frage...


Mein Ziel war es, in der online.php und in der online.php?action=today die Avatare der User in die erste Spalte einzufügen.
Getestet habe ich es erstmal an der 'Wer war heute online-Liste' in meinem Testforum.

Das ist mein derzeitiges Ergebnis:
   
Rolleyes

Mein Problem ist es, die richtige Variable für den Avatar zu finden.
Ich habe es schon mit {$mybb->user['avatar']} (wird immer der eigene Avatar angezeigt), {$post['useravatar']}, {$online['useravatar']}, {['useravatar']} und ['useravatar'] ausprobiert. Bei den letzten 4 zeigte er mir jeweils nichts an...

Mir gehen also nun so langsam die Ideen aus Toungue Kann mir villeicht jemand wie richtige Variable nennen?
Und villeicht auch, wie ich dann auch den Avatar verlinken kann, sodass man auf das dementsprechende Profil kommt?


Wäre sehr dankbar.
Liebe Grüße
Sternchen
[Bild: 326646.jpg]
Zitieren
#2
Versuchs mal mit $user['avatar'] Shy
Gruß NetHunter
Zitieren
#3
lol, habs ausprobiert. habe es so, wie du es gesagt hast, nun in das Template eingefügt.
Code:
<tr>
<td align="center" class="trow1" width="5%"><img src="$user['avatar']" /></td>
<td align="center" class="trow2" width="55%">{$online['profilelink']}{$invisiblemark}</td>
<td align="center" class="trow1" width="40%">{$onlinetime}</td>
</tr>
Sieht... spannend aus Big Grin
und er zeigt erst das:
Zitat:Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /var/www/web.../html/testforum/online.php(64) : eval()'d code on line 3

Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /var/www/web.../html/testforum/online.php(64) : eval()'d code on line 3
an und leitet dann weiter zum Forum, in dem er dann das Design nicht richtig anzeigt.

Also das mag er nich^^
[Bild: 326646.jpg]
Zitieren
#4
Du musst
Code:
{$user['avatar']}
einsetzen
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#5
funktioniert noch immer nicht Blush
Es wird nun wieder so angezeigt, wie oben beschrieben. Felder sind leer, Avatar wird nicht angezeigt Sad

Hm.. Shy
[Bild: 326646.jpg]
Zitieren
#6
Beitrag gelöscht, weil Käse Wink
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#7
lol, ich hab schon fleißig probiert & gegoogelt, funktionierte aber, wie du gerade ja gesagt hast, nicht Toungue
[Bild: 326646.jpg]
Zitieren
#8
schau mal da rein, vielleicht hilft es Dir weiter: http://forums.mybb-plugins.com/Thread-Ad...AND+avatar
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#9
damit kann man ja sowas hier einfügen:    

War zwar nicht so mein Ziel, doch nun gefällt es mir^^ ich glaub, das werd ich auch noch uns Forum einbauen Toungue

Hm... nun überlege ich, wie man es denn nun für die online.php umschreiben könnte.
Denn das ist ja schonmal ein guter Anfang Shy


Vielen Dank auf jeden Fall schonmal
[Bild: 326646.jpg]
Zitieren
#10
Hab mir mal die Online.php angeschaut, dort ist nichts mit Avatar definiert..

Also ohne Codeänderung wäre dies wohl nicht möglich
Zitieren