Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Variable für Avatar und Link gesucht
#11
Das habe ich mir auch gedacht Wink
in der online.php wird im normalfall ja auch kein Avatar aufgerufen, deshalb hatte ich es mit Template-Änderungen, wie oben beschrieben, schon versucht.

Mir ist es eigentlich auch egal, wenn es eine Änderung der php-Datei sein muss. Wenn ich weiß, wo ich was machen muss, geht das. (Hat sogar dann den vorteil, dass es gleich für alle meine Themes angewand wird Toungue)
Nur so kenn ich mich halt zu wenig mit php aus Shy
[Bild: 326646.jpg]
Zitieren
#12
Für "Wer war heute online" müsste es $online['avatar'] sein.

Für die aktuellen User suche in der online.php:
Code:
SELECT DISTINCT s.sid, s.ip, s.uid, s.time, s.location, u.username, s.nopermission, u.invisible, u.usergroup, u.displaygroup
Ersetzen durch
Code:
SELECT DISTINCT s.sid, s.ip, s.uid, s.time, s.location, u.username, s.nopermission, u.invisible, u.usergroup, u.displaygroup, u.avatar
Dann müsstest du $user['avatar'] verwenden können.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#13
Hm... Das klappt leider nicht Micha

er gibt auch keine Fehlermeldung raus

Edit:

Filezilla hats vergessen hochzuladen

Dennoch gehts nicht

Dort wo das Bild sein soll, erscheint bei mir nur "./uploads/avatars/avatar_1.jpg?dateline=1284299691"

Ich vermute mal das "." vor "/uploads" den Link unterbricht
Zitieren
#14
Du musst die Variable noch in ein img-Tag packen, so wie Scherbensternchen es bereits gemacht hatte.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#15
Hm...
Also ich hab die online.php nun genauso bearbeitet und mein Template online_today_rows sieht so aus:
Code:
<tr>
<td align="center" class="trow1" width="5%"><td align="center" class="trow1" width="5%"><img src="{$user['avatar']}" /></td>
<td align="center" class="trow2" width="55%">{$online['profilelink']}{$invisiblemark}</td>
<td align="center" class="trow1" width="40%">{$onlinetime}</td>
</tr>
online_today hab ich dementsprechend natürlich auch bearbeitet, sodass ich dann die 3.Zeile habe.


Aber: Noch immer ist die Zeile Leer, es wird nichts angezeigt.

Hab ich irgendwas falsch gemacht? Shy
[Bild: 326646.jpg]
Zitieren
#16
Der Teil
Code:
<td align="center" class="trow1" width="5%">
steht da doppelt, lösch den ein mal.
Vantage-Forum: http://vantage-forum.de/
Zitieren
#17
Hm. irgendwie hab ich es aus versehen falsch hierher kopiert... Blush
Bei mir steht es so:
Code:
<tr>
<td align="center" class="trow1" width="5%"><img src="{$user['avatar']}" /></td>
<td align="center" class="trow2" width="55%">{$online['profilelink']}{$invisiblemark}</td>
<td align="center" class="trow1" width="40%">{$onlinetime}</td>
</tr>
Aber wie gestagt, den Avatar sieht man trotzdem nicht Sad
[Bild: 326646.jpg]
Zitieren
#18
Kann ich bestätigen

habs auch so eingefügt

aber das gehört zum Plugin, oder besitzt MyBB "Wer war heute Online" Liste schon?

Dann bin ich falsch informiert, sonst heißt es wieder

> Die Datei des Plugins ändern
Zitieren
#19
(14.09.2010, 09:51)Michael schrieb: Für "Wer war heute online" müsste es $online['avatar'] sein.

viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#20
(14.09.2010, 18:41)Jockl schrieb:
(14.09.2010, 09:51)Michael schrieb: Für "Wer war heute online" müsste es $online['avatar'] sein.

Autsch..

Stimmt, danke Jockl, man übersieht wohl einiges wenn mans nur so klein dasteht Toungue
Zitieren