Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Kategorie-Icons
#1
Hallo, ich habe mir Foren-Icons gebastelt, wie im Thema
https://www.mybb.de/forum/thread-11166.html beschrieben.
Das hat für die Unterforen auch geklappt.
Nun nutze ich aber auch Unterkategorien, in denen stattdessen weiterhin das Status-Icon eingeblendet wird. Kann man den Kategorien auch individuelle Grafiken verpassen?
Schön wäre auch wenn beides angezeigt würde, also individuelle Foren-/Kategorie-Icons plus Statusicon.

So sieht mein Forum zur Zeit aus:
http://www.forum.sonett-archiv.com

Die doppelten icons stelle ich mir vor wie bei:
http://blauersalon.net/online-literaturforum/index.php

Das ist zwar ein phpbb-Forum aber das sollte doch auch hier möglich sein, oder?

Zudem stört mich, daß bei mir die Spaltenbeiten in den einzelnen Kategorien unterschiedlich sind obwohl die Icons gleich groß sind.

Ich hoffe ihr könnt mir helfen.

LG ZaunköniG
Zitieren
#2
Meinst du soetwas wie mit diesem Plugin:
https://www.mybb.de/forum/thread-22151.html
MyBBoard.de jetzt auf YouTube!
Fehlender Plan wird durch Wahnsinn ersetzt!!Toungue
Gruß Krafdi www.krafdi.de
Zitieren
#3
hallo krafdi,

Dies Plugin verspricht individuelle Status-Icons für einzelne Foren, wenn ich es richtig verstanden habe. Bei einem komplexen Forum braucht man aber viele viele Grafiken.
Ein Nebeneinander von gleichbleibenden Status-Icons und individuellem Bildchen fände ich für mein Forum zweckmäßiger: In der ersten Spalte das Status-Icon, in der zweiten das Individuelle Bild, in der dritten Spalte dann Foren-Name und Bescheibung ect.

Anscheinend betrifft dieses Plugin auch nur die Foren und Unterforen, nicht aber die Kategorien.
Ich möchte aber das Foren und Kategorien das gleiche Design haben, da sie teilweise auf der gleichen Ebene liegen.

LG ZaunköniG
Zitieren
#4
So, inzwischen hab ich selbst etwas herumgefrickelt.

Auf der Startseite sieht es schon ganz gut aus.
Auf den Foren der untersten Ebene auch.
Nur auf der mittleren Ebene, in Foren mit weiteren Unterforen sehen die Tabellen verheerend aus ?!?

Ein Beispiel fürs Gemeinte:
http://www.sonett-archiv.com/forum/forum...php?fid=19

Herumgebastelt habe ich an der

forumbit_depth1_cat

die jetzt so aussieht:

Zitat:<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<thead>
<tr>
<td class="thead" colspan="6">
<div class="expcolimage"><img src="{$theme['imgdir']}/{$expcolimage}" id="cat_{$forum['fid']}_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
<div><strong><a href="{$forum_url}">{$forum['name']}</a></strong><br /><div class="smalltext">{$forum['description']}</div></div>
</td>
</tr>
</thead>
<tbody style="{$expdisplay}" id="cat_{$forum['fid']}_e">
<tr>
<td class="tcat" colspan="3"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>
<td class="tcat" width="85" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_threads}</strong></span></td>
<td class="tcat" width="85" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_posts}</strong></span></td>
<td class="tcat" width="200" align="center"><span class="smalltext"><strong>{$lang->forumbit_lastpost}</strong></span></td>
</tr>
{$sub_forums}
</tbody>
</table>
<br />

an der

forumbit_depth2_cat:

Zitat:<tr>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" valign="top">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$subforums}</div>
</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</tr>

und an der

forumbit_depth2_forum

Zitat:<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" valign="top" style="width:85px;">
<div style="float:left;"><img src="{$theme['imgdir']}/{$forum_img}.gif" border="1" style="width:85px;"
alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" /><td class="{$bgcolor}" valign="top"><strong><a
href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div
class="smalltext">{$forum['description']}{$modlist}{$subforums}</div></td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</tr>
Zitieren
#5
Wenn ich das jetzt richtig verstanden habe möchtest du für jedes Forum ein individuelles Icon haben?

Schau dir mal folgendes Plugin an: http://www.mybbcentral.com/thread-2676.html

Das Plugin kannst du aber nur herunterladen wenn du "zahlender Kunde" bist. D.h. du musst dich dort registrieren und ein paar Dollar für eine Mitgliedschaft bezahlen um Plugins herunterladen zu können.

Zitat:To download our plugins you must be a paid member. Currently our rate is $10 for a lifetime membership.
Zitieren
#6
Danke Kenny,

Das Plugin selbst habe ich zwar nicht herunter geladen, aber die beschriebenen Template-Änderungen funktionieren auch für meinen Ansatz.

Bleibt nur eine Kleinigkeit:
Bei weitergeleiteten Foren wird statt des Icons nur ein Platzhalter (rotes X und Forenname) angezeigt.
Notfalls muß ich die beiden Links in einem normalen Thema posten, aber vielleicht gibt es auch eine elegantere Lösung.

LG ZaunköniG
Zitieren
#7
Hast du den Pfad für die Grafiken mal überprüft?

Beispiel Saul Tschernichowsky
Pfad der Grafik: http://www.sonett-archiv.com/forum/images/.gif

Fehlt da nicht ein Dateiname? Toungue
Zitieren
#8
Hallo Kenny,

Das ist aber ein schlechtes Beispiel, weil es bei dieser Rubrik funktioniert.
Wo hast Du den Pfad her?
Wenn ich mir per rechtem Mausklick die Eigenschaften der Grafik anschaue steht da auch ein Pfad.

Allerdings nicht bei "Sonett-Archiv" und "Edition Elf", eben den weitergeleiteten Foren.
Dort sieht der Pfad aus, wie du beschrieben hast.
Die Lösung mit der Variablen für individuelle Foren-Icons funktioniert eben nur bei "echten" Foren.
Da die Zieldomains auch eigene sind habe ich sogar versucht die Grafiken dort abzulegen, aber anscheinend wird der Pfad gar nicht vollständig generiert.

LG ZaunköniG
Zitieren
#9
(20.05.2010, 08:45)ZaunköniG schrieb: Hallo Kenny,

Das ist aber ein schlechtes Beispiel, weil es bei dieser Rubrik funktioniert.
Wo hast Du den Pfad her?
Wenn ich mir per rechtem Mausklick die Eigenschaften der Grafik anschaue steht da auch ein Pfad.

Stelle gerade fest, daß das Icon nur bei Usern angezeigt wird, die auch Leserechte im jeweiligen Forum haben.
Das Icon sollte allerdings jeder sehen, sonst könnte ich die Rubrik auch ganz verstecken...
Zitieren