Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Anbindung an phpmailer
#1
Hallo Zusammen

Auch wenn es schon mehrfach gerfagt wurde eine richtig Antwort hab ich noch nie gelesen

Ich habe den phpmailer auf meinem Webserver am laufen (Versand geht)
Wie bringe ich jetzt das Board dazu auch diesen PDF Mailer zu nutzen?
Zum Beispiel für die Autentifizierung oder auch den Mailversand der einzelnen Leute untereinander. Und wenn die Leute untereinander versenden möchte ich natürliuch nicht das immer der Absender des Boards angegeben wird.

Bitte helft mir und nicht nur die verlinungen auf die anderen Thema zu diesem Thema die hab ich alle durch da steht es nicht drin.

Habe Apache Webserver, PHP 5, und Mysql 5 am laufen. Der Server ist mein eigener also localhost und ist mit win 2003 server ausgestattet

Danke

Jörg
#2
In der Datei inc/functions.php findest du die Funktion "mymail", die für den Versand aller Mails zuständig ist. Diese musst du so umschreiben, dass das Skript phpmailer verwendet wird. Wie du diesen verwendest, findest du z.B. hier.

Was meinst du mit dem Versand der Personen untereinander? Meinst du den Versand einer Email an einen Benutzer über das entsprechende Formular im MyBB, also z.B. hier: https://www.mybb.de/forum/member.php?act...er&uid=495

Solltest du das meinen, hier werden der Name und die Email-Adresse des Benutzers verwendet.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
ja bestens vielen dank werde mich mal daran versuchen

Jörg
#4
Sad 
so ich hab mir das mal angesehen aber sorry damit komme ich gar nicht klar
gibts keine einfachere Lösung?? wie man mails über das board verschieken kann???????

#5
joebus schrieb:so ich hab mir das mal angesehen aber sorry damit komme ich gar nicht klar
gibts keine einfachere Lösung?? wie man mails über das board verschieken kann???????
Wo genau liegt denn das Problem? Mails lassen sich doch über das Forum verschicken.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#6
ich weiß nicht wo das Problem liegt. Der phpmailer verschickt mails aber aus dem Board kommt nichts. Vielleicht mache ich ja auch die falschen einstellungen in der php.ini. Ich kanns echt nicht sagen. Vielleicht kann mir mal eine schreiben was in die php.ini muß damit alles reibungslos geht. Ich komme damit wirklich nicht klar

Gruß

Jörg
#7
Da das MyBB die Standard PHP-Mail-Funktion verwendet, handelt es sich um einen üblichen Weg Emails zu versenden. Warum es bei dir nicht funktioniert, kann ich dir nicht sagen.

Wie du das Mail-System von PHP konfiguerierst, findest du z.B. hier.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
Also ich weiß nicht was es ist.

Ich habe die php.ini jetzt so bearbeitet das die einträge stimmen. wenn ich jetzt im Board eine Mail versende sagt er auch erfolgreich versendet aber es kommt nichts beim empfänger an. Ich dreh hier noch durch
ich habe als provider 1und1 und den auch für smtp eingetragen aber irgendwo bleiben die mails hängen aber ich weiß nicht wo. muss ich denn nicht auch ein Passwort für smtp verwenden? wenn ja wo soll ich das eintragen.
Oder hat jemand eine idee wie man den phpmailer zum laufen bringt. Ich meine das dieser für den ganzen mailverkehr aus dem board zuständig ist. Welche einstellungen müssen hierzu in der php.ini gemacht werden damit er diesen auch benutzt

Ich dreh noch durchSadSadSad
#9
jetzt hab ich den Fehler

die Autentifizierung bei 1und1 schlägt fehl deswegen kein versand möglich, aber wie kann ich das denn jetzt regeln da ich ja kein passwort oder so angeben kann in der php.ini.
Sorry für diese dämliche fragerei aber jeder fängt mal klein an

jörg
#10
Hallo joebus,

wenn es an der Authentifizierung liegt, bringt dich eine Anfrage beim Provider sicher weiter.

P.S.: Dämliche Fragen gibt es nicht! Smile
Gruß NetHunter