Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Database Script.
#11
Wie im Link fuktioniert nicht.

wenn ich es peer:

<iframe src="database2.php" width="100%" height="450px" border="0">
</iframe>

in das database teamplet einfüge, und ich dann die database.php aufrufe, wird die database zwar angezeigt, aber mit dicken rand runterrum, der nich twegzubekommen ist.

Also habe ich den Quelltext der der eigentlichen database also Database2.php in die database.php eingefügt. Die database wird nur angezeigt, wenn ich es so mache, und sieht dann so wie im Bild oben aus. Eine anderen varianten wird die Database garnicht angezeigt.

PHP-Code:
<?php

define
("KILL_GLOBALS"1); 
require 
"./global.php";
require 
"./inc/functions_post.php";

if(
$mybb->usergroup['canviewcalendar'] == "no")
{
    
nopermission();
}

/
Make navigation
addnav
($lang->nav_database"database.php");

eval(
"\$database = \"".$templates->get("database")."\";");
//outputpage($database);
//$plugins->run_hooks("database_end");

# hier hab ich den Quelltext der Database eingefügt#

outputpage($database);
//eval("\$database = \"".$templates->get("database")."\";");
$plugins->run_hooks("database_end");

?>[/code] 
Zitieren
#12
(23.02.2010, 21:08)Feiwel schrieb: Wie im Link fuktioniert nicht.
Was genau ist das Problem? Denn genau so sollte es gehen und auch das Anzeigeproblem lösen, da du die Ausgabe frei im Template positionieren kannst.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#13
Hallo Michael,

hab es nun so genacht, allerdings bekomme ich wenn ich die database.php aufrufe nur eine weisse seite. Berichtige mich, wenn ich es nicht richtig verstanden hab.

Habe nun 2 dateien.
1. database.php
2. database2.php ---hie rsteht der database code drin. (Dedatabase selbst)

So sieht meine Templet database aus.
PHP-Code:
<html>
<
head>
<
title>$settings[bbname] - $lang->database</title>
$headerinclude
</head>
<
body>
$header
<table>
<
tr>
$database2
</tr>
</
table>
</
span>
</
td>
</
form>
$footer
</body>
</
html

So sieht meine database.php
PHP-Code:
<?php

ob_start
();
include(
"database2.php");
$database2ob_get_contents();
ob_end_clean(); 

define("KILL_GLOBALS"1); 
require 
"./global.php";
require 
"./inc/functions_post.php";

// Load global language phrases
$lang->load("database");

if(
$mybb->usergroup['canviewdatabase'] == "no")
{
    
nopermission();
}

// Make navigation
addnav($lang->nav_database"database2.php");


eval(
"\$database = \"".$templates->get("database")."\";");
outputpage($database);
$plugins->run_hooks("database_end");
?>


Hat geklappt. hatte ein fehler in der database2.php der beim direkten aufrufen nicht auffiel.

Nun hätte ich noch gern, wo meinforumname / Database steht, wird ja hiermit erzeugt:

// Make navigation
addnav($lang->nav_database, "database.php");

das die database.php aufgerufen wird.
Zitieren
#14
(22.02.2010, 14:50)StefanT schrieb: Die verwendeten Codes sind veraltet und stammen wahrscheinlich von MyBB 1.0.
Der Code wird zwangsläufig Probleme machen. Die Variablen und Funktionen heißen anders und müssen teilweise anders verwendet werden. Im Template solltest du mit geschweiften Klammern um die Variablen arbeiten, $settings wurde durch $mybb->settings ersetzt. Der verwendete HTML-Code ist zudem unsinnig, da ganz andere Tags geschlossen werden, als geöffnet. Im PHP-Code stimmen die requires und das "no" nicht und nopermission und outputpage gibt es gar nicht mehr... Das einbauen des Hooks ist zudem unsinnig, da man dort nichts mehr machen kann.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#15
Genau, 1.04 da das 1.40 nicht vernümftig leuft, auf Debian und PHP 5x

Hatte testweise das 1.40 instaliert, und war absolut unzufrieden damit. Selbst das löschen der Dateien war problematisch, da ich keine rechte zum löschen hatte. Musste ich das ganze Serverseitig platt machen. Obwohl eine 2 database für das 1.40 vorhanden war, hat die instalation die tabellen von der 1.04 weggehauen, usw....

Ich auf alle fälle werde beim 1.04 bleiben und die paar Bugs werden nach und nach behoben.

Zu der database.php....... Anders lüft es aber nicht.

Da mann hier anscheinend auf ne einfache Frage keine vernümftige Antwort erhält, verabschiede ich mich hier, mit der Bitte an den Administrator, meine post zu löschen + meinem Nick + Mailadresse.
Zitieren
#16
(24.02.2010, 17:08)Feiwel schrieb: Genau, 1.04 da das 1.40 nicht vernümftig leuft, auf Debian und PHP 5x
Woher soll ich das denn wissen? Du hättest mich ja schon bei dem ersten Hinweis darauf aufmerksam machen können...
(24.02.2010, 17:08)Feiwel schrieb: Da mann hier anscheinend auf ne einfache Frage keine vernümftige Antwort erhält, verabschiede ich mich hier, mit der Bitte an den Administrator, meine post zu löschen + meinem Nick + Mailadresse.
Vielleicht liegt es an deinen Fragen. Zu deinem Script können wir dir kaum helfen...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren