Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Ungewollte Zeichen
#1
Nachdem mein Forum wieder geht tauchen aufeinmal ungewollte Zeichen auf.

Vor diesen Zeichen " & '
erscheint immer ein \
#2
https://www.mybb.de/forum/thread-15237-p...#pid108983
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Parse error: syntax error, unexpected T_VARIABLE, expecting T_FUNCTION in /data/multiserv/users/200291/projects/294451/www/Upload/inc/class_core.php on line 169


ein Versuch war es ja mal wert
#4
Warum erzeugen alle Fehler, wenn sie die paar Zeilen ändern? Du hast irgendetwas zu viel oder zu wenig entfernt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
das

// Determine Magic Quotes Status (< PHP 5.3)

muss ich auch entfernen, oder?
#6
Das ist egal, aber du hast irgendwo eine geschweifte Klammer übersehen. Poste mal deinen Code (ein paar Zeilen davor und danach).
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
PHP-Code:
                $this->ignore_clean_variables IGNORE_CLEAN_VARS;
            }
        }

        
// Determine Magic Quotes Status (< PHP 5.3)
        
if(version_compare(PHP_VERSION'5.3''<'))
        {
            if(
get_magic_quotes_gpc())
            {
                
$this->magicquotes 1;
                
$this->strip_slashes_array($_POST);
                
$this->strip_slashes_array($_GET);
                
$this->strip_slashes_array($_COOKIE);
            }
            
set_magic_quotes_runtime(0);
            @
ini_set("magic_quotes_gpc"0);
            @
ini_set("magic_quotes_runtime"0); 
        }
        
        
// Determine input
        
$this->parse_incoming($_GET);
        
$this->parse_incoming($_POST); 
#8
Du ist aber nichts geändert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
Achso dachte ich soll den alten Posten.

Nunja hab jetzt den zu ersetzenden Code neu eingefügt und jez kommt weder eine Fehlermeldung, und der Fehler scheint behoben zu sein. Warum so etwas immer erst beim 3en mal klappen muss Sad

Nunja danke für den support Wink
Thema damit erledigt


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Ungewollte Statistikanzeige Unbedarfter 6 1.304 19.12.2008, 13:23
Letzter Beitrag: Unbedarfter