Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Modnotice PM Benachrichtigung
#1
Hab ein Problem bei Modnotice - hab ne Benachrichtigung der User angestellt, die Links zu der Post sind jedoch falsch:

showthread.php?tid=12&pid=27#pid27

anstelle:

showthread.php?tid=12&pid=27#pid27

Wie kann ich das ändern?
[Bild: LFE-Banner.jpg]
Zitieren
#2
Hallo MH_Razen,

du könntest diese Version probieren.
http://community.mybboard.net/thread-503...#pid355299

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#3
perfekt - jetzt funktionierts erst recht nicht:

System: Dein Beitrag wurde von einem Moderator bearbeitet
An: Razen
Hallo %s,
Dein Beitrag wurde von einem Moderator bearbeitet.
Besuche deinen Beitrag hier -> http://%s/
[Bild: LFE-Banner.jpg]
Zitieren
#4
Hallo MH_Razen,

gehe bitte in die (Plugindatei) modnotice.php und suche die Funktion modnotice_send_pm() { ...
Ersetze sie mit

PHP-Code:
function modnotice_send_pm() {
    global 
$mybb$db$url$lang;

    if(isset(
$mybb->input['moderate']) && $mybb->input['moderate'] == 1) {
        require_once 
MYBB_ROOT."inc/functions_user.php";

        
$query $db->simple_select("posts""uid, username""pid='".intval($mybb->input['pid'])."'");
        
$user$db->fetch_array($query);

        
$lang->load('modnotice');

        if(
$mybb->settings['modnotice_pm'] == 1) {
            
$url $mybb->settings['bburl'].'/'.$url;
            
$url str_replace('&''&'$url);

            
$privatemessage = array(
                
'fromid' => 0,
                
'toid' => $user['uid'],
                
'uid' => $user['uid'],
                
'folder' => 1,
                
'subject' => $db->escape_string($lang->modnotice_PM_subject),
                
'icon' => 0,
                
'message' => $db->escape_string($lang->sprintf($lang->modnotice_PM_message$db->escape_string($user['username']), $db->escape_string($url) )),
                
'dateline' => TIME_NOW,
                
'status' => 0,
                
'includesig' => 0,
                
'smilieoff' => 0,
                
'receipt' => 0,
                
'readtime' => 0,
            );
            
$db->insert_query("privatemessages"$privatemessage);
            
update_pm_count($user['uid'], 7);
        }
    } 

Gehe bitte in die Sprachdatei modnotice.lang.php
Suche:
PHP-Code:
$l['modnotice_PM_message'] = "Hi {1},\n Your Post was edited by a moderator. He left a message for you.\n Visit your post here: [url]{2}[/url] "
Und ersetze mit:
PHP-Code:
$l['modnotice_PM_message'] = "Hi {1},\n Your Post was edited by a moderator. He left a message for you.\n Visit your post here: [url]{2}[/url] "

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#5
wow klasse, funktioniert!!!

Eine frage für ein forum wo ich das schon länge (mit bugs) anwende - muss ich theoretisch das plugin deaktivieren um die umsetzung zu bewirken oder reicht das reine ersetzen? habs im zweiten Forum mit Neuinstallation probiert...
[Bild: LFE-Banner.jpg]
Zitieren
#6
Um das Plugin zu aktualisieren muss dieses einmal de- bzw. reaktiviert werden.

Ggf. muss außerdem die Sprachdatei aktualisiert werden.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#7
gehen dann die bisherigen modnotizen verloren?
[Bild: LFE-Banner.jpg]
Zitieren
#8
Bei einer Neuinstallation gehen bisherige Moderatornachrichten verloren.
Wird das Plugin (wie oben beschrieben) reaktiviert, dann bleiben diese erhalten.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#9
Bei einem der Foren ging was schief, beim deaktivieren hat er quasi deinstalliert und die neuinstallation funzt einfach nicht:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1060 - Doppelter Spaltenname: 'modnotice'
Query:
ALTER TABLE `mybb_posts` ADD `modnotice` TEXT NOT NULL , ADD `modedituid` INT( 10 ) NOT NULL , ADD `modedittime` BIGINT( 30 ) DEFAULT '0' NOT NULL;

Hab schon in der Datenbank alles was ich mit modnotice gefunden hab gelöscht, was kann ich noch tun?
[Bild: LFE-Banner.jpg]
Zitieren
#10
Hallo MH_Razen,

die Fehlermeldung sagt aus, dass in der Tabelle posts die Spalte "modnotice" bereits existiert.

Folgende Felder werden durch das Plugin hinzugefügt:
PREFIX_usergroups:
  • cancreatemodnoticethread
  • cancreatemodnotice
PREFIX_moderators:
  • cancreatemodnoticethread
  • cancreatemodnotice
PREFIX_posts:
  • modnotice
  • modedituid
  • modedittime

Prüfe bitte ob diese Felder noch existieren und lösche sie aus der Datenbank. (Da du nun bereits Felder des Plugins geslöscht hast, ist dies der sinnvollste Weg.)

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Modnotice Garlant 6 1.284 03.07.2008, 07:13
Letzter Beitrag: Garlant
  Modnotice PorSche 5 1.111 18.07.2007, 18:52
Letzter Beitrag: ehorn