Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
img im vor der Forenname
#1
Guten Abend,

ich habe da ein Problem udn zwar.

Ich habe in mein Forum vor dem Forenname ein kleine Bildchen eingefügt,
in etwa so

Forum Sortierung Steuerungen
<img src="http://mystical.kilu.de/imghost/i/c5905db6fa61.gif" alt="" />Hier der Foren Name.

Dies wird auch aufen Index angezeigt.
Bloß Klickt man dann auf den Link,wo man dnn zu den Unterforen usw gelagt hat man über dem Forum ja die Navigationsleiste.

Die wie folgt dann leider aussieht:

Name .. / <img src="http://mystical.kilu.de/imghost/i/c5905db6fa61.gif" alt="" />Forum / Unterforum usw



Kann man dies noch irgendwie einstellen oder verbessern,das dieses Img auch hier angezeigt wird und nich nur der Code?


MFG Corle
Zitieren
#2
Ich weiß nicht genau was du meinst, aber versuche mal Folgendes:
Lade dein Gewünschtes bild z.b auf Directupload.de hoch -> Rechtsklick -> Grafikadresse Kopieren.
Dann; Admin-Cp -> Templades & Styles -> Dein Themen Name z.B Default (auf den Namen Klicken) -> Dann runterscrollen bist du auf das kommst:
Zitat: Logo
Wählen Sie die URL zum Logo des Forums für dieses Theme.
Und fügst die Grafikadresse ein.
Zitieren
#3
Hallo Corleone,

ersetze in der Datei "../inc/functions.php" (~Zeile 2889)
PHP-Code:
                $navbits[$navsize]['name'] = htmlspecialchars_uni($forumnav['name']); 
durch
PHP-Code:
                $navbits[$navsize]['name'] = "<img src=\"images/fid_".$forumnav['fid'].".gif\" alt=\"\" /> ".htmlspecialchars_uni(strip_tags($forumnav['name'])); 

Der jew. Grafikname muss dann "fid_X.gif" lauten ('X' durch die jew. Forum-ID ersetzen).
Zitieren
#4
Guten Tag sie meine bestimmt hier diese Zeile in der funktions.php.

* Resets the breadcrumb navigation to the first item, and clears the rest
*/
function reset_breadcrumb()
{
global $navbits;

$newnav[0]['name'] = $navbits[0]['name'];
$newnav[0]['url'] = $navbits[0]['url'];

unset($GLOBALS['navbits']);
$GLOBALS['navbits'] = $newnav;
}

was anderes is dort nicht enthalten.

udn einmal dies ,aber nich ihren Code.


$navsize = count($navbits);
$navbit = $navbits[$navsize-1];

   
Zitieren
#5
Ich meine die Zeile mit dem Code, den ich gepostet habe; die Zeilennr. bezieht sich auf die Datei "functions.php" in der Version MyBB 1.4.9.

Welche Version verwendest du?
Zitieren
#6
Ich benutze die neuste MyBB Foren Version.
EIn Bild was ich genau meine is oben mit dran gehangen.

Sry hatte es übersehn.
Habe es gefunden.

Aber es Funktioniert nich so ganz jetzt ist die Navigations leiste weg.
Zitieren
#7
Dann ist an deiner Änderung irgendetwas nicht i. O. >    
Zitieren
#8
Vielen Dank.Hat Alles Funktioniert.
Hatte ein Zeichen Vergessen.
Bloß jetzt kommt das Problem jetzt will er jedes Forum ein bildchen haben,dies soll ja nur beim Forum ,nicht bei jedem Unterforum auch noch.

Ich hatte ja den HTML Code inne Admin CP Foreneinstellung und vorm namen des gewünschten Forums

<img src="http://Bildchen.de/imghost/i/c92b30bd4151.gif" alt="" />Forum

jetzt hat man ja vorm Foren name das gewünschte Image.

Jetzt durch diesen Code will er ja bei jedem Forum eins ,dies ist aber falsch.
Nur im Uberforum.
Zitieren
#9
Zitat:...jetzt will er jedes Forum ein bildchen haben,dies soll ja nur beim Forum ,nicht bei jedem Unterforum auch noch.

Das kann ich nicht nachvollziehen...
   
Zitieren
#10
Nein,so war das nich gemeint,der will dann aber oben in der Navigation dann ein bildchen haben,nicht
im Forum selbst.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Umbruch zwischen minion/-off icon und Forenname verhindern GrosserBlonder 2 612 14.09.2007, 10:44
Letzter Beitrag: GrosserBlonder
  Männchen vor der Benutzernamen in der Wer ist Online anzeige... Crasher 5 896 21.10.2006, 16:01
Letzter Beitrag: ElkeK.