Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyCode, falsch verstanden?
#11
Jetzt gehts nicht, Loading....

Denke ihn bringt das $2 durcheinander.
#12
Die Ausgabe müsste aber stimmen. Aus dem Quelltext deines Forums:
Code:
<a class="aion-item-full-large" href="http://de.aiondatabase.com/item/155006350">text</a>

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#13
Ja, aber der Titel (...6350">text</a>) verwirrt ihn denk ich
Ich habs nochmal umgestellt:

Code:
<a class="aion-item-full-large" href="http://de.aiondatabase.com/item/$1">$1</a>

und

Code:
\[item\](.*?)\[/item\]

Aber es liegt am Titel, wenn ich html erlaube und ohne eintippe gehts....
#14
Wie Michael schon schrieb: der Code funktioniert.

Regulärer Ausdruck:
Code:
\[item=(.*?)\](.*?)\[/item\]

Ersetzung:
Code:
<a class="aion-item-full-large" href="http://de.aiondatabase.com/item/$1">$2</a>

Testwert:
Code:
[item=100900189]Grässliche Grausamkeit[/item]

Ergebnis (s. auch: Browser - Statusleiste):
Grässliche Grausamkeit
#15
Jaa!

Ich bitte vielmals um Entschuldigung!!

Ich bin in der Zeile verrutscht und habe eine Zahl eingefügt die es unter item nicht gibt Blush

SORRY!

Code:
\[item\](.*?)\[/item\]
Code:
<a class="aion-item-full-large" href="http://de.aiondatabase.com/item/$1"></a>

geht auch, nochmal sorry