Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Tutorial zur Themeerstellung (MyBB 1.2)
kimoo schrieb:Ich hab im admincp bereits umgestellt auf css nicht in der Datenbank speichern und der Cssordner besitzt auch die 777 Smile

Sobald Du die Speicherung des CSS-Mediums auf Ordner umgestellt hast, greifen die Änderungen am Theme, die Du über das Admin-CP machst, nicht mehr! Es werden dann nur noch die Einstellungen der ersten Box (Theme anpassen: xxxxxx) berücksichtigt!

Du musst deshalb die erstellte Datei im CSS-Ordner bearbeiten (runterladen -> bearbeiten -> hochladen).

Bei Dir z.Zt. also die http://www.sawasdee.at/mybb/css/theme_5.css.
 
The User, Formerly Known As "En-Gedi"
 
Super Smile Danke für die schnelle und kompetente Antwort.

Edit: brachte leider auch nicht den gewünschten effekt, mir kommts so vor als sei das theme ein mischmasch aus dem orig. theme der letzten version und dem theme (black rose) das ich mir runtergeladen habe. da das theme black rose nicht für die letzte version kompatibel ist habe ich bei der installation das ignorieren der kompatibilität eingschaltet, ist das vlt. der fehler?
en-gedi schrieb:Sobald Du die Speicherung des CSS-Mediums auf Ordner umgestellt hast, greifen die Änderungen am Theme, die Du über das Admin-CP machst, nicht mehr! Es werden dann nur noch die Einstellungen der ersten Box (Theme anpassen: xxxxxx) berücksichtigt!
Das ist Unsinn. Wenn du das Theme im ACP änderst, werden die Dateien sofort aktualisiert. Von Änderungen an den Dateien rate ich ab.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitat:Das ist Unsinn. Wenn du das Theme im ACP änderst, werden die Dateien sofort aktualisiert. Von Änderungen an den Dateien rate ich ab.

Nun, wie auch immer, ich habe jetzt wieder umgestellt und sichere jetzt wieder auf die datenbank, da die css bearbeitung leider auch nicht den gewünschten effekt erzielt hat.

es ist leider nach wie so das der footer bzw last menu immer noch den #efefef hintergrund hat, der teil wo die credits, links zu mybb Board.de etc. zu lesen sind hat einen schwarzen hintergrund und tw sind auch manche fonts in schwarz sodas nur ein teil zu lesen ist.
wie kann ich das theme editeren das es auch abspeichert oder geht das nur mit den codes die in blauer farbe dargestellt werden?
Ich nehme eher an, dass du die falsche Stelle bearbeitest.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Dragon schrieb:Das ist Unsinn. Wenn du das Theme im ACP änderst, werden die Dateien sofort aktualisiert ...

Ooops, sorry! Da hab´ ich auf die Schnelle was verwechselt. Ich bearbeite die CSS-Datei im Ordner und da werden dann die Änderungen nicht in Datenbank übernommen.




Dann versuch´ ich mal, meinen Fehler wieder "auszubügeln" Wink

Ich vermute, dass dieses Problem auch auf Dich zutrifft, da sich geänderte Werte nicht abspeichern lassen.

Die Schriftfarbe für das Copyright kannst Du übrigens unter "Zusätzliches CSS" ändern bzw. hinzufügen. Z.B.

PHP-Code:
#copyright {
    
font11px VerdanaArialSans-Serif;
    
color#FFF;
    
margin0;
    
padding10px 0 0 0;

 
The User, Formerly Known As "En-Gedi"
 
Dragon schrieb:Ich nehme eher an, dass du die falsche Stelle bearbeitest.

Gut, auch ok und welche wäre dann die Richtige?
Du musst #copyright im CSS definieren (siehe der Beitrag vor deinem).

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
danke das problem mit dem copyright ist im moment nicht so wichtig, wichtiger ist es das ich den footer und den rest hinbekomme, ich habe die css datei zwar editiert was allerdings nicht den gewollten effekt brachte.

es werden nach wie vor die dateien nicht abgespeichert, ich hab mal meinen provider bzgl dem suhosin patch angeschrieben, mal sehen was er mir morgen antwortet.
Das Problem mit dem Suhosinpatch verursacht, dass nicht alle Einstellungen gespeichert werden, d.h. die Felder sind im Admin-CP einfach leer. Ist das bei dir der Fall?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  cache problem bei themeerstellung nubi 8 881 13.10.2014, 21:29
Letzter Beitrag: nubi
  Tutorial zur Themeerstellung bei 1.8.x StefanT 4 4.127 16.09.2014, 20:07
Letzter Beitrag: StefanT
  Tutorial zur Themeerstellung bei 1.4.X & 1.6.X krafdi 4 27.774 29.10.2008, 21:14
Letzter Beitrag: krafdi