Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Installation bricht ab
#1
Hallo!

Kurioses Problem. Habe in der Suche zwar schon ein paar Dinge gefunden, allerdings trifft das hier leider alles nicht zu.

Hintergrund: 1 Server, bislang zwei Installationen von MyBB (damals 1.4.0, jetzt 1.4.2) unter zwei verschiedenen Domains, alles läuft problemlos. PHP 5.2.6, MySQL ist allerdings noch eine 4er.

3. Installation, wieder unter einer anderen Domain. Installationsassistent zeigt bei PHP XML-Erweiterung nichts an, nach Eingabe der DB-Daten passiert dann nichts. Interessant: XML-Erweiterung ist lt. phpinfo aktiv (libxml2-Version 2.6.32). Und wie gesagt: Auf dem Server laufen bereits 2 Installationen. Einziger Unterschied: Die anderen wurden damals als 1.4.0 installiert, diese eben als 1.4.2.

Hat jemand eine Idee, woran das liegen könnte?
#2
Das ist ein Bug im Zusammenhang mit MySQL 4. Öffne die Dateien db_mysql.php und db_mysqli.php im Ordner "inc" und suche in beiden die Zeile:
PHP-Code:
if($this_link && $this->get_version() < 4.1
Ersetzen durch:
PHP-Code:
if($this->link && $this->get_version() < 4.1

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Danke!
#4
Hallo zusammen,

leider sind bei mir die 2 Zeilen so ausgeführt wie oben beschrieben und trotzdem kommt nur die weiße Seite. Es laufen auf dem gleichen Server schon 2 Foren in der Version 1.4.

Kann mir jemand weiterhelfen, maile auch gerne noch weitere Daten zu.

Der Anbieter ist All-Incl.com

Vielen Dank im vorraus.
#5
Hallo Flogsc,

hast du Zugriff aud den Errorlog deines Accounts? Ggf. ist da der Grund zu finden.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#6
Hallo Garlant,

hab leider keinen Errorlog gefunden. Allerdings hab ich das Problem übergangen indem ich erst die Version 1.2.9 installiert und anschließend das ganze auf v1.4.2 Upgegradet habe. Aber wie es cheint ist es nicht nur ein Problem mit der v1.4.2, denn die v1.4 hat auch nicht funktioniert. Würde gerne noch weiterhelfen wenn ich kann.

MfG flogsc
#7
Habe das gleiche Problem. Die Info von Michael brachte leider keine Abhilfe.
#8
Welche PHP- und MySQL-Version sind auf dem Webspace verfügbar?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
PHP Version: 4.4.9
MySQL Version: 4.0.27

Edit: Im Server-Log findet sich auch kein Fehler.
#10
MySQL muss mindestens in Version 4.1 vorliegen, noch besser direkt 5. Die PHP-Version sollte auch dringend aktualisiert werden, da PHP4 nicht mehr mit Sicherheitsupdates versorgt wird.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Installation bricht nach Automatikk 3 1.028 19.12.2008, 08:07
Letzter Beitrag: Automatikk