Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.4.1 veröffentlicht
#1
MyBB 1.4.1 wurde veröffentlicht und steht ab sofort zum Herunterladen bereit. Es handelt sich um ein Sicherheits- und Wartungsupdate, das eine Sicherheitslücke mit mittlerem und eine mit geringem Risiko schließt.

Diese Sicherheitslücken betreffen MyBB 1.4.0 und ältere Versionen der 1.2er-Reihe. Ältere Versionen könnten ebenfalls betroffen sein. Ein Patch für MyBB 1.2.14 befindet sich weiter unten in dieser Ankündigung.

Informationen zum Update, zu Templateänderungen und zu Änderungen in den Sprachdateien befinden sich in den nächsten Beiträgen.

MyBB 1.4.0 zu 1.4.1 Patch
Der beigefügte Patch ist für Benutzer von MyBB 1.4.0. Sollte eine ältere Version eingesetzt werden ist das Gesamtpaket MyBB 1.4.1 herunterzuladen und ein Upgrade durchzuführen.

Lade das angefügte ZIP-Archiv herunter und entpacke es. Ersetze die Dateien auf dem Server mit den neuen aus dem Archiv.

.zip   mybb_1401_changed_files.zip (Größe: 631,5 KB / Downloads: 648)

Solltest du ein manuelles Update bevorzugen, lade die Datei mybb_1400_patches.txt herunter und folge den enthaltenen Anweisungen.

.txt   mybb_1400_patches.txt (Größe: 2,93 KB / Downloads: 493)

Für die Aktualisierung von MyBB 1.4.0 auf 1.4.1 ist die Ausführung des Upgradeskripts erforderlich, um die Standardtemplates zu aktualisieren. Beachte, dass durch das Einspielen des manuellen Patches nur die Sicherheitslücken mit mittlerem Risiko geschlossen werden. Solltet ihr euer Forum nicht sofort aktualisieren können, ist das eine temporäre Lösung. Wir empfehlen die Aktualisierung schnellstmöglich vorzunehmen.

Melden von Sicherheitsproblemen
Solltest du ein Sicherheitsproblem im Code des MyBB finden, poste dieses bitte NICHT im Forum. Melde das Problem stattdessen über das Kontaktformular oder per PN an ein Mitglied des Support-Teams.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#2
MyBB 1.2.14 Patch
Der beigefügte Patch ist für Benutzer von MyBB 1.2.14 oder ältere Versionen der 1.2er Serie.

Lade bitte die Datei mybb_1214_patches.txt herunter und folge den enthaltenen Anweisungen.

Wir empfehlen allen Benutzern, die noch die 1.2er Serie einsetzen ein Upgrade auf die aktuelle Version (1.4.1).


Angehängte Dateien
.txt   mybb_1214_patches.txt (Größe: 2,33 KB / Downloads: 389)

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Aktualisierung von MyBB 1.4.x
Bei der Aktualisierung gehen keine eigenen Themes, Plugins und Sprachpakete verloren.

Führt ein normales Upgrade durch.

Aktualisierung von vorigen Versionen
Bei der Aktualisierung gehen eigene Plugins und Sprachpakete verloren. Es wird versucht eigene Themes zu übernehmen.

Sichert vorher alle Dateien des Forums und die Datenbank! So kann das Forum im Notfall wiederhergestellt werden.

Führt ein normales Upgrade durch.

Geänderte Dateien seit MyBB 1.4.0
  • install/
    • index.php
    • resources/
      • language.lang.php
      • mybb_theme.xml
      • upgrade11.php
      • upgrade12.php
      • upgrade13.php
      • upgrade14.php
      • upgrade3.php
      • upgrade5.php
    • upgrade.php
  • jscripts/
    • editor.js
  • admin/
    • jscripts/
      • codepress/
        • codepress.js
    • modules/
      • config/
        • plugins.php
        • settings.php
      • forum/
        • management.php
      • home/
        • version_check.php
      • style/
        • templates.php
        • themes.php
      • tools/
        • backupdb.php
        • maillogs.php
      • user/
        • admin_permissions.php
        • banning.php
        • groups.php
        • mass_mail.php
        • titles.php
        • users.php
  • inc/
    • class_core.php
    • class_datacache.php
    • class_error.php
    • class_language.php
    • class_mailhandler.php
    • class_moderation.php
    • class_session.php
    • datahandlers/
      • post.php
      • user.php
    • db_mysql.php
    • db_mysqli.php
    • db_pgsql.php
    • db_sqlite2.php
    • db_sqlite3.php
    • functions.php
    • functions_forumlist.php
    • functions_image.php
    • functions_massmail.php
    • functions_modcp.php
    • functions_online.php
    • functions_task.php
    • functions_upload.php
    • init.php
    • languages/
      • english/
        • admin/
        • online.lang.php
        • search.lang.php
    • mailhandlers/
      • php.php
    • tasks/
      • massmail.php
  • announcements.php
  • attachment.php
  • calendar.php
  • captcha.php
  • css.php
  • editpost.php
  • forumdisplay.php
  • global.php
  • index.php
  • managegroup.php
  • member.php
  • memberlist.php
  • misc.php
  • modcp.php
  • moderation.php
  • newreply.php
  • newthread.php
  • online.php
  • polls.php
  • portal.php
  • printthread.php
  • private.php
  • ratethread.php
  • report.php
  • reputation.php
  • search.php
  • sendthread.php
  • showteam.php
  • showthread.php
  • stats.php
  • syndication.php
  • task.php
  • usercp.php
  • usercp2.php
  • warnings.php
  • xmlhttp.php
In rot markierten Dateien wurden Sicherheitslücken geschlossen. Diese Dateien müssen aktualisiert werden.
Grün markierte Dateien sind neu.
Grau markierte Dateien wurden entfernt.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#4
Theme- und Templateänderungen
Seit MyBB 1.4.0 haben sich die folgenden Templates geändert. "Rücksetzung erforderlich" bedeutet, dass dieses Template zurückgesetzt werden muss oder die Änderungen manuell in die Templates eingefügt werden müssen, damit MyBB 1.4.1 korrekt funktioniert. Ist eine Rücksetzung nicht erforderlich, stehen alle Funktionen auch ohne ein Update des Templates zur Verfügung.

Geht nach dem Ausführen des Upgradeskripts ins Admin-CP und sucht nach aktualisierten Templates. Setzt die gefundenen Templates zurück in den Originalzustand oder lasst euch die Änderungen anzeigen und fügt diese manuell ein.
  • search_results_threads_thread
  • usercp_subscriptions
  • modcp_announcements_new

Sprachpaketänderungen
Seit MyBB 1.4.0 wurden folgende Sprachdateien geändert:
  • online.lang.php
  • search.lang.php
  • admin/tools_maillogs.lang.php

Die deutschen Sprachpakete wurden aktualisiert und stehen in einer neuen Version zum Herunterladen bereit. Eine Aktualisierung ist empfehlenswert, da zudem viele Korrekturen vorgenommen wurden.

Plugins
Plugins aus MyBB 1.4.0 sollten auch unter 1.4.1 funktionieren.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Diskussion zur Ankündigung

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#6
Alle, die das Paket mit den geänderten Dateien oder das Komplettpaket für MyBB 1.4.1 vor diesem Beitrag heruntergeladen haben, dürften Probleme mit den Einstellungen im Admin-CP haben.

a) Einstellungsgruppen doppelt
Wenn ihr in der Konfiguration in eurem Admin-CP doppelte Einstellungsgruppen findet, die keine Einstellungen enthalten, ladet die folgende Datei herunter. Übertragt diese in den Ordner des Forums auf dem Server und ruft sie im Browser auf. Nach dem Durchlauf ist die Datei wieder zu entfernen. Beachte, dass bei dieser Lösung nur die Standardeinstellungen wiederhergestellt werden. Einstellungen, die von Plugins angelegt wurden, müssen durch die erneute Aktivierung des Plugins wieder eingefügt werden. Wenn du ein Backup der Datenbank von vor dem Upgrade besitzt, kannst du alle Einstellungen wiederherstellen (siehe Punkt b).

.php   1401_settinggroups_remove.php (Größe: 1,16 KB / Downloads: 353)

b) Einstellungsgruppen und Einstellungen verschwunden
Sind alle Einstellungen verschwunden, müssen diese in der Datenbank wiederhergestellt werden. Wenn du ein Backup der Datenbank von MyBB 1.4.0 hast, musst du die Datenbanktabellen präfix_settinggroups und präfix_settings zurückspielen. Wenn du Fragen dazu hast, kannst du dich gerne im Forum melden.

Wenn du kein Backup der Datenbank vorliegen hast, kannst du den Dump aus diesem Beitrag mit den Standardeinstellungen und Gruppen in die Datenbank importieren. Solltest du einen anderen Präfix als mybb_ verwenden, musst du diesen im Dump mit einem geeigneten Editor anpassen.

Beachte, dass bei dieser Lösung nur die Standardeinstellungen wiederhergestellt werden. Einstellungen, die von Plugins angelegt wurden, müssen durch die erneute Aktivierung des Plugins wieder eingefügt werden.

In beiden Fällen müsst ihr nach dem Einspielen des Backups anschließend ins Admin-CP -> Konfiguration -> Forum online/offline und die Einstellungen abspeichern. Dadurch werden diese aus der Datenbank auch wieder ins Dateisystem übernommen.

Wir bitten die Unannehmlichkeiten zu entschuldigen!

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren