Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Externer Login MyBB 1.4
#1
Hi,
hat sich von euch schon mit einem externen Login für die Version 1.4 beschäftigt?

Ich bräuchte ein Formular zum einloggen ohne weiterleitung auf eine andere Seite!
Und die Möglichkeit abzufragen ob die Person eingeloggt ist oder nicht.

Wenn sich damit schon jemand beschäftigt hat, bin ich seh dankbar Big Grin

mfg
brainkopf
Zitieren
#2
Dazu gibt es schon verschiedene Ansätze, die du über die Suche hier im Forum sicher findest. Die Codes für MyBB 1.2 können übernommen werden, da hat sich nichts geändert.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
schönen guten abend!

erst einmal ein lob an das forum - nette informationen für mybb einsteiger und php-neulinge Smile

nun zum thema:
könnte nicht jemand mal einen code für mybb 1.4 ins forum stellen, der
a) die möglichkeit gibt, sich einzuloggen und
b) wenn jemand eingelogged ist, z.b. die nachricht ausgibt "hallo user XXX"

ich habe nämlich selbiges problem, wie der herr vor mir:
unter mybb1.2 lief mein login noch!!!

hier der code:
Code:
<?php
if($mybb->user['uid'])
{
echo "Willkommen Benutzer X";
}
else
{
echo "
<form action='forum/member.php' method='post'>
  <input type='text' name='username'  /><br />
  Passwort:<br />
  <input type='password' name='password'  /><br />
  <input type='hidden' name='action' value='do_login' />
  <input type='hidden' name='url' value='../loginseite.php' />
  <input type='submit' class='submit' name='submit' value='Login'  />&nbsp;<a href='{$mybb->settings["bburl"]}/member.php?action=register'>Registrieren</a>
</form>
";
}

?>

mit dem update auf 1.4 will er sich jedoch nur noch mit meinem externen-login-code einloggen (was im forum auch geschieht) --> nur leider funktioniert es nicht mit dem "if($mybb->user['uid'])" d.h. es erscheint bei mir immer nur die loginform und nicht das "Willkommen Benutzer X" auf meiner externen seite (die in einem übergeordnetem verzeichnis liegt).

ich habe mir natürlich auch die anderen themen angeschaut und auch schon auf anderen foren nach einer lösung gesucht - leider ohne ergebnis. meine php kenntnisse sind nur begrenzt, also wäre es wirklich nett, wenn man mal einen funktionierenden "mybb1.4 externer login" posten könnte.

ich hoffe, dass ich jetzt keinen der herrschaften belästige - die geposteten anregungen haben mir leider nicht weitergeholfen. ich vermute, dass es an den cookies(?),sessions(?) liegt, kenne mich da aber nicht so gut aus (hat sich da was geändert von mybb1.2 zu1.4? werden die cookies anders ausgelesen?).

vorab schon einmal herzlichen dank!
ein verzweifelter user Smile

ps:
"<?php echo $mybb->user['uid'] ?>" gibt übrigens nur eine "0" aus und
"<?php echo $mybb->user['logoutkey'] ; ?>" nichts

und hier noch einmal der ganze code:
Code:
<?php
define("IN_MYBB", 1);
chdir('forum');
require './global.php';
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Seitenname</title>
</head>
<body>


<?php
if($mybb->user['uid'])
{
echo "Sie sind angemeldet";
}
else
{
echo "
<form action='forum/member.php' method='post'>
  <input type='text' name='username' /><br />
  Passwort:<br />
  <input type='password' name='password' /><br />
  <input type='hidden' name='action' value='do_login' />
  <input type='hidden' name='url' value='../loginseite.php' />
  <input type='submit' class='submit' name='submit' value='Login' />&nbsp;<a href='{$mybb->settings["bburl"]}/member.php?action=register'>Registrieren</a>
</form>
";
}

?>
</body>
</html>
Zitieren
#4
Code:
<form action="ForenURL/member.php" method="post">
<input type="hidden" name="action" value="do_login" />
<input type="hidden" name="url" value="ForenURL/index.php" />
<table border="0" cellspacing="1" cellpadding="4" class="tborder">
<tr>
<td class="thead" colspan="2"><span class="smalltext">Forum-Login</span></td>
</tr>
<tr>
<td class="trow1"><strong>Benutzername:</strong></td>
<td class="trow1"><input type="text" class="textbox" name="username" tabindex="1" /></td>
</tr>
<tr>
<td class="trow2"><strong>Passwort:</strong></td>

<td class="trow2"><input type="password" class="textbox" name="password" tabindex="2" /></td>
</tr>
<tr>
<td class="trow2" colspan="2"><span class="smalltext" style="float:right; padding-top:3px;"><a href="ForenURL/member.php?action=register">Registrierung?</a> | <a href="ForenURL/member.php?action=lostpw">Passwort vergessen?</a>&nbsp;</span>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<input type="submit" class="button" value="Logon" tabindex="3" /></td>
</tr>
</table>
</form>

So er ist getestet sollte funktionieren!
Dieser Code auf einer Externen Seite Einfügen!
... Fehler sind die wahre Perfektion.
Zitieren
#5
hi!
nicht falsch verstehen:
mein login funktioniert auch, nur das:
Code:
if($mybb->user['uid'])
{
echo "Willkommen Benutzer X";
}
else (...usw.
oder mit den worten vom ersten user:
Zitat:(...)Und die Möglichkeit abzufragen ob die Person eingeloggt ist oder nicht
...will nicht so recht! darum muss es wohl am cookie oder an der session liegen oder lieg ich da falsch?
wie muss der code dann lauten bzw. wie kann ich überprüfen, ob ein user nun eingelogged ist oder nicht?
Zitieren
#6
Der Code ist korrekt. Kannst du die ganze Datei zeigen?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
die ganze datei steht in meinem ersten post
Zitieren
#8
Wie lauten deine Cookie-Einstellungen (Domain und Pfad)?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#9
hi!

hier die daten zur cookieeinstellung:

Cookie-Domain: ".meinehp.de"
Cookie-Pfad: "/forum/"

(die seite mit dem login befindet sich allerdings im verzeichnis http://www.meinehp.de/indexmitlogin.php )

edit:

fehleranalyse: hallo! habe folgendes noch einmal getestet: der login funktioniert, wenn die login-datei im forumordner liegt. leider ist diese in einem höheren verzeichnis d.h. der cookiepath wurde dann wohl falsch angegeben:

myhp/login.php
und das forum myhp/forum/index.php

nur wie muss dieser dann lauten bzw. wenn ich ihn veränder funktioniert es wahrscheinlich nicht mehr mit dem forum-login. muss ich den cookie extra auslesen? wenn ja, wie muss dann der code lauten?
edit:
nun klappt es bei mir! es lag am cookiepfad (sorry: habe das hier schon oft im forum gelesen, aber tortz ausprobieren wollte es anfangs - warum auch immer - nicht funktionieren! nun habe ich in der datei forum/inc/settings den $settings['cookiepath'] von "/meinehp/forum" einfach auf "/meinehp/" gestellt und die cookies gelöscht Smile

danke noch einmal an die freundliche hilfe und entschuldigt meine (vermeintlich) dummen fragen Smile
Zitieren
#10
Wenn du die Cookie in einem höheren Verzeichnis benutzen willst, darfst du den Pfad natürlich nicht ins tiefere legen. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Problem externer Login torrywarez 10 2.307 13.08.2009, 13:28
Letzter Beitrag: Riccardo
  externer Login Frido 5 1.201 18.01.2009, 14:48
Letzter Beitrag: StefanT
  Externer Login im Header JF600 2 1.161 24.12.2008, 15:57
Letzter Beitrag: JF600
  [1.4] Externer Login Pokecamp 9 3.345 13.08.2008, 03:03
Letzter Beitrag: Michael
  Externer Login - Wie muss der aussehen!? SweetySchnuffel 8 2.460 28.06.2007, 19:16
Letzter Beitrag: smily