Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem beim Einloggen...
#1
Guten Abend,

habe auf einem Webhost myyboard erfolgreich installiert.

Nun habe ich versucht mybboard lokal zu installieren, für ein Intranet.
Dazu habe ich das Programm xammp verwendet.

Die gesamte Installation verlief ohne Probleme, auch kann ich mich im Administrationsbereich einloggen und Veränderungen durchführen, welche auch dauerhaft gespeichert werden.

Nur in dem Forum kann ich mich nicht einloggen, werde immer wieder auf die Forenstartseite geleitet.

Meine PHP Version ist PHP Version 5.2.5 (vom Prinzip gleich, wie auf meinem echten Wehost); mybboard Version ist aktuell...

Die F.A.Q. und die Suche habe ich schon um Hilfe gebeten und keine Lösung gefunden.

Cookie-Domain: .localhost
Cookie-Pfad: /mybboard/
Forum URL http://localhost/mybboard

Vielen Dank für Ihr/Euer Gedankengut

Christian
#2
Jamaica_sun schrieb:Cookie-Pfad: /mybboard/

Dort nur / eintragen.

ACP / Foreneinstellungen / Ändern / Allgemeine Konfiguration/ Cookie-Pfad

Sollte dann eigentlich gehen.
Gruß, Micha
=========
#3
Hallo Thai-Tiger ,

Danke für die Antwort,

/mybboard/ hatte ich aus den F.A.Q. entnommen,
habe jetzt den Pfad auf / geändert, aber leider funktioniert es noch nicht, ich werde wieder auf die Startseite weitergeleitet.

Gruß Christian

mybboard
http://localhost/mybboard/

$config['dbtype'] = 'mysql';
$config['hostname'] = 'localhost';
$config['username'] = 'root';
$config['password'] = '**';
$config['database'] = 'mybboard';
$config['table_prefix'] = 'mybboard';

Forum Name: Forums
Forum URL (No trailing slash): http://localhost/mybboard
Website Name: Your Website
Website URL: http://localhost/
Cookie-Domain: .localhost
Cookie-Pfad: /
#4
Hi Christian,

wird Dein Forum auch mit http://localhost aufgerufen?

Denn ich habe mal gesucht hier im Forum und da heisst es immer das die Cookie-Domain nicht stimmte. Geh mal hier in die Suche und suche nach "Login" oder "Einloggen". Das Problem hatten schon viele Leute. Allerdings nicht auf einen eigenen Webserver.

https://www.mybb.de/forum/search.php
Gruß, Micha
=========
#5
Hallo Thai-Tiger,

habe ja schon alles erdenkliche an cookie probiert, auch den Einstellungsgeneratur in F.A.Q. und fast alle Fragen durch zum Thema einloggen über die Funktion "Suchen" im Forum...

Oder lässt sich mybboard nicht lokal ausführen, wäre ja auch eine Möglichkeit...

Gruß Christian
#6
Lies mal den Beitrag von en-gedi: https://www.mybb.de/forum/showthread.php...7#pid67317

Probiere mal so:

Cookie-Domain:
Cookie-Pfad: /
Gruß, Micha
=========
#7
Also ich habe das auch erst vor ein paar Tagen mal wieder auf Xampp installiert.

Aufruf des Forums über http://localhost/forum

In meiner settings.php steht:
Code:
$settings['bburl'] = "/forum";
$settings['cookiedomain'] = "";
$settings['cookiepath'] = "/forum/";
Mit diesen Einstellungen klappt es prima.
viele Grüße
Jockl
übersetzte und eigene Plugins
#8
Jockl schrieb:Aufruf des Forums über http://localhost/forum

In meiner settings.php steht:
Code:
$settings['bburl'] = "/forum";
$settings['cookiedomain'] = "";
$settings['cookiepath'] = "/forum/";
Mit diesen Einstellungen klappt es prima.

Dann wäre in seinem Fall diese Einstellung richtig:

Code:
$settings['bburl'] = "/";
$settings['cookiedomain'] = "";
$settings['cookiepath'] = "/";
Gruß, Micha
=========
#9
Vielen Dank Thai-Tiger,

das war der 100 %tige Treffer, bei der lokalen Installation mit xammp muss keine Cookie-Domain angegeben werden aber der Cookie Pfad /

Statt zu tüfteln, welche es denn nun sein wird, war dass natürlich die Lösung, die ich am wenigsten vermutet hätte.

Danke schön und das mybboard auch lokal lauffähig ist, find ich bärenstark, mal nebenbei erwähnt...

Gruß Christian